• Global community
    • Language:
      • Deutsch
      • English
      • Español
      • Français
      • Português
  • 日本語コミュニティ
    Dedicated community for Japanese speakers
  • 한국 커뮤니티
    Dedicated community for Korean speakers

Xliff translation custom XTS file

New Here ,
Jun 19, 2022 Jun 19, 2022

Copy link to clipboard

Copied

Hi Everyone,

I have some questions regarding "g" element level tags. How do I modify the translation XTS file to remove the following? 

<g translate="no" id="ID0EYX3O" />, where the "id" could be any value.
My translation provider has flagged the <g translate="no" id="........." /> string as being incorrect.
Example below

 

<trans-unit resname="p[Bullet]" restype="x-paragraph" id="ID0EL3DQ">
<source xml:space="preserve" xml:lang="en-US">
<g translate="no" id="ID0ET3DQ" />The charger is for indoor use only. Do not use outdoors.</source>
</trans-unit>

 

I have noticed the application of  <g translate="no" id="........." />  seems to be related to paragraph styles that include bullet points etc. But it also seems to apply some what randomly as in the example below which contains no bullet points or character formatting.

 

<trans-unit resname="p[Body]" restype="x-paragraph" id="ID0EZYDQ">
<source xml:space="preserve" xml:lang="en-US">
<g translate="no" id="ID0EGZDQ" />Be sure to charge the battery fully before using it for the first time or after not using it for long periods.</source>
</trans-unit>​

 

Any help you could provide would be appreciated.

Thanks,

Liam

 

 

 

 
 
 

 

 

Views

100

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 23, 2022 Jun 23, 2022

Copy link to clipboard

Copied

Hi,

 

According to this discussion the attribute is correct:

https://github.com/vslavik/poedit/issues/586

How did you get this attribute? Do you have a symbol font or language None?

What does your translation provider actually say? Why is this not correct?

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

Hi Winfried,

 

Thanks for your response and sorry for the late reply. The linked discussion talks about applying the "translation=no" attribute to a "trans-unit" not a <g> sub-element.

 

To answer your questions:

The <g translate="no" id="ID0EGZDQ" /> attribute is automatically applied by FrameMaker.

The paragraph format language is set to English (US).

 

From our translation provider "Several strings are marked as translate=”no”. This flag is normally used to mark strings which are out of scope. However in the files provided, this flag is present on unusual place. Being more specific – it’s at “g” element level, while it should be at “trans-unit” level" and "In other words: entire “trans-unit” need to be flagged instead of sub-elements for flag to work. As a result, the flag is not correctly processed by our tools and content is not excluded."

 

Can I edit the XTS file to exclude "translate=no" from sub-elements?

 

Regards,

Liam

 

 

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Expert ,
Jun 28, 2022 Jun 28, 2022

Copy link to clipboard

Copied

Hi Liam,

 

When you manually change this attribute to "yes", make a test, whether you can still import the changed XLIFF file.

Also make some changes to the text and see, if the import still works.

 

Did you check the paragraphs which have this attribute set to "no"? When your translation provider says that there are unusual places, then check this in your document! Do these paragraphs have a language set? The language of your other paragraphs? Or a different language or no language at all?

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jun 30, 2022 Jun 30, 2022

Copy link to clipboard

Copied

Hi Winfried,

I shall try manually changing the attribute to "yes" and making changes to the text and try importing and see if the import works.

There doesn't seem to be a common theme regarding which paragraphs have the attribute set to "no".

I'll check the paragraphs and double check their language, by default they should be set to English (US).

 

I was hoping someone from Adobe would be able to chime in and provide a solution regarding modifying the translation XTS files in some way.

Regards,

Liam

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Jul 07, 2022 Jul 07, 2022

Copy link to clipboard

Copied

LATEST

Hi Winfried,

 

After some futher investigation and experimentation, it appears the <g translate="no" id="........." /> tag is used to maintain autonumbering formats in FrameMaker. This is why it appears before the text to be translated rather than at the "trans-unit" level. It also appears before bullet points, numbered lists etc.

 

Example: 

LiamF_0-1657243014205.png

<trans-unit resname="p[Numbered1]" restype="x-paragraph" id="ID0EE1DO">
<source xml:space="preserve" xml:lang="en-US">
	<g translate="no" id="ID0EM1DO" />Numbered1 (paragraph format) - use to start a numbered list at 1.
</source>
<seg-source xml:space="preserve">
	<g translate="no" id="ID0EM1DO" />
    <mrk mtype="seg" mid="34">Numbered1 (paragraph format) - use to start a numbered list at 1.</mrk>
</seg-source>
</trans-unit>

 

I have asked my translation provider to ignore these "g" tags and hopefully when I receive my translated files, the autonumbering remains intact.

 

Thanks,

Liam

Likes

Translate

Translate

Report

Report
Community guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines