Highlighted

2015 FDK debug libs

New Here ,
Apr 14, 2016

Copy link to clipboard

Copied

FM 11 to FM 2015. Skipped 12. FDK 11 included debug versions of libs, FDK 2015 does not. Unable to build debug apiclients unless you have workaround for lnk2038 problem. Can we get debug libs for 2015?

Views

369

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

2015 FDK debug libs

New Here ,
Apr 14, 2016

Copy link to clipboard

Copied

FM 11 to FM 2015. Skipped 12. FDK 11 included debug versions of libs, FDK 2015 does not. Unable to build debug apiclients unless you have workaround for lnk2038 problem. Can we get debug libs for 2015?

Views

370

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 14, 2016 0
Mentor ,
Apr 15, 2016

Copy link to clipboard

Copied

Can you elaborate? I don't have any problem building debug DLLs with the current libraries. Remind me, what is the lnk2038 problem?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 15, 2016 0
New Here ,
Apr 20, 2016

Copy link to clipboard

Copied

error LNK2038: mismatch detected for '_ITERATOR_DEBUG_LEVEL': value '2' doesn't match value '0'…

The link error results from linking my debug apiclients with non-debug versions of fdk.lib etc.

I was able to get things to link for the debug target by using the following preprocessor directive:

     _ITERATOR_DEBUG_LEVEL=0

But when actually trying to debug my apiclient I get all sorts of strange results, which makes it impossible to debug.

We are using the STL extensively.

The Frame 11 FDK did include debug versions of the libs, and we skipped Frame 12 so I never saw its FDK.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 20, 2016 0
Mentor ,
Apr 21, 2016

Copy link to clipboard

Copied

hovernut,

I don't know the answer. You might consider posting this to the Frame development forum on Yahoo. The technical expertise on raw programming matters is much stronger there:

https://groups.yahoo.com/neo/groups/Frame_dev/info

Russ

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2016 0
New Here ,
Apr 21, 2016

Copy link to clipboard

Copied

Thanks for the reply Russ but the forums will be no help.

The answer is simple: provide debug versions of the fdk libraries, as they were in the Frame 11 FDK.

We're not going to rewrite almost 20 years of Frame apiclients using C++/STL just to get around this.

To whom can we elevate this issue to get it resolved as quickly as possible?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2016 0
Adobe Community Professional ,
Apr 21, 2016

Copy link to clipboard

Copied

You could try pinging the FM engineers – remember, this place is primarily a user-to-user forum.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2016 0
New Here ,
Apr 21, 2016

Copy link to clipboard

Copied

Thanks Jeff, will do. Just thought we would start here.

You wouldn't by any chance have any information on how to use the new SVG Export filter for Frame 2015 would you?

We are very interested here at Boeing in seeing how it works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2016 0
Mentor ,
Apr 21, 2016

Copy link to clipboard

Copied

hovernut,

I think the problem is in your IDE configuration, which corresponds to the lack of good documentation on how to configure the IDE. I work extensively with the FDK in FM2015 and have no issues with build errors or the debugger. But, I don't have any way to help you figure out what the problem is. That's why I suggested the other forum... there are numerous developers over there with a deeper knowledge of IDE setup. They have saved me on multiple occasions.

Assistance directly from Adobe is uncommon, but not impossible, I suppose.

Russ

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2016 0
Adobe Community Professional ,
Apr 21, 2016

Copy link to clipboard

Copied

Sorry, not in the slightest – my whole feeling about this thread is that it’s in the wrong forum to begin with ;>)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 21, 2016 0