Highlighted

Apply Master Pages in a book crashes if no rows in the MasterPageMaps table match

Adobe Community Professional ,
Jan 12, 2016

Copy link to clipboard

Copied

FM 2015 (version 13.0.2.422) crashes when applying master pages in a book when the book contains a document that has no content matching a row in the MasterPageMaps table. The crash does not occur in version 13.0.1.385. The earlier version opens a log file with the confusing message "No master pages applied because the MasterPageMaps table contains no mapping information." This message appears if the table contains mapping information, but a document in the book happens not to use any of the indicated elements or paragraphs.

       --Lynne

Views

366

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Apply Master Pages in a book crashes if no rows in the MasterPageMaps table match

Adobe Community Professional ,
Jan 12, 2016

Copy link to clipboard

Copied

FM 2015 (version 13.0.2.422) crashes when applying master pages in a book when the book contains a document that has no content matching a row in the MasterPageMaps table. The crash does not occur in version 13.0.1.385. The earlier version opens a log file with the confusing message "No master pages applied because the MasterPageMaps table contains no mapping information." This message appears if the table contains mapping information, but a document in the book happens not to use any of the indicated elements or paragraphs.

       --Lynne

Views

367

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 12, 2016 0
Adobe Community Professional ,
Jan 14, 2016

Copy link to clipboard

Copied

My analysis of this issue was way off.

First, the crash occurred not in actually applying master pages, but in the attempt to open a book error log to report that the command happened not to apply any master pages. I tested another situation that results in a book error log and that one crashed as well. Meanwhile, I spoke with several people who were unable to reproduce the crashes.

Second, TCS tech support gave me a workaround. There is a Windows display setting for custom scaling. The recommended setting for my high resolution monitor is 200%. When it is higher than 150%, FM crashes. I may need to use a magnifying glass to work, but at least I have the option of changing the display setting depending on what I am doing.

          --Lynne

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2016 0
Adobe Community Professional ,
Jan 14, 2016

Copy link to clipboard

Copied

You can also control how FM launches by editing the shortcut – there’s a flag for high resolution display monitors in there that allows you to change the Windows settings to be higher without FM going all sideways.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2016 0
Adobe Employee ,
Jan 14, 2016

Copy link to clipboard

Copied

Interesting … I'm running FM on a MacBook Pro with Retina Display, and Windows 10 is set to 175%. However, I have excluded FrameMaker from scaling and therefore did not run into the crash. But good to know about this and making FrameMaker compatible with extreme high dpi screens is a top priority.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2016 0
Adobe Community Professional ,
Jan 14, 2016

Copy link to clipboard

Copied

Just had a look at my FM12 shortcut – on the Compatibility tab, there’s a “Disable display scaling on high DPI settings” field. That’s allowing me to run at 150%.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2016 0
Adobe Community Professional ,
Jan 14, 2016

Copy link to clipboard

Copied

Jeff, Stefan,

   Thanks for your comments.

   Disable display scaling on high DPI settings does not affect this crash.

   I tried setting the scaling to 175% and still crashed.150% seems to be the maximum number I can use to avoid the crash.

   Is there a way to change the scaling only for 2015? Jeff, what are the flags I can set in the shortcut?

            --Lynne

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 14, 2016 0
Adobe Community Professional ,
Jan 15, 2016

Copy link to clipboard

Copied

See my previous post about modifying the shortcut; but it sounds like you’ve already got that turned on & it had no impact at a higher % setting.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 15, 2016 0