Highlighted

Autonumber Format Help

New Here ,
May 25, 2017

Copy link to clipboard

Copied

For reference, I'm working in a table, maybe that has something to do with it.

The autonumbering format is working fine, but somewhere in the middle, it just stops working. I'm using the formula: A:< >< >< >< >< >< >< >< >< >< ><n+>.< =0>< >< >\t (yes I understand it's long, even getting rid of "the fat" it still won't work correctly). What it does is instead of 1,2,3 etc. it's just all 1's. Even when I use a+ instead of n+ it's just all a's. The formula is the EXACT same throughout the entire table, but it just doesn't work.

Getting rid of the "A:" works BUT I need it. For example:

My table will have different sections so it'll say:

Title

1. Info

2. Info

3. Info

Another Title

1. Info

2. Info

3. Info

I can't have the numbering to continue for it to be through 6, it has to start over WITHIN the one table. Therefore I'll tag the title to have "A:" in it, that seems to do the trick to reset the numbers after the titles.

Now that you know that, I can't take out the "A:" in my formula to number, because then it just connects ALL of it and I'll go up to number 50, when it just needs to have 3 or 4 here and there.

Views

209

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Autonumber Format Help

New Here ,
May 25, 2017

Copy link to clipboard

Copied

For reference, I'm working in a table, maybe that has something to do with it.

The autonumbering format is working fine, but somewhere in the middle, it just stops working. I'm using the formula: A:< >< >< >< >< >< >< >< >< >< ><n+>.< =0>< >< >\t (yes I understand it's long, even getting rid of "the fat" it still won't work correctly). What it does is instead of 1,2,3 etc. it's just all 1's. Even when I use a+ instead of n+ it's just all a's. The formula is the EXACT same throughout the entire table, but it just doesn't work.

Getting rid of the "A:" works BUT I need it. For example:

My table will have different sections so it'll say:

Title

1. Info

2. Info

3. Info

Another Title

1. Info

2. Info

3. Info

I can't have the numbering to continue for it to be through 6, it has to start over WITHIN the one table. Therefore I'll tag the title to have "A:" in it, that seems to do the trick to reset the numbers after the titles.

Now that you know that, I can't take out the "A:" in my formula to number, because then it just connects ALL of it and I'll go up to number 50, when it just needs to have 3 or 4 here and there.

Views

210

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
May 25, 2017 0
Adobe Community Professional ,
May 25, 2017

Copy link to clipboard

Copied

Let's simplify this question: are you asking how to number the cells in a table to look the like image below? After a title, the numbers should reset to 1?

VMware Fusionss_001.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 25, 2017 0
Adobe Community Professional ,
May 26, 2017

Copy link to clipboard

Copied

It looks like all numbering within your chapter is in this string.

Try breaking up into separate series for connected content.

If the numbering is only within tables, I suggest creating a new series (perhaps T:) and setting only the autonumbers and reset codes for those tags within the tables.

Likewise, figures and titles would get their own series, and volumes, chapters, sections, and subsections can use the appropriate variables, rather than creating one long string to control everything.

FrameMaker - Working with Content explains it all in greater detail.

-Matt

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 26, 2017 0
Community Beginner ,
Aug 16, 2017

Copy link to clipboard

Copied

The way that the company I work for worked around this is to create two (2) paragraph tags.

In the first one (i.e. L:List1First) you have A:<n=1>.\t, and in the second one (i.e. L:List1Next) you have A:<n+>.\t.

The way this would look as tags would be like this:

Paragraph tag     |        Output

H:Head1              |        Title A

L:List1First          |        1.   info

L:List1Next          |        2.   info

L:List1Next          |        3.   info

H:Head1              |        Title B

L:List1First          |        1.   info

L:List1Next          |        2.   info

L:List1Next          |        3.   info

I hope that the way I explained how we worked around this problem helps.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 16, 2017 1
Adobe Community Professional ,
Aug 19, 2017

Copy link to clipboard

Copied

In your example, the autonumbering for the Title paragraph tag needs to have the 11th set of brackets changed from < > to < =0>

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 19, 2017 0