Highlighted

Autosave doesn't appear to work in FM 2019

Explorer ,
Sep 07, 2018

Copy link to clipboard

Copied

I have enabled the Auto Save option in the General section of preferences and set it to save every 2 minutes. However, there are no auto saved files being created. In FM 2017 they would appear in the same directory as the .fm and backup files but there don't seem to be any files created in FM2019. Are they being saved somewhere else or is this function not working correctly?

Hi Barb,

I've installed the update and it does appear to have fixed the issue. I am able to use all my workspaces and so far the auto files have been generating in the background they way they should.

Knowing that there should always be a snapshot of my open files no more than a couple of minutes old certainly puts my mind at ease, as having to work in a virtual machine does occasionally lead to unexpected situations where the only way out is to reboot!

Cheers,

Bob.

Views

905

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Autosave doesn't appear to work in FM 2019

Explorer ,
Sep 07, 2018

Copy link to clipboard

Copied

I have enabled the Auto Save option in the General section of preferences and set it to save every 2 minutes. However, there are no auto saved files being created. In FM 2017 they would appear in the same directory as the .fm and backup files but there don't seem to be any files created in FM2019. Are they being saved somewhere else or is this function not working correctly?

Hi Barb,

I've installed the update and it does appear to have fixed the issue. I am able to use all my workspaces and so far the auto files have been generating in the background they way they should.

Knowing that there should always be a snapshot of my open files no more than a couple of minutes old certainly puts my mind at ease, as having to work in a virtual machine does occasionally lead to unexpected situations where the only way out is to reboot!

Cheers,

Bob.

Views

906

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 07, 2018 0
Adobe Community Professional ,
Sep 07, 2018

Copy link to clipboard

Copied

Auto-save files are saved in the same folder as the document you are working on. Note that they delete themselves when you save your work. They are also deleted when you close the file. Is that what is going on?

I just realized I tested this on 2017. I need to get to the office to test on 2019. If this is a bug, hopefully someone else can help in the meantime. Otherwise, I'll be back in a bit.

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2018 0
Adobe Community Professional ,
Sep 07, 2018

Copy link to clipboard

Copied

You getting that in FM2019 BarbBinder​? IIRC, there was a bug reported in the beta about autosave not working, but it might be fixed already.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2018 0
Adobe Community Professional ,
Sep 07, 2018

Copy link to clipboard

Copied

No, Jeff, I tested it on 2017... 2019 isn't on this computer.  I'll be able to test on 2019 in about half hour.

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2018 0
Adobe Employee ,
Sep 07, 2018

Copy link to clipboard

Copied

The bug report was pulled back by the person who had filed it in. The problem was on the user machine with an incompatible plugin as far as I remember.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2018 0
Explorer ,
Sep 07, 2018

Copy link to clipboard

Copied

Hi Stefan. I just noticed your comment about Auto Save possibly not working if there is an incompatible plugin installed. Do you have more details? As far as I know I do not have any plugins installed (apart from any which may get installed as part of the standard FM installer).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2018 0
Explorer ,
Sep 14, 2018

Copy link to clipboard

Copied

After removing and re-installing FM 2019 the autosave worked as expected. However, when I subsequently copied back in my custom workspaces, it stopped working again. I haven't narrowed down exactly what is causing this problem - and it is a bit strange as the problem only seems to occur if my custom workspace is selected when I start FrameMaker. If I start with a standard workspace and then switch to my custom workspace the autosave still seems to work.

If I get a chance I'll try and find out exactly what's causing the issue. One thing to note is that the custom workspaces were created in FM 2017 so maybe there is something in the file which is 'upsetting' FM 2019 when it first opens the workspace file. Looking at the XML there doesn't seem to be any difference between the FM 2017 and 2019 workspace files.

My workaround for now is to open FM with the factory "Authoring" workspace set and then switch to my custom workspace. This seems to work ok, but I have to remember to switch back to the Authoring workspace before quitting FrameMaker.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2018 0
Explorer ,
Sep 14, 2018

Copy link to clipboard

Copied

The culprit seems to be the Variables pod. If I open the Variables pod and the Add/Edit Variable pod and then minimise them to icons, the auto backup file is no longer updated. As soon as I close these pods (icons) the backups start again. I'll log a bug for this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 14, 2018 1
Adobe Community Professional ,
Oct 07, 2018

Copy link to clipboard

Copied

Hi Bob:

There is an update to FrameMaker 19 available and I thought of your question when I saw this on the list of fixes:

FrameMaker creates a backup file now if Auto Save Every x Minutes option is enabled.

For more details, see: Adobe FrameMaker (2019 release) – Update 1

Let us know if this takes care of the issue.

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2018 0
Explorer ,
Oct 07, 2018

Copy link to clipboard

Copied

Hi Barb,

I've installed the update and it does appear to have fixed the issue. I am able to use all my workspaces and so far the auto files have been generating in the background they way they should.

Knowing that there should always be a snapshot of my open files no more than a couple of minutes old certainly puts my mind at ease, as having to work in a virtual machine does occasionally lead to unexpected situations where the only way out is to reboot!

Cheers,

Bob.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2018 2
Adobe Community Professional ,
Oct 07, 2018

Copy link to clipboard

Copied

That's great! Glad to hear the patch solved the issue.

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 07, 2018 0
Adobe Community Professional ,
Sep 07, 2018

Copy link to clipboard

Copied

OK, I'm back and yes it is working as expected on 2019 (v 15.0.0.393).

~Barb

Screenshot 2018-09-07 08.23.00.png Screenshot 2018-09-07 08.23.59.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2018 0
Participant ,
Sep 07, 2018

Copy link to clipboard

Copied

I just tested. Auto save works for me on the latest FM 2019 build 15.0.0.393.

The selection is off by default, but enabling Auto Save Every in the Edit > Preferences location let me set 2 minutes and, sure enough, after 2 minutes I got a *.auto.fm file in the same directory as all my FrameMaker files and the backup files.

Sean

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2018 0
Explorer ,
Sep 07, 2018

Copy link to clipboard

Copied

Well this is strange. It definitely doesn't work on my machine.

I created a new file in FM 2017 and saved it to a new directory on my desktop. I opened the directory and could see the .fm file. I then made some changes to the document but didn't save it and switched over to explorer to monitor the contents of the directory on my desktop. Sure enough after 2 minutes a .auto file appeared with the same filename as the .fm file. So it works in FM 2017.

I then closed FM 2017 and ran up FM 2019 (15.0.0.393) - same machine, same settings, same everything! I opened the same file and then saved it immediately so it would now be a valid FM 2019 file. I then made further changes but didn't save. Again monitoring the directory I could see the .fm file but after waiting more than 10 minutes no .auto file appeared.

I can't see what's wrong. As I said, this is the same machine with the same settings in preferences. I have double-checked and the Auto Save option is definitely on and set to 2 minutes (exactly the same settings as in FM 2017).

FYI, my operating system is Windows 10 Home, version 1709. I am running it within a virtualbox virtual machine inside Mac OSX 10.12 but this is the way I have run FM for years and I have never had any problems like this before.

My next step would be to uninstall and re-install FM 2019

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2018 0