Highlighted

Chapter autonumbering suddenly stopped working

Explorer ,
Apr 03, 2017

Copy link to clipboard

Copied

Hello, all.

Delighted user of Frame2015 in Win 7, here.

Suddenly every chapter in my book is chapter 1, and every appendix is appendix A.

I have correctly set up chapter and appendix numbering for the past 25 years at least. Why has it suddenly stopped working? I have set up the

I know that our autonumbering is somewhat antiquated, but until this very evening, it worked. The pre FM 5.5 variables were set up correctly, and numbering properties were set up consistently both in the individual .fm files and in the book files. But, suddenly, autonumbering has ceased to work.

I've read the sections in Matt Sullivan's book, but I am a bit afraid to start adding the <$chapnum> variable into our autonumbering setup, since I don't know how it ripples through other document setup. I need these files to work, soon, and I don't want a trial by fire to learn the use of the variables. I also don't know what the appendix equivalent variable is.

Has anyone run into this sudden failure of autonumbering? Did you find a way to fix it? Thanks very much.

Most Valuable Participant
Correct answer by Arnis_Gubins | Most Valuable Participant

1. Check the settings on this tab at the book level for all files"

restart_paraa_numberiong.png

2. Just use the <$chapnum> variable only. Omit such things as <N=1>, <N+>, etc. increments. The increments are set at the book-level using the Chapter tab of the Numbering Properties for each respective file.  The Format option lets you change between numeric and alpha sequences.

chapnum_settings.png

Views

315

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Chapter autonumbering suddenly stopped working

Explorer ,
Apr 03, 2017

Copy link to clipboard

Copied

Hello, all.

Delighted user of Frame2015 in Win 7, here.

Suddenly every chapter in my book is chapter 1, and every appendix is appendix A.

I have correctly set up chapter and appendix numbering for the past 25 years at least. Why has it suddenly stopped working? I have set up the

I know that our autonumbering is somewhat antiquated, but until this very evening, it worked. The pre FM 5.5 variables were set up correctly, and numbering properties were set up consistently both in the individual .fm files and in the book files. But, suddenly, autonumbering has ceased to work.

I've read the sections in Matt Sullivan's book, but I am a bit afraid to start adding the <$chapnum> variable into our autonumbering setup, since I don't know how it ripples through other document setup. I need these files to work, soon, and I don't want a trial by fire to learn the use of the variables. I also don't know what the appendix equivalent variable is.

Has anyone run into this sudden failure of autonumbering? Did you find a way to fix it? Thanks very much.

Most Valuable Participant
Correct answer by Arnis_Gubins | Most Valuable Participant

1. Check the settings on this tab at the book level for all files"

restart_paraa_numberiong.png

2. Just use the <$chapnum> variable only. Omit such things as <N=1>, <N+>, etc. increments. The increments are set at the book-level using the Chapter tab of the Numbering Properties for each respective file.  The Format option lets you change between numeric and alpha sequences.

chapnum_settings.png

Views

316

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 03, 2017 0
Most Valuable Participant ,
Apr 03, 2017

Copy link to clipboard

Copied

How is this set-up in the book file (book file trumps individual fm files)? Did you import a template or formats across all files recently?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2017 0
Explorer ,
Apr 03, 2017

Copy link to clipboard

Copied

Hi, Arnis.

In the book file, I selected chapters 2-12. I selected Format - Document - Numbering. On the Chapter tab, I selected "Continue numbering from previous chapters in book." I waited for that to ripple through all the chapters. I updated the book. Chapters 2-12 remain numbered "Chapter 1."

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2017 0
Explorer ,
Apr 03, 2017

Copy link to clipboard

Copied

I've completely deleted the previous TOC files -- everything. I added a new TOC and imported the paragraph formats. But the .chm output is still using the filenames for the chapter titles, which tells me that the TOC is somehow not registering in the help output. When it registers, the TOC of the .chm file uses the document chapter titles for the help topic titles, instead of the filenames.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2017 0
Most Valuable Participant ,
Apr 03, 2017

Copy link to clipboard

Copied

Since you're not using the $chapnum variable (which you really  should), I suspect that you're numbering scheme is being reset by the paragraph numbering control that probably is set to re-start the paragraph numbering for every file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2017 0
Explorer ,
Apr 03, 2017

Copy link to clipboard

Copied

Hi again, Arnis.

Two questions:

1. Where is the variable being reset? I thought the settings in the book file overrode the ones in each chapter file. But I have carefully set each one in each individual .fm file, too, and they are in agreement. Where is the overriding being done?

2. If I were to use the variable, would it look like this:

chapter 1 autonumbering: CURRENTLY C:<n=1>.\t     CHANGE TO  C:<$chapnum><n=1>.\t

Chapter 2+                        CURRENTLY  C:<n+>.\t      CHANGE TO   C:<$chapnum><n+>.\t

Appendix A:                      CURRENTLY X:<A=1>.\t      CHANGE TO  X:<$chapnum><A=1>.\t

Appendix B+                     CURRENTLY X:<A+>.\t        CHANGE TO   X:<$chapnum><A+>.\t

If I make these changes in the autonumbering setup, and copy them into the appropriate files, will my autonumbering problems go away?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2017 0
Most Valuable Participant ,
Apr 03, 2017

Copy link to clipboard

Copied

1. Check the settings on this tab at the book level for all files"

restart_paraa_numberiong.png

2. Just use the <$chapnum> variable only. Omit such things as <N=1>, <N+>, etc. increments. The increments are set at the book-level using the Chapter tab of the Numbering Properties for each respective file.  The Format option lets you change between numeric and alpha sequences.

chapnum_settings.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2017 0
Explorer ,
Apr 03, 2017

Copy link to clipboard

Copied

THAT. WAS. IT!

Arnis, you are my HERO. Thank you so much!!!

I will switch to that newfangled way of setting up autonumbering. You may get some followup questions from me.

Thank you again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 03, 2017 0