Highlighted

Character Tag Find/Replace Issues

Community Beginner ,
Sep 10, 2015

Copy link to clipboard

Copied

FM 12.0.4.445 on Windows 7 Enterprise

I've created a character tag (Skip Spelling) with all properties set to "As Is" except for Language, which is set to "None." The purpose of this tag is to have FM skip certain terms for spell checking. For example, my document discusses many different file extensions, such as .TXT, .DAT, etc. These terms can't be added to the dictionary due to the "Space Before" setting for periods, which I don't want to change.

Applying this character tag works fine, except in two instances:

  • First, applying it occasionally forces a term to the next line of a paragraph, as if the term has grown in size. Not a big deal, but I am curious as to why this would happen. It also makes me wonder about the Spread and Stretch settings, which remain at 0% and 100%, although I tried deleting them in the character tag definition.
  • More importantly, using Find/Change with change = By Pasting applies the new character tag but also changes bold to plain text, especially in bold headings. (Copy Special > Character Format was used to copy the character tag.) Applying the character tag directly to a bold term does not remove the bold. Is the Find/Change set up correctly or this is a bug?

Thanks very much for your help.

I can't help much with the respacing issue. Double check that your Skip Spelling character format really is changing only the Language. See what changes in the Character Designer when you apply the format, or save a file as MIF and examine the definition of your Skip Spelling character format.

Copy Special > Character Format copies all properties of the character formatting. So the Find/Change dialog is behaving as expected - which unfortunately for you, isn't as wanted.

Views

347

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Character Tag Find/Replace Issues

Community Beginner ,
Sep 10, 2015

Copy link to clipboard

Copied

FM 12.0.4.445 on Windows 7 Enterprise

I've created a character tag (Skip Spelling) with all properties set to "As Is" except for Language, which is set to "None." The purpose of this tag is to have FM skip certain terms for spell checking. For example, my document discusses many different file extensions, such as .TXT, .DAT, etc. These terms can't be added to the dictionary due to the "Space Before" setting for periods, which I don't want to change.

Applying this character tag works fine, except in two instances:

  • First, applying it occasionally forces a term to the next line of a paragraph, as if the term has grown in size. Not a big deal, but I am curious as to why this would happen. It also makes me wonder about the Spread and Stretch settings, which remain at 0% and 100%, although I tried deleting them in the character tag definition.
  • More importantly, using Find/Change with change = By Pasting applies the new character tag but also changes bold to plain text, especially in bold headings. (Copy Special > Character Format was used to copy the character tag.) Applying the character tag directly to a bold term does not remove the bold. Is the Find/Change set up correctly or this is a bug?

Thanks very much for your help.

I can't help much with the respacing issue. Double check that your Skip Spelling character format really is changing only the Language. See what changes in the Character Designer when you apply the format, or save a file as MIF and examine the definition of your Skip Spelling character format.

Copy Special > Character Format copies all properties of the character formatting. So the Find/Change dialog is behaving as expected - which unfortunately for you, isn't as wanted.

Views

348

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Sep 10, 2015 0
Contributor ,
Sep 11, 2015

Copy link to clipboard

Copied

I can't help much with the respacing issue. Double check that your Skip Spelling character format really is changing only the Language. See what changes in the Character Designer when you apply the format, or save a file as MIF and examine the definition of your Skip Spelling character format.

Copy Special > Character Format copies all properties of the character formatting. So the Find/Change dialog is behaving as expected - which unfortunately for you, isn't as wanted.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2015 0
Community Beginner ,
Sep 11, 2015

Copy link to clipboard

Copied

Thanks, Mike. I did check the format in a .mif file, and only language is changed -- so the spacing glitch will remain a mystery.

On Copy Special > Character Format, I thought that maybe if you clicked in a paragraph without selecting anything, it would copy the character tag and not all character properties, which you indicate is not correct. Wishful thinking on my part, I guess. Geez, you should be able to copy a tag in FM (character or para.).

Thanks again.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2015 0
Community Beginner ,
Sep 11, 2015

Copy link to clipboard

Copied

By the way, I did find a FM bug (feature) request on the issue of copy/pasting character tags - Feature 3937977.  It is marked as ToFix, so maybe in our lifetime they will add the functionality.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 11, 2015 0
Advisor ,
Sep 13, 2015

Copy link to clipboard

Copied

Out of curiosity, is there a difference in the behaviour of Copy Special > Character Format? you could have text under the cursor which has a paragraph style applied but no character style …

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 13, 2015 0
Community Beginner ,
Sep 17, 2015

Copy link to clipboard

Copied

FieryP. - Not sure what you are asking, but the character tag was applied to the text from which I copied the character format.

If you are asking about copying character format when no char. tag has been applied, I tried that, though it doesn't apply to my situation. What I found was that the text characteristics of the paragraph tag are copied.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 17, 2015 0
Advisor ,
Sep 18, 2015

Copy link to clipboard

Copied

That's what I was curious about – and yes, you'd expect that copying a character format from text to which a  character style has been applied would load the clipboard with the definition used in the style. Good luck with resolving this one!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2015 0
Most Valuable Participant ,
Sep 18, 2015

Copy link to clipboard

Copied

As Mike says, the Copy Special function copies the existing formats (paragraph or character) at the insertion point, not the Catalog definitions. This is the way that the function has behaved all along in FM.

If you just want to apply the Language> None setting using the Change/Find, then use the Change > To Character Format... option and set the Language to None, leaving all of the other options to AsIs.

Change_to_Char_format.png

Note: this will create a character format override instead of applying a character tag.

What is needed is an enhancement to the Copy Special where the user can either specify the format or the tag at the insertion point [and this enhancement should also allow Object formats/styles to be copied as well].

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 18, 2015 0
Community Beginner ,
Sep 20, 2015

Copy link to clipboard

Copied

Thanks, Arnis. I didn't think about just applying the override - that is definitely one solution. I prefer to have the character tag, though. Glad you voted on the feature request I mentioned earlier in this thread.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 20, 2015 0