Highlighted

Color values in the output are different from those in FrameMaker source files

New Here ,
Aug 13, 2018

Copy link to clipboard

Copied

Hi,

FrameMaker color conversion issue has been discussed at large. I have read through many discussions, but could not find a fix. If this has been discussed already, kindly help me find the correct thread.

We use unstructured FrameMaker (version 9). We generate a PDF output from FrameMaker and an online help (OLH) using WebWorks ePublisher Express.

Due to rebranding, we had to change the heading colors used in our guides.

I created custom colors in the Color Definitions dialog by entering RGB values and used them.

Result:

In the PDF output, colors are correct.

In the OLH, colors look similar but not the same. Color values change.

1. Although I chose the color model to be RGB in the Color Definitions dialog, when FrameMaker (FM) is relaunched, it had changed to CMYK (may be because FM saves colors as CMYK?)

2. In the Color Defintions dialog, I input the CMYK equivalent of the required color instead. This, corrects the color in the OLH but the colors in PDF are wrong.

3. I tried to set "GetLibraryColorRGBFromCMYK" in Maker.ini to None, Printing, and Screen&Printing. None of the setting made a difference. Should it make any difference at all?

Isn't this simply, change the setting to required value, and then launch FrameMaker? Did I miss any step?

4. Then I meddled with the Adobe driver settings a bit. That did not help either.

5. I use "Save as PDF" with "Convert CMYK colors to RGB" enabled to generate a PDF .

Thanks,

Jyothi

Views

110

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Color values in the output are different from those in FrameMaker source files

New Here ,
Aug 13, 2018

Copy link to clipboard

Copied

Hi,

FrameMaker color conversion issue has been discussed at large. I have read through many discussions, but could not find a fix. If this has been discussed already, kindly help me find the correct thread.

We use unstructured FrameMaker (version 9). We generate a PDF output from FrameMaker and an online help (OLH) using WebWorks ePublisher Express.

Due to rebranding, we had to change the heading colors used in our guides.

I created custom colors in the Color Definitions dialog by entering RGB values and used them.

Result:

In the PDF output, colors are correct.

In the OLH, colors look similar but not the same. Color values change.

1. Although I chose the color model to be RGB in the Color Definitions dialog, when FrameMaker (FM) is relaunched, it had changed to CMYK (may be because FM saves colors as CMYK?)

2. In the Color Defintions dialog, I input the CMYK equivalent of the required color instead. This, corrects the color in the OLH but the colors in PDF are wrong.

3. I tried to set "GetLibraryColorRGBFromCMYK" in Maker.ini to None, Printing, and Screen&Printing. None of the setting made a difference. Should it make any difference at all?

Isn't this simply, change the setting to required value, and then launch FrameMaker? Did I miss any step?

4. Then I meddled with the Adobe driver settings a bit. That did not help either.

5. I use "Save as PDF" with "Convert CMYK colors to RGB" enabled to generate a PDF .

Thanks,

Jyothi

Views

111

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 13, 2018 0
Adobe Community Professional ,
Aug 13, 2018

Copy link to clipboard

Copied

Since the colors are correct in PDF, you might want to check with WebWorks to ask what they recommend.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 13, 2018 0
New Here ,
Aug 13, 2018

Copy link to clipboard

Copied

But, please note that if I input the CMYK equivalent of the required color, the color in PDF is wrong and the OLH is correct. It is as though FrameMaker imparts RGB values to the PDF output and CMYK to the OLH (please correct me if this understanding is wrong).

Is the following behavior normal:

In FM, RGB: 0, 144, 198 is saved as CMYK: 77.6, 21.2, 0, 22.4

If a color converter is used, the CMYK equivalent is 100, 27, 0, 22 and not what It is saved FM.

If I set this CMYK value (100, 27, 0, 22 ) in FM, the color in OLH is fine.

So, is there some workaround that can be used in FM, which will ensure that the CMYK values are used in PDF output?

Please suggest.

Thanks,

Jyothi

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 13, 2018 0
Adobe Community Professional ,
Aug 14, 2018

Copy link to clipboard

Copied

I believe the color engine has changed since FrameMaker 9. Try downloading a free trial of Fm 2017 (v. 14) to see if it resolves your issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 14, 2018 0