Highlighted

conkeyref in Framemaker DITA ?

New Here ,
Aug 12, 2019

Copy link to clipboard

Copied

Hello,

I am currently evaluating if Framemaker can be used as an alternative editor in a predominantly OxygenXML based authoring environment with standard DITA.

Now I have found that it already fails when using keys in the following way (I have prepared files, but found no way to add them to this post):

bookmap:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE bookmap PUBLIC "-//OASIS//DTD DITA 1.3 BookMap//EN" "bookmap/dtd/bookmap.dtd" [

]>

<bookmap>

    <booktitle>

        <mainbooktitle>BOOKTITLE MAINBOOKTITLE</mainbooktitle>

    </booktitle>

    <chapter navtitle="test">

        <topicref href="testtopic.dita"></topicref>

    </chapter>

    <appendix>

        <keydef keys="name" href="testkey.dita" />

    </appendix>

</bookmap>

testkey file:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE topic PUBLIC "-//OASIS//DTD DITA Topic//EN" "topic.dtd">

<topic id="testkey">

    <title>testkeys</title>

    <body>

        <p id="testid">paragraph inserted via conkeyref.</p>

    </body>

</topic>

and the testtopic file:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE topic PUBLIC "-//OASIS//DTD DITA Topic//EN" "topic.dtd">

<topic id="testtopic">

    <title>testtopic</title>

    <body>

        <p conkeyref="name/testid"/>

    </body>

</topic>

When opening the bookmap in Framemaker, it does not recognize the key.

Now this is a problem, because we have thousands of documents built on this principle and we are going to continue using this principle.

Is there a way to get Framemaker to comply with this requirement ?

Thanks in advance.

Christophe

TOPICS
Structured

Views

112

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

conkeyref in Framemaker DITA ?

New Here ,
Aug 12, 2019

Copy link to clipboard

Copied

Hello,

I am currently evaluating if Framemaker can be used as an alternative editor in a predominantly OxygenXML based authoring environment with standard DITA.

Now I have found that it already fails when using keys in the following way (I have prepared files, but found no way to add them to this post):

bookmap:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE bookmap PUBLIC "-//OASIS//DTD DITA 1.3 BookMap//EN" "bookmap/dtd/bookmap.dtd" [

]>

<bookmap>

    <booktitle>

        <mainbooktitle>BOOKTITLE MAINBOOKTITLE</mainbooktitle>

    </booktitle>

    <chapter navtitle="test">

        <topicref href="testtopic.dita"></topicref>

    </chapter>

    <appendix>

        <keydef keys="name" href="testkey.dita" />

    </appendix>

</bookmap>

testkey file:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE topic PUBLIC "-//OASIS//DTD DITA Topic//EN" "topic.dtd">

<topic id="testkey">

    <title>testkeys</title>

    <body>

        <p id="testid">paragraph inserted via conkeyref.</p>

    </body>

</topic>

and the testtopic file:

<?xml version="1.0" encoding="UTF-8"?>

<!DOCTYPE topic PUBLIC "-//OASIS//DTD DITA Topic//EN" "topic.dtd">

<topic id="testtopic">

    <title>testtopic</title>

    <body>

        <p conkeyref="name/testid"/>

    </body>

</topic>

When opening the bookmap in Framemaker, it does not recognize the key.

Now this is a problem, because we have thousands of documents built on this principle and we are going to continue using this principle.

Is there a way to get Framemaker to comply with this requirement ?

Thanks in advance.

Christophe

TOPICS
Structured

Views

113

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Aug 12, 2019 0
Amitoj LATEST
Adobe Employee ,
Aug 13, 2019

Copy link to clipboard

Copied

Can you please try loading the keyspace. Structure -> Dita -> Options -> Load keyspace. By default keyspace is not loaded which we do plan to improve with upcoming release.

Thanks

Amitoj Singh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Aug 13, 2019 0