Cross-reference text the same for every xref in entire published ditamap/book!

Community Beginner ,
Jul 16, 2019 Jul 16, 2019

Copy link to clipboard

Copied

I have a ditamap utilizing dita files. I publish through Save Ditamap As Book 2019 with fm components, and then Save as PDF. WE have numerous ditamaps for various products. This particle one is large and takes more than a few minutes to run. But has been run repeatedly without issue for years. As recently as last week.

Yesterday I was editing various dita files connected to the ditamap (image scale, text edits, etc), nothing consequential. I published to see how the images were looking and every single cross-reference in the PDF has the same text! Every last one in a 350 page PDF! While the text says the same thing for each cross-reference, the links work and go to the locations they are supposed to - just the text is incorrect.

Things I have checked:

  • The links are correct at the book stage - text is all there. Only after publishing to a PDF, does the text change.
  • Naturally, I published other ditamaps to see if something broke in our structured templates - but everything else publishes fine. Only this ditamap.
  • I have started rebuilding the ditamap, one document at a time and re-running a publish process and have run across one dita file that seems to trigger the link conundrum. So I went back to the original ditamap, removed that dita file and re-ran the publish but that did not correct the problem. Same result with repeated xref text. So these leads me to believe there are other dita files triggering the problem.
  • Looking at the dita file that seemed to trigger the results, it does not appear any different than any other of our docs.

Due to the size of this ditamap, I would like to avoid rebuilding it. Plus, after adding each file, I need to test to see if there are any other files that trigger the problem. This is extremely time consuming.

Any idea why this is happening and the root of the problem?

TOPICS
Structured

Views

336

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Employee ,
Jul 16, 2019 Jul 16, 2019

Copy link to clipboard

Copied

If you could share a sample of the dita project with us, we could look at what may be causing it.

thanks

Amitoj Singh

email: amitosin@adobe.com

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Jul 17, 2019 Jul 17, 2019

Copy link to clipboard

Copied

I am not sure how to provide a "sample". To send any ditamap, you will also need the dita files contained in the map, correct? Plus any other components used by the dita files? Graphics, conrefs, etc?

As mentioned, I have started rebuilding a new ditamap that could be a sample but I am already 70 dita files into that.

I could create a yet another new ditamap and add the files that seem to be a problem and see what happens in order to send to you?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines