Customized templates not applied while saving ditabookmap as book with fm components

Contributor ,
Oct 09, 2019

Copy link to clipboard

Copied

Hi,

I cannot get FrameMaker to use customized templates while creating fm components from a ditabookmap. For instance, the booktitle still shows the adobe logo, although I have created a customized template and have replaced the native FrameMaker template via File->Publish -> DITA template list. It simply uses the default template from FrameMaker installation path, which I would like to avoid manipulating. I use FrameMaker 2019.

Thanks!

Hadi

TOPICS
PDF output, Publishing, Structured

Views

182

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Oct 09, 2019

Copy link to clipboard

Copied

Hi Hadi

 

Are you changing the template (output) in the sts file (File -> Publish -> Edit). You may have to export the same once and then import it back again. 

 

clipboard_image_0.png 

 

and then save the sts file. Also please ensure that in DITA options you have the correct options selected.

clipboard_image_1.png

 

Thanks

Amitoj Singh

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Oct 10, 2019

Copy link to clipboard

Copied

 Hi Amitoj, Thank you for the tip. Under DITA options, I had to select save PDF via Book with components. Then, if I publish my ditabookmap via the Generate Selected Output tab, it works. Whereas, if I save my ditabookmap as book with fm components, then do the same via the publish menu, it will use the template in the default path.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Oct 10, 2019

Copy link to clipboard

Copied

Hi Hardi,

The above setting is for Publishing Ditamap to Pdf. (It automatically converts it into Book with FM components, Apply template and publish ).

If you want to skip this and manually save Ditamap into Book with FM componenets then you also have to apply the template manually via the File-Import-formats route.

I suggest you to directly save ditamap into Pdf by giving template in the settings file.

 

-Pulkit 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Oct 10, 2019

Copy link to clipboard

Copied

Hi Pulkit, I fully agree with you and I am more comfortable with publishing ditamap directly to pdf rather than save ditamap into book with fm components and then manually import formats.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Employee ,
Oct 10, 2019

Copy link to clipboard

Copied

We also had a webinar on designing templates and publishing to PDF.
You can see the recording - http://bit.ly/2PeQYlA

You can refer https://meetus.adobeevents.com/technicalcommunication/  for upcoming webinars

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
hadih26673991 AUTHOR LATEST
Contributor ,
Oct 15, 2019

Copy link to clipboard

Copied

Hi Pulkit, I have a small problem, when publishing the pdf, that is FM does not ask for ditaval file. The only way, I found so far is via save as book with FM conponents. Do you know a work around to get the prompt for ditaval in publish mode? Under DITA options, I see a box: apply as condition (for ditaval preview), but I am not sure I understand it correctly!

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more