Highlighted

ES: Event script runs intermittently

Participant ,
Oct 14, 2015

Copy link to clipboard

Copied

Hello fellows,

I've created an event extendscript that saves a Mif file as FM upon opening the Mif file (used Constants.FA_Note_PostOpenMIF as the notification trigger).

For some reason, the script is sometimes triggered, and sometimes not. I tried removing the script and registering it again, but this does not change anything.

I am currently using FM13. Any ideas why the script/FM behavior is inconsistent?

Thank you in advance!

TOPICS
Scripting

Views

652

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

ES: Event script runs intermittently

Participant ,
Oct 14, 2015

Copy link to clipboard

Copied

Hello fellows,

I've created an event extendscript that saves a Mif file as FM upon opening the Mif file (used Constants.FA_Note_PostOpenMIF as the notification trigger).

For some reason, the script is sometimes triggered, and sometimes not. I tried removing the script and registering it again, but this does not change anything.

I am currently using FM13. Any ideas why the script/FM behavior is inconsistent?

Thank you in advance!

TOPICS
Scripting

Views

653

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 14, 2015 0
Enthusiast ,
Oct 14, 2015

Copy link to clipboard

Copied

That is a BUG.

I am struggling for weeks / months with that problem.

I've opened a bug report:

Bug#4065866 - Losing definition of variables

When I run a script from the library, it works fine.

But when I run it from "autorun" or via menue, it fails.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 14, 2015 0
Participant ,
Oct 15, 2015

Copy link to clipboard

Copied

Hi Klaus,

Thank you for your response!  It clarifies the situation.

So far, I am disappointed with the latest TCS.

The Framemaker 2015 quality and stability has not been improved much -- it crashes in the same situations as FM10 and FM12.

Acrobat DC is much worse than Acrobat 11 I had. It crashes upon trying to close a PDF file. In addition, by default, the Title bar of the PDF includes the PDF file name instead of the book title. Each time I generate a PDF, I need to manually change the setting via the PDF file properties. I never had such a problem in the previous versions of Acrobat.

I wonder if Adobe has a QA dept...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2015 0
Adobe Employee ,
Oct 15, 2015

Copy link to clipboard

Copied

Hi Rombanks,

I see the bug logged by Klaus, we are working on it and I will update the thread soon on this.

In addition to this, if you let me know what FM or TCS specfic stability and functional issues you are facing. We will be glad to help you.

You can directly mail me at ksaini@adobe.com (ksaini at adobe dot com)

Thanks

Kunal Saini

Manager QA

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 15, 2015 0
Participant ,
Oct 29, 2015

Copy link to clipboard

Copied

Hi Kunal,

Thank you for your response!

I will send you a list of issues I encountered while using FM and Acrobat DC.

Regards,

Roman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 29, 2015 0
Adobe Employee ,
Oct 29, 2015

Copy link to clipboard

Copied

Hi Rombanks,

It seems that the problem mentioned by you is different from what kalus has mentioned.

Could you please share the script along with detailed steps which you are following to execute the script.

You can directly mail me at aggrawal@adobe.com aggrawal at adobe dot com)

Thanks

Pankaj

Frame Engg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 29, 2015 0
rombanks LATEST
Participant ,
Oct 29, 2015

Copy link to clipboard

Copied

Hi Pankaj,

Thank you for your response! I added the event script I mentioned earlier to Autorun. After restarting FrameMaker, I expect the script to be loaded automatically and perform all functions when encountering the Constants.FA_Note_PostOpenMIF notification. However, the script is either not triggered at all, or doesn't execute all its functions. For the script to be run correctly, I need to manually hit Run under Autorun each time I load FM. I'll send you the script.

Thanks again,

Roman

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 29, 2015 0