FDK2017 Visual Studio Version Compatibility

New Here ,
Feb 28, 2020 Feb 28, 2020

Copy link to clipboard

Copied

Hi,

I am using FrameMaker 2017 with FDK 2017. I was wondering about the following compatibility questions:

 

  • Can I use Visual Studio 2013 Express for the development? It seems Microsoft Foundation Classes (MFC) are required for some elements. Since MFC is only part of the non-express version, no development seems possible. Any advice on that?
  • Can I use newer Visual Studio versions than 2013 with the required platform toolset (v120)? How about the MFC in such a case?
  • For future versions of FrameMaker, which might not use the v120 anymore, the purchasing of a new Visual Studio will be required to maintain the plugins. Correct?

Thank you.

TOPICS
Scripting

Views

306

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
no replies

Have something to add?

Join the conversation