Highlighted

FM-14.0.1.406: CTRL+0 does not insert variable - it kills FM

Advocate ,
Jun 15, 2017

Copy link to clipboard

Copied

I have filed bug FRMAKER-3007

In FM-13 and before CTRL+0 opened the list of variables and with quick selection only a few keystrokes were necessary to insert the variable. For example:

CTRL+0

a

Enter

inserted the variable named Arrow.

Since I had only recently used this function in FM-14 I did not discover it earlier and assumed a recent Windows update as reason. But removing that update did not help. Hence there must be a problem in FM.

Can You please check and confirm the bug?

BTW cmds.cfg states:

<Command QuickVariables
    <Label Quick Variable>
    <KeySequence \!qv>
    <KeySeqLabel Ctrl+0>
    <Definition \xF42>>

...

<Command Variable
   <Label Variables...>
   <KeySequence \!sv>
   <Definition \x353>>

and  wincmds.cfg states:

<Modify QuickVariables            <KeySequence  ^ 0    > >

In FM-13 the definitions are:

<Command QuickVariables
    <Label Quick Variable>
    <KeySequence \!qv>
    <Definition \xF42>>

...

<Command Variable
   <Label Variables...>
   <KeySequence \!sv>
   <Definition \x353>>

and  wincmds.cfg states:

<Modify QuickVariables            <KeySequence  ^ 0    > >

Good News: problem cured - not a bug of FrameMaker!
Re-installing FM-14 did not cure the problem.

The newly installed .NET Framework 4.7 was the most suspicious update for me, but I was not able to uninstall it with Windows Update (in contrast to the security updates), so I decided to do a restore to a restore point only 2 days ago.
Although System Restore claimed an error 0x000022 (no system files restored/changed) all affected FM versions (11 to 14) again work as expected!
Carefully inspecting the system at least reveals these changes done by the restore: Windows Update again offers for installation (hence they had been de-installed by the restore):
1) 2017-06 Security Monthly Quality Rollup for Windows 7 for x64-based Systems (KB4022719)
2) Microsoft .NET Framework 4.7 for Windows 7 and Windows Server 2008 R2 for x64 (KB3186497)
3) Update for Windows 7 for x64-based Systems (KB2952664)
4) Update for Windows 7 for x64-based Systems (KB3150513)

So It may be worth to watch the last Windows updates!

Views

253

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

FM-14.0.1.406: CTRL+0 does not insert variable - it kills FM

Advocate ,
Jun 15, 2017

Copy link to clipboard

Copied

I have filed bug FRMAKER-3007

In FM-13 and before CTRL+0 opened the list of variables and with quick selection only a few keystrokes were necessary to insert the variable. For example:

CTRL+0

a

Enter

inserted the variable named Arrow.

Since I had only recently used this function in FM-14 I did not discover it earlier and assumed a recent Windows update as reason. But removing that update did not help. Hence there must be a problem in FM.

Can You please check and confirm the bug?

BTW cmds.cfg states:

<Command QuickVariables
    <Label Quick Variable>
    <KeySequence \!qv>
    <KeySeqLabel Ctrl+0>
    <Definition \xF42>>

...

<Command Variable
   <Label Variables...>
   <KeySequence \!sv>
   <Definition \x353>>

and  wincmds.cfg states:

<Modify QuickVariables            <KeySequence  ^ 0    > >

In FM-13 the definitions are:

<Command QuickVariables
    <Label Quick Variable>
    <KeySequence \!qv>
    <Definition \xF42>>

...

<Command Variable
   <Label Variables...>
   <KeySequence \!sv>
   <Definition \x353>>

and  wincmds.cfg states:

<Modify QuickVariables            <KeySequence  ^ 0    > >

Good News: problem cured - not a bug of FrameMaker!
Re-installing FM-14 did not cure the problem.

The newly installed .NET Framework 4.7 was the most suspicious update for me, but I was not able to uninstall it with Windows Update (in contrast to the security updates), so I decided to do a restore to a restore point only 2 days ago.
Although System Restore claimed an error 0x000022 (no system files restored/changed) all affected FM versions (11 to 14) again work as expected!
Carefully inspecting the system at least reveals these changes done by the restore: Windows Update again offers for installation (hence they had been de-installed by the restore):
1) 2017-06 Security Monthly Quality Rollup for Windows 7 for x64-based Systems (KB4022719)
2) Microsoft .NET Framework 4.7 for Windows 7 and Windows Server 2008 R2 for x64 (KB3186497)
3) Update for Windows 7 for x64-based Systems (KB2952664)
4) Update for Windows 7 for x64-based Systems (KB3150513)

So It may be worth to watch the last Windows updates!

Views

254

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 15, 2017 0
Enthusiast ,
Jun 15, 2017

Copy link to clipboard

Copied

Hi Klaus,

I've just tested - it works.

But what's not clear to me is: what exactly happens when you try this.

Does the list open? or crashes FM, when you select a variable? or when you hit enter?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2017 0
Advocate ,
Jun 15, 2017

Copy link to clipboard

Copied

Klaus, to answer your question:

I normally apply a paragraph format, say en-example-narrow by these keystrokes (cursor in paragraph):

F9, en, ENTER

Now, when typing F9 (or the others i have tested) FM tilts

In FM-13 the catalogue was not opened for this - but I need to look what's wrong with my installion of FM in general:

Since today also FM-13 creates the same problem! Quite a number of Fxx shortcuts are broken (test from FM-14):

F9 (pargraph catalog) => tilt; F8 (char catalogue) => tilt; F6 (repeat, OK); F3 (repeat Find, OK); F4 (style bold, OK); F5 (style italic, OK); F7 (command search, tilt). Well I do not check all other shortcuts with function keys (CTRL+..., ALT+...) - I have now enough frame logs and am tired from restarting my beloved application.

I thought that the last Windows update (installed today) was the culprit, but nope. Need to dig in the mud.

Update: the problem occurs in FM-14, FM-13, FM-12 and FM-11. It is not present in FM-10 and below.

I will unintall all Windows updates from today and test again:

2017-06 Security Monthly Quality Rollup for Windows 7 for x64-based Systems (KB4022719) - uninstalling did not help, so probably not the culprit.

Update for Windows 7 for x64-based Systems (KB3150513)

Update for Windows 7 for x64-based Systems (KB2952664)

Microsoft .NET Framework 4.7 for Windows 7 and Windows Server 2008 R2 for x64 (KB3186497)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2017 0
Adobe Employee ,
Jun 15, 2017

Copy link to clipboard

Copied

Does this also happen with a fresh installation of FrameMaker? Or are you experiencing it with your customized versions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2017 0
Advocate ,
Jun 15, 2017

Copy link to clipboard

Copied

Stefan, before calling it a problem with FM, I always de-install my modifications. Of course this is not a fresh installation, but if you would compare all files after the installation of FM and after the de-installation of my mods You would not get a difference. I'm very careful with this. But as said in my previous post - most likely one of the Windows update plays a rôle here. My suspicion is the Net FrameWork update, because FM-10 and FM-9 are not affected.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 15, 2017 0
Advocate ,
Jun 16, 2017

Copy link to clipboard

Copied

Good News: problem cured - not a bug of FrameMaker!
Re-installing FM-14 did not cure the problem.

The newly installed .NET Framework 4.7 was the most suspicious update for me, but I was not able to uninstall it with Windows Update (in contrast to the security updates), so I decided to do a restore to a restore point only 2 days ago.
Although System Restore claimed an error 0x000022 (no system files restored/changed) all affected FM versions (11 to 14) again work as expected!
Carefully inspecting the system at least reveals these changes done by the restore: Windows Update again offers for installation (hence they had been de-installed by the restore):
1) 2017-06 Security Monthly Quality Rollup for Windows 7 for x64-based Systems (KB4022719)
2) Microsoft .NET Framework 4.7 for Windows 7 and Windows Server 2008 R2 for x64 (KB3186497)
3) Update for Windows 7 for x64-based Systems (KB2952664)
4) Update for Windows 7 for x64-based Systems (KB3150513)

So It may be worth to watch the last Windows updates!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 16, 2017 1
Adobe Employee ,
Jun 17, 2017

Copy link to clipboard

Copied

Thanks for sharing, Klaus.

We will look into that as well.

Meanwhile two suggestions that you might want to include in your tests as well:

- rename the FM version specific folder in %appdata% from e.g. "14" to to "14_old" and restart FM

- empty Windows' %temp% folder and reboot Windows

My hunch is (why only … ;-)) is that you do that already anyway, but I thought I just mention it 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 17, 2017 0
K.Daube LATEST
Advocate ,
Jun 19, 2017

Copy link to clipboard

Copied

Stefan, thanks for reminding me of the Windows temp folder - I haven't thought of this.

On my system it is only cleared automatically on mondays.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 19, 2017 0