FM 2015 Cannot save custom rule in table format

Explorer ,
Sep 08, 2016 Sep 08, 2016

Copy link to clipboard

Copied

Hello. I'm using fm2015 in Win 7 environment.

I created a table with single 1-point rules throughout.

I then applied a double 1-point rule to the bottom edge of the Heading row. I did this in Custom Ruling and Shading, and then when I saw that I could apply that rule directly in the Table Designer, I applied it there.

I've saved it every which way, but the double rule is never saved. I get the uniform 1-pt rule throughout.

What am I missing? I'm sure I used to be able to do this.

Thanks.

Views

233

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Sep 12, 2016 Sep 12, 2016
Custom Ruling & Shading overrides Table Designer settings. It sounds like you want a double rule between heading and body rows? Select the Heading row In Custom Ruling & Shading, check Custom Cell Ruling, pick From Table, check Bottom. Click on Apply. This removes the override and the table will use the settings from Table Designer. In Table Designer, add it back in via Separators: If that fails, you might have added the override to the top of the first body row instead of the bottom of the hea...

Likes

Translate

Translate
Adobe Community Professional ,
Sep 12, 2016 Sep 12, 2016

Copy link to clipboard

Copied

Custom Ruling & Shading overrides Table Designer settings. It sounds like you want a double rule between heading and body rows?

  1. Select the Heading row
  2. In Custom Ruling & Shading, check Custom Cell Ruling, pick From Table, check Bottom. Click on Apply. This removes the override and the table will use the settings from Table Designer.
    VMware Fusionss_006.png
  3. In Table Designer, add it back in via Separators:
    VMware Fusionss_005.png

If that fails, you might have added the override to the top of the first body row instead of the bottom of the heading row. It might seem like the same place to us, but FrameMaker sees the difference. It can show you were the override is with the Show Current Settings button in the CR&S dialog box, but when a table gets too confusing with a bunch of overrides, I pull them all off, do what I can through Table Designer and then only use CR&S where absolutely necessary. To remove all the CR&S, enable all four Outside Edge checkmarks and both of the Inside Border checkmarks, and pick From Table in the Apply Ruling Style list. Click Apply.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Sep 15, 2016 Sep 15, 2016

Copy link to clipboard

Copied

Thank you, Barb. This worked perfectly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Sep 15, 2016 Sep 15, 2016

Copy link to clipboard

Copied

Oh good! I was wondering if that took care of it for you.

Here's why I believe CR&S is so painful: generally speaking, in any other dialog box in any other application, we enable checkmarks to turn a feature on, and disable them to turn the feature off. In CR&S, to turn a feature off (either the ruling or shading overrides), we have to enable the checkmarks, and then choose From Table. That logic isn't intuitive prior to being explained, and I've watch so many of my students struggle with it.

So glad you are back on track.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Explorer ,
Dec 13, 2016 Dec 13, 2016

Copy link to clipboard

Copied

I have a question along these lines. Hopefully someone is still watching and can answer without having to start a new thread.

My table has grey headings and white body rows. The body rows have grey rules to separate the columns, and I'd like the headings to have white rules separating the columns. I can't figure out how to add a column rule to the heading only and using CR&S doesn't save with the table style, so I always have to reapply it.

Any thoughts?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 13, 2016 Dec 13, 2016

Copy link to clipboard

Copied

LATEST

Hopefully someone is still watching and can answer without having to start a new thread.

It's a good idea to start a thread for each new question. That way, others searching for an answer to the same question have a better change of finding it.

I'd like the headings to have white rules separating the columns

If you want lines only between the columns in the heading rows, that's CR&S, unfortunately. My advice to my students is always to redesign their tables to take advantage of the patterns in the Table Designer, and to avoid CR&S whenever possible.

That said, if the body rows are white, why can't you have white rules down the entire table? The ones on the body rows won't show against the white background. Just add a white rule the list in Table Designer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines