Framemaker 12. Discretionary hyphenation not working

New Here ,
Nov 03, 2017 Nov 03, 2017

Copy link to clipboard

Copied

Hello,

I have a document where I want to use discretionary hyphenation but when I enter one (CTL+ -) it does not hyphenate at the position chosen and causes surpression of hyphenation for the whole word.

Why?

Views

295

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 04, 2017 Nov 04, 2017

Copy link to clipboard

Copied

Try checking your settings for Shortest Prefix and Shortest Suffix, and Shortest Word. Note that FrameMaker counts punctuation as letters when using hyphenation. For example, if a word that has a period or parenthesis those characters will be counted as letters in the Prefix/Suffix.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Nov 04, 2017 Nov 04, 2017

Copy link to clipboard

Copied

Thanks for the reply Barbara, no that isn't the problem, unfortunately.

This is what appears with the standard hyphenation on

And when I insert CTRL- in the two places I would prefer the hyphenation - "Patienten-positionierung" and "Kontakt-ansicht" it acts like a suppress hyphenation marker (ESC ns at start of word)

the settings for hypenation are:

The only other place I know to control line endings is the "Text Options" and I have checked them and can't see any problem. There are this.

I can't think of any other place the CTRL- is controlled.

This only happens in this set of documents so it is a setting somewhere.

Thanks for any input you can offer.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 04, 2017 Nov 04, 2017

Copy link to clipboard

Copied

You're right that there is something in that particular document. I'm not able to reproduce the issue.

All I can suggest are some general troubleshooting techniques. For example, you could save the file as MIF and then open the MIF in FrameMaker. Or, you could try File > Import Formats from your template.

I haven't experienced the issue you're facing but on rare occasions, I've solved an issue by selecting everything in the document and pasting it into a brand new document, then re-importing the template. 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 04, 2017 Nov 04, 2017

Copy link to clipboard

Copied

Another thought. Is there a non-breaking hyphen anywhere in the word (Esc h)?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines