Framemaker 12 won't display files

New Here ,
Jun 07, 2017

Copy link to clipboard

Copied

When I double-click a file to open it directly, Framemaker reports the following error.

frameerror.PNG

When I open Framemaker and click File>Open and select a Framemaker file, it will appear to open the file but no content is displayed. It is completely blank.  If I close, save as, or print the file, the file content appears in the background but it disappears when I close the save/print window.

This happens to every Framemaker file including new files. My colleagues can open and edit the files normally. I have uninstalled and reinstalled Framemaker 12 but it did not fix the problem. 

Kind regards.

Views

221

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Enthusiast ,
Jun 07, 2017

Copy link to clipboard

Copied

Hi,

do you auto-run any scripts?

It seems to me, that anything (a script in your startup folder)  switched display to off.

If you are familiar with scripts, you could start the ExtendScript Toolkit (ESTK) type in these lines or copy/paste and run it.

alert("Display : " +  app.Displaying);

if (app.Displaying == 0)

   {

   app.Displaying = 1;

   }

If Displaying is off it will show you "Display : 0" and switch it on.

ESTK can be found here: C:\Program Files (x86)\Adobe\Adobe ExtendScript Toolkit CC\ExtendScript Toolkit.exe

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Jun 07, 2017

Copy link to clipboard

Copied

Thanks Klaus,

This worked! However when I close the file and open it again I must open Extendscript and run the script again. Is there a way of permanently applying the fix?

I don't normally work with scripts in Frame.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Enthusiast ,
Jun 07, 2017

Copy link to clipboard

Copied

Hi,

just have a look at the script in your autorun.

If you don't need it in autorun, just remove it : file-> script -> library.

It seems to me that this script crashes and so it can't reset "displaying".

You should find hints in your console.

In this case you should contact the author.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 07, 2017

Copy link to clipboard

Copied

I think there's still something messed up in your installation - did you install it as a local admin? When you uninstalled, did you use a tool like revouninstaller to clean out all FM traces? After reinstalling, did you apply all patches?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more