Framemaker 2012 or 2015 Tab and Soft Returns displays as numbers

New Here ,
Aug 01, 2016 Aug 01, 2016

Copy link to clipboard

Copied

In Framemaker 2012 or 2015,  how do we change the Tab and Soft Returns characters from being displayed as numbers?

Thanks
Rich

Views

627

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Most Valuable Participant , Aug 01, 2016 Aug 01, 2016
Are you seeing these numbers when you have the View > Text Symbols option enabled,  but otherwise the required action (tab or soft/forced- return) does happen?If so, then it might be that the fm5font.ttf file in your \fminint is missing or corrupt.

Likes

translate

Translate

Translate
Most Valuable Participant ,
Aug 01, 2016 Aug 01, 2016

Copy link to clipboard

Copied

How were these characters entered in the first place?

A tab is \x08 and a soft-return is \x09. You can do a search & replace to get the correct characters in place.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 01, 2016 Aug 01, 2016

Copy link to clipboard

Copied

Arnis

The tab is entered by the Tab Key and soft return is entered by Shift-Enter Keys.  I tried what you suggested; I can find all the Tabs (\x08) and Soft Returns (\x09), but still shows numbers when I replace them, even if I manually re-enter the Tabs and Soft Returns, the numbers reappears. 

Tabs appear as 1.

Soft Returns appear as 2.

Multiple users here are having the same issue.

Thanks

Rich

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Aug 01, 2016 Aug 01, 2016

Copy link to clipboard

Copied

What font is being used and does this happen for any font just a specific one?

Also, are you using any Windows language settings/keyboards?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 01, 2016 Aug 01, 2016

Copy link to clipboard

Copied

Font being used is Times New Roman.  I tried different fonts and have the same issue.  Using default Windows and Keyboard settings.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Aug 01, 2016 Aug 01, 2016

Copy link to clipboard

Copied

Are you seeing these numbers when you have the View > Text Symbols option enabled,  but otherwise the required action (tab or soft/forced- return) does happen?

If so, then it might be that the fm5font.ttf file in your \fminint is missing or corrupt.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 01, 2016 Aug 01, 2016

Copy link to clipboard

Copied

Yes I see these numbers when Text Symbols option is enabled and the fm5font.ttf file is in the correct folder.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Most Valuable Participant ,
Aug 01, 2016 Aug 01, 2016

Copy link to clipboard

Copied

Are you seeing the proper symbols for markers, anchored frames, etc?

Check your maker.ini file (both the local user and the main one in the FM installation folder) [Files] section for the following two-lines:

FMFont=fminit\fm5font.ttf

FMSmallFont=fminit\fmsmall.fon

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 01, 2016 Aug 01, 2016

Copy link to clipboard

Copied

Only symbol that appears correctly is the Hard Return.  Both the maker.ini has those two lines included.  I'm waiting for IT personnel to re-install the fm5font.ttf file to see if that is causing this issue.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Advocate ,
Aug 02, 2016 Aug 02, 2016

Copy link to clipboard

Copied

I wanted to get more insight into this problem and hence I installed FM-13 on my wife's PC (it's a simplistic W7 installation).

I can get the mentioned effect only when renaming/deleting the font $HOME\fminit\fm5font.ttf so that it is no more available to FM.

NoTextSymbols2.PNG

I can not reproduce this on my working PC because there the font exists also in the Windows font directory (from other FM-installations) and it can not be renamed/deleted there.Character Designer claims that the figures shown here are from TimesNewRoman. But this is not true at all as the shape of the 1 in Times is that displayed with "Table 1:".

Another issue demonstrated here is this: The font contains two sets of glyphs (x01 ... x07) which are used for the text symbols and x31 ... x37 (code places of figures). In the latter the glyphs are not in the correct order. This may be the reason why in the screen shot the TAB is displayed by a 1 and not by a 2...

NoTextSymbols3.PNG

A code table reveals this:

NoTextSymbols4.png

So there are plenty of mysteries around this font - it must be in proper place (depending on FM version). If it's missing, FM (at least FM-13) does make any note to the user and nothing is written into the FM log.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
New Here ,
Aug 02, 2016 Aug 02, 2016

Copy link to clipboard

Copied

Actually had to re-install the fm5font.ttf (Right-click on File and Install).  Once it was re-installed, everything is back to normal.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines