Highlighted

Framemaker 2015 issue with losing italics in legacy files

Community Beginner ,
Jan 27, 2016

Copy link to clipboard

Copied

Our team just upgraded to FrameMaker 2015 (from FrameMaker 12). We're running into some issues where we lose italic formatting in existing files and templates, and/or the "Emphasis" character tag that we use to apply italic formatting does not work correctly.

For example, when I open our existing template in FrameMaker 2015, the "Emphasis" character tag is still defined correctly – it shows the "Italic" property in the "Angle" field. But, when I select a word or phrase and apply the "Emphasis" style, the text does not get italicized. Frame shows that the "Emphasis" tag has been applied, but the text is still roman (i.e., not italicized).

When I change the "Angle" property from "Italic" to "Kursiv" that seems to resolve the issue, but I'm not sure why.

We are also seeing inconsistent issues of italic formatting getting dropped altogether in existing files, or getting dropped just from cross-references, etc.

Are there any known issues with italic formatting in FrameMaker 2015? Or anything we might be doing that triggers this?

FYI: We are all on Windows 7.

Thanks in advance...

Most Valuable Participant
Correct answer by Arnis_Gubins | Most Valuable Participant

Have you checked what's in your templates? It could be that the plug-in (or perhaps another start-up initial script or a different plug-in) is loading something that leads to this behaviour. It sort of sounds like the template catalogs are getting (re-)imported at start-up to ensure a uniform behaviour in your workgroup.

Views

768

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Framemaker 2015 issue with losing italics in legacy files

Community Beginner ,
Jan 27, 2016

Copy link to clipboard

Copied

Our team just upgraded to FrameMaker 2015 (from FrameMaker 12). We're running into some issues where we lose italic formatting in existing files and templates, and/or the "Emphasis" character tag that we use to apply italic formatting does not work correctly.

For example, when I open our existing template in FrameMaker 2015, the "Emphasis" character tag is still defined correctly – it shows the "Italic" property in the "Angle" field. But, when I select a word or phrase and apply the "Emphasis" style, the text does not get italicized. Frame shows that the "Emphasis" tag has been applied, but the text is still roman (i.e., not italicized).

When I change the "Angle" property from "Italic" to "Kursiv" that seems to resolve the issue, but I'm not sure why.

We are also seeing inconsistent issues of italic formatting getting dropped altogether in existing files, or getting dropped just from cross-references, etc.

Are there any known issues with italic formatting in FrameMaker 2015? Or anything we might be doing that triggers this?

FYI: We are all on Windows 7.

Thanks in advance...

Most Valuable Participant
Correct answer by Arnis_Gubins | Most Valuable Participant

Have you checked what's in your templates? It could be that the plug-in (or perhaps another start-up initial script or a different plug-in) is loading something that leads to this behaviour. It sort of sounds like the template catalogs are getting (re-)imported at start-up to ensure a uniform behaviour in your workgroup.

Views

769

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 27, 2016 0
Most Valuable Participant ,
Jan 27, 2016

Copy link to clipboard

Copied

The usage of Italic vs. Kursiv all depends upon the actual typeface that you are using. What fonts are you using in the documents where this happens?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 27, 2016 0
Community Beginner ,
Jan 27, 2016

Copy link to clipboard

Copied

Ah, ok, thanks. We are restricted to using a single font family: Akzidenz-Grotesk Pro

All 28 fonts in the family are Open Type (.otf).

We have always used the "Italic" property in the past with Frame 10–12 – it's not until installing Frame 13 that we ran into this issue...

Thanks again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 27, 2016 0
Most Valuable Participant ,
Jan 27, 2016

Copy link to clipboard

Copied

The Akzindez-Grotesk Pro family does have the Italic version according to the Berthold descriptions, so the font family shouldn't be the issue in this case.

Have you tried a brand new document in FM2015 to see if FM shows an Italic version of this font and another standard font (such as Arial) in the Angle dropdown list of the Designers? If Arial shows Italic and the Akzidenz shows Kursiv, then I would wonder if the internal setting in the Akzindenz font is suspect [i.e. have these been modified with a font editor?].

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 27, 2016 0
Community Beginner ,
Jan 27, 2016

Copy link to clipboard

Copied

If I understood you correctly, Akzidenz, like Arial and Times New Roman, is just showing "Italic" in the "Angle" drop-down, not "Kursiv" (see image attached/below).

(This was in a new blank document not based on our template.)

Appreciate your help. Happy to test anything else that might be good to check...

Akzidenz_font_Italic.jpg

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 27, 2016 0
Most Valuable Participant ,
Jan 27, 2016

Copy link to clipboard

Copied

It looks like FM is behaving properly with your Akzidenz font.

I wonder if something in your existing documents is munged. Can you try to do a MIF-wash (i.e. save as MIF, open the MIF and re-save as a .fm file) on one of the mis-behaving files to see if this cleans out any cruft.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 27, 2016 0
Contributor ,
Jan 28, 2016

Copy link to clipboard

Copied

This might be a difference in the font configuration within the maker.ini file. This is found within the FrameMaker application. There is also a user-specific copy that can override the main settings. See the top of the main maker.ini file for details.

I'd investigate the following.

The Angles setting defines the vocabulary that is used for italicized fonts. This is the default for FM12:

;

; Definition of the font vocabulary:

;  Angles, Variations: a list of the words.

;  Weight: the list of words and the associated weight for Windows, if any.

;

Angles=Regular, Kursiv, Slanted, Oblique, Italic, Obliqued

Look for differences between FrameMaker 12 and 2015. Don't forget to check for overrides in your personal maker.ini files.

Also, search for Akzidenz-Grotesk in the files. Are there any settings in one file that are not in the other? Likewise for Kursiv.

Finally, the following might provide a workaround:

  1. Quit FrameMaker 2015.
  2. Open your personal FrameMaker 2015 maker.ini file in a text editor.
    This file is typically in \Users\<username>\AppData\Roaming\Adobe\FrameMaker\<version>.
  3. Add the following two lines:
    [WindowsToFrameFontAliases]
    AkzidenzGrotesque Pro, Italic, *=AkzidenzGrotesque Pro, Kursiv, *, Regular
    (I'm assuming there isn't already a WindowsToFrameFontAliases section)
  4. Save the maker.ini file
  5. Restart FrameMaker 2015.

If necessary try this again, changing the first occurence of AkzidenzGrotesque Pro to any variation you can find displayed in Windows, or within the font file itself (e.g.  AkzidenzGrotesque-Pro or AkzidenzGrotesquePro).

If this works, consider adding the setting to the main maker.ini file so it applies to all users.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 28, 2016 0
Most Valuable Participant ,
Jan 28, 2016

Copy link to clipboard

Copied

@Mike,

The maker.ini changes would be global, but the italic function worked properly in a new file for Jason, so it's a bit of an oddity why it happened in the upgraded documents only.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 28, 2016 0
Community Beginner ,
Jan 28, 2016

Copy link to clipboard

Copied

@Mike, @Arnis,

Thank you both (and apologies for the slow reply). I didn't find anything unusual in the maker.ini file, and adding the "[WindowsToFrameFontAliases]" lines to my personal maker.ini file didn't have any effect. (I should mention that we do make a couple font-related changes in the main maker.ini file, but when I reverted to the original maker.ini file the same issues were still occurring in the same way.)

Also, alas, I tried a MIF wash on one file, but that seemed to have no effect either. I'm stumped – I kinda thought that would fix it...

For what it's worth, several writers have run into some form of this issue now with our existing files, and we're seeing it in documents based on two separate templates. Also, I can start a new blank document in FrameMaker 2015, and this issue does not occur. But if I import everything from one of those existing templates, the italic issues do crop up. Not sure if that helps at all...

Anyway, appreciate your help, thanks again. If you think of anything else that would be good to try, I'm open to all suggestions   . . . And if we figure it out in the meantime, I'll be sure to post an update here...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 28, 2016 0
Most Valuable Participant ,
Jan 28, 2016

Copy link to clipboard

Copied

Jason,

Have you tried importing everything except the Character catalog (or conversely just the Character catalog) from the templates into a new file? How does the italic vs kursiv behave then?

You also could try searching through the MIF versions of your template, or any converted documents, to see where the string "Kursiv" is located. This may give you a clue as to where things went astray. If you can (easily?) fix it in the template(s), then just re-import the appropriate template into the mis-behaving documents.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 28, 2016 0
Community Beginner ,
Jan 29, 2016

Copy link to clipboard

Copied

Hi Arnis,

Ok, here's what I found. (Before I tested all this, I reverted to the original maker.ini files.)

When I open a new blank document in Frame 2015, there is an existing "Emphasis" character tag. For me and at least one other colleague, this style is set to the "Kursiv" angle by default. Like I mentioned before, the style works fine on any font.

But, if I change the "Angle" property to "Italic," the style no longer works on *any* font on my system. When I apply it, the text stays in roman format, even though Frame shows that the style is applied.

I had been planning to try deleting and reinstalling the Akzidenz-Pro fonts, but now I'm not sure what the issue might be, or what to try next. I guess we can just update our templates and files to all use the "Kursiv" angle instead, since that seems to work. I just wish we understood why "Italic" doesn't work all of a sudden.

In case it helps, we all just recently installed Tech Comm Suite 2015 and Creative Cloud 2015. So maybe something did get hosed on our systems somewhere along the way?...

p.s. I searched the MIF version of both templates, but no instances of "kursiv" came up.

Thanks again for all your help...

Jason

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2016 0
Most Valuable Participant ,
Jan 31, 2016

Copy link to clipboard

Copied

I don't think anything in the CC installation hosed how the fonts are handled in FM. This now sounds more like a global setting, which [as Mike suggested] is controlled by your maker.ini settings.

Check your maker.ini file(s) [both the general one in the FMHome folder and in your personal AppData area]. Look (again) in the [Fonts] section for the entries pertaining to "Angle=..." and also check the [FontAngleAliases] section to see if any re-definitions exist there.

The default entries I have [same as Mike's] are:

Angles=Regular, Kursiv, Slanted, Oblique, Italic, Obliqued   [FM is sensitive to the order of entries for some maker.ini entries, but I don't know about this one, so verify that yours is identical]

and

[FontAngleAliases]  <<--- [Check for a Kursiv or Italic entry here]

Obliqued=Oblique

Also check for any Font Alias settings that use Kursiv (either side of the equal sign) in the [WindowsToFrameFontAliases] and [UnknownToKnownFontMap] sections.

Note: the personal maker.ini file in the C:\Users\<username.>\AppData\Roaming\Adobe\FrameMaker\13 area will override any setting in the master maker.ini located in the FMHome folder.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 31, 2016 0
Community Beginner ,
Feb 01, 2016

Copy link to clipboard

Copied

Hi Arnis,


I appreciate all your patient replies with this . . . This has gotten me closer to a solution, I think, but I'm still not quite there...

First, real quick, there was only a single instance of "kursiv" in either maker.ini file – it was in the "Angles" definition, which was identical for me to what you and Mike listed (including the order).

This got me thinking though . . . I next tried removing a plug-in that we purchased for a prior version and then restarting Frame and creating a new blank document. (This plug-in loads at startup and uses an FM file that contains content from our templates.) I thought this did the trick. The default "Emphasis" character tag was now showing "Italic" by default instead of "Kursiv." And everything appeared to be working as it should – when I applied the "Emphasis" character tag, the text actually did get italicized (even when I changed the font to Akzidenz-Grotesk Pro).

But then as soon as I opened existing files based on our templates, the italic issue was still there, as before.

What's more, opening a legacy file seemed to change Frame's behavior for that session. That is, after opening the legacy file, I tabbed back over to the new, blank document I had started with. Now, when I checked the Emphasis tag, it was showing "Kursiv" as the angle instead of "Italic," as it had before.

When I shut down Frame, then reopened it and started another new, blank document, the "Emphasis" tag and italic functionality continued to work properly until I opened a legacy document. Then it didn't work properly in any file.

This makes me think the issue is with our templates somehow. I tried another MIF wash on the templates, but the issue persists. So strange...

Thanks,

Jason Nichols

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2016 0
Most Valuable Participant ,
Feb 01, 2016

Copy link to clipboard

Copied

Have you checked what's in your templates? It could be that the plug-in (or perhaps another start-up initial script or a different plug-in) is loading something that leads to this behaviour. It sort of sounds like the template catalogs are getting (re-)imported at start-up to ensure a uniform behaviour in your workgroup.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2016 0
Community Beginner ,
Feb 01, 2016

Copy link to clipboard

Copied

Hi Arnis,

Well, here's what seems to be working, after an initial test:

  1. Create a MIF version of the template file.
  2. Open the MIF version of the template.
  3. Delete the "Emphasis" character tag.
  4. Find any instances where the "Emphasis" character style had been applied. Remove that formatting by applying "Default paragraph font."
  5. Recreate the "Emphasis" character tag with the same settings as before (i.e., using "Italic" as the "Angle" property).
  6. Save the MIF file as a regular FM document, overwriting the original template file.

Now, when I open the template file, the "Emphasis" character style seems to work as it did before the upgrade.

The challenge now is figuring out how best to clean up all our existing work files. I can import character styles from the cleaned up template, but in the first test I did, the italic formatting had disappeared in most places. I had to reapply the "Emphasis" style to re-italicize the text in each case.

I'll test this some more and let you know if I found out anything else. And thanks again for all your help!

Jason Nichols

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2016 0
Most Valuable Participant ,
Feb 01, 2016

Copy link to clipboard

Copied

Jason,

You should be able to import just the Character Catalog from a clean template (or just a blank document) that has just the correct Italic definition for the "Emphasis" tag. This should update any existing versions of Emphasis tags in a document.

Try this on a copy of a currently munged document to see how it works.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2016 0
Community Beginner ,
Feb 02, 2016

Copy link to clipboard

Copied

Hi Arnis,

Yes, that did work. But there was a particular set of steps that had to be done in a particular sequence for this to work (for me anyway).

So, in case anyone else runs into this, here's the steps and sequence that seems to be working for me:

  1. Open a set of existing FM files where the italics issue needs to be fixed (such as the chapters in a book).
  2. Delete the "Emphasis" character style from each file. (For me, I also had to delete the "Equation Variables" character style in each file that contained it.)
  3. Save and close each file.
  4. Close FrameMaker.
  5. Open the template file that has already been MIF washed and had the "Emphasis" style recreated.
  6. Open the book file containing the FM files you updated in Step 2.
  7. Import just the "Character Formats" from the template into the files in the book that you updated in Step 2. (Or if there's no book file, open each individual file and import the Character Formats file-by-file.)
  8. Close the template file. Do NOT save changes to the template.
  9. Save and close the book file and/or all the individual files you're updating.
  10. Close FrameMaker.
  11. Reopen your updated FM files. Try applying the "Emphasis" character style to make sure it works. Check your files to make sure no existing italic formatting was lost (especially within cross-references).

I've passed this along to our team, so we'll see if this works okay for everyone else...

In any case, it looks like we're on our way. Really appreciate your help, thanks again!

Jason

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 02, 2016 0