Highlighted

FrameMaker 2015 throws an error when opening files

New Here ,
Jul 01, 2015

Copy link to clipboard

Copied

I just Installed FrameMaker 2015 (no errors), but when I open a FM 11 file, even after updating it to FM 2015 and importing new formats and element definitions, I receive the following error message in the FM console:

maker: While reading menu customization file C:\Users\smayer.AVIDWW\AppData\Roaming\Adobe\FrameMaker\13\WorkSpaces\Structured\WYSIWYGView\menus\menus_structured_authoring.cfg,

maker: (1414) Command or menu named ChildElements has not been defined.

maker: (1415) Command or menu named SiblingElements has not been defined.

maker: (1417) Command or menu named ChildAttributes has not been defined.

maker: (1418) Command or menu named SiblingAttributes has not been defined.

maker: (1420) Command or menu named ChildElements has not been defined.

maker: (1421) Command or menu named SiblingElements has not been defined.

maker: (1423) Command or menu named ChildAttributes has not been defined.

maker: (1424) Command or menu named SiblingAttributes has not been defined.

The configuration file referenced in the message has what I'd expect in terms of the relevant menus. And the Expand/Collapse menus in fact do have the child/sibling elements/attributes options. So I'm puzzled as to why I'm getting this error message. Has anyone else seen it or have any idea how to address the issue? Thanks.

     --Steve

FrameMaker 2015 13.0.0.333 (structured)

DITA 1.2 structured application (I do have a few customizations, but nothing that would affect a menu cfg file)

Windows 7 Professional

TOPICS
Structured

Views

857

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

FrameMaker 2015 throws an error when opening files

New Here ,
Jul 01, 2015

Copy link to clipboard

Copied

I just Installed FrameMaker 2015 (no errors), but when I open a FM 11 file, even after updating it to FM 2015 and importing new formats and element definitions, I receive the following error message in the FM console:

maker: While reading menu customization file C:\Users\smayer.AVIDWW\AppData\Roaming\Adobe\FrameMaker\13\WorkSpaces\Structured\WYSIWYGView\menus\menus_structured_authoring.cfg,

maker: (1414) Command or menu named ChildElements has not been defined.

maker: (1415) Command or menu named SiblingElements has not been defined.

maker: (1417) Command or menu named ChildAttributes has not been defined.

maker: (1418) Command or menu named SiblingAttributes has not been defined.

maker: (1420) Command or menu named ChildElements has not been defined.

maker: (1421) Command or menu named SiblingElements has not been defined.

maker: (1423) Command or menu named ChildAttributes has not been defined.

maker: (1424) Command or menu named SiblingAttributes has not been defined.

The configuration file referenced in the message has what I'd expect in terms of the relevant menus. And the Expand/Collapse menus in fact do have the child/sibling elements/attributes options. So I'm puzzled as to why I'm getting this error message. Has anyone else seen it or have any idea how to address the issue? Thanks.

     --Steve

FrameMaker 2015 13.0.0.333 (structured)

DITA 1.2 structured application (I do have a few customizations, but nothing that would affect a menu cfg file)

Windows 7 Professional

TOPICS
Structured

Views

858

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 01, 2015 0
Adobe Employee ,
Jul 02, 2015

Copy link to clipboard

Copied

Hello Steve,

Thanks for reporting the issue. We've logged a bug for the same.

Regards,

Harsh Gupta

FrameMaker Engineering

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 02, 2015 0
New Here ,
Jul 06, 2015

Copy link to clipboard

Copied

Hi Harsh,

Thanks for looking into it.

     --Steve

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 06, 2015 0
New Here ,
Feb 24, 2016

Copy link to clipboard

Copied

Hi Harsh,

we encountered the same issue. Any idea about the cause?

Wim

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
New Here ,
Feb 24, 2016

Copy link to clipboard

Copied

Hi Steve,

did you solve this?

Wim

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
New Here ,
Feb 24, 2016

Copy link to clipboard

Copied

Hi Wim,

No, I still get the error. I see it when I first launch FM and open an existing file or create a new one, even I'm just using one of the default templates Adobe supplies with FM 2015. It also happens intermittently with older files I open in FM. I haven't heard anything about the problem apart from Harsh's comment above. My workaround is to ignore the error message, since it doesn't seem to affect anything and the menu commands FM thinks are missing in fact are present.

     --Steve

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
Adobe Community Professional ,
Feb 24, 2016

Copy link to clipboard

Copied

This whole discussion should (a) be moved to the Structured forum & (b) has anyone performed the updates to FM2015 (there’s at least 2 of them) and tried this again?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
New Here ,
Feb 24, 2016

Copy link to clipboard

Copied

Jeff,

I'd be glad to move the discussion, but you have to be one of the forum's hosts (I'm not) to move discussions. Maybe an appropriate moderator will do it for us.

As for updates, yes, my installation of FM 2015 is up to date (13.0.2.433) and the problem persists.

     --Steve

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
Adobe Community Professional ,
Feb 24, 2016

Copy link to clipboard

Copied

Arnis will get around to moving it sometime (grin)

Meanwhile, I’d be tempted to PM Harsh to see what the bug # logged was & where it’s at.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
Most Valuable Participant ,
Feb 24, 2016

Copy link to clipboard

Copied

Moved.  [I'm not an early bird these days... ]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
Adobe Community Professional ,
Feb 24, 2016

Copy link to clipboard

Copied

LOL Arnis – with this weather, I don’t blame you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
New Here ,
Feb 25, 2016

Copy link to clipboard

Copied

Arnis,

Thanks for moving the discussion to the right forum.

I've taken Jeff's suggestion and pinged Harsh to see what the status of the bug is. I'll post whatever I find out from Adobe.

     --Steve

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2016 0
Explorer ,
May 04, 2016

Copy link to clipboard

Copied

Has anyone been able to fix this issue? I'm seeing the same error message.

thanks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 04, 2016 0
JCmayer LATEST
Explorer ,
May 11, 2016

Copy link to clipboard

Copied

Hello

Have you try to "save as" the FM11 in .mif and open it with FM2015 ?

Regards

JC

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 11, 2016 0