FrameMaker adds white spaces to text range formatted elements

Community Beginner ,
Mar 09, 2016

Copy link to clipboard

Copied

Hi all,

I encounter a weird behavior of FrameMaker when I open a with FrameMaker saved  sgml / xml file.

When a text range formatted element like "Emphasis" occurs standalone, FrameMaker adds white spaces in front and after the text range formatted content.

If there is plain text before the text range formatted content no white spaces are added.

Is there any way to stop FrameMaker from adding white spaces? e.g a special read/write rule?

Snippet from the EDD:                                                                    

Example from the import

Structured View of the Example

TOPICS
Structured

Views

494

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Contributor ,
Mar 09, 2016

Copy link to clipboard

Copied

Hi,

I think this is related to the bug described by Lynn. It looks like there is a bug in FM how it handles LF/CR in XML import if the maker.ini setting RemoveExtraWhiteSpacesOnXMLImport.

I've seen it myself on FM 2015, XML roundtrip add space to inline-type elements.

Default value is On, change it to Off and give it a try.

BR,

Martti

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Community Beginner ,
Mar 09, 2016

Copy link to clipboard

Copied

Hi Martti,

thx for the tip, I gave it a try but to no avail. Even if  RemoveExtraWhiteSpacesOnXMLImport is turned off the result is the same.

I am using FrameMaker 12 on a Windows 7 64bit professional machine.

Here is the snippet from the sgml/xml file I opened:

<GRAPHTEXTCONTENT>

      <LIST LISTTYPE="UNNUMBERED">

       <LISTINTRO>The rotary plunger module consists of:</LISTINTRO>

       <ITEM>

        <PARAGRAPH>cylinder driven <EMPHASIS>device carrier plungers (1)</EMPHASIS></PARAGRAPH>

       </ITEM>

       <ITEM>

        <PARAGRAPH>

         <EMPHASIS>vacuum tubes (2)</EMPHASIS>

        </PARAGRAPH>

       </ITEM>

       <ITEM>

        <PARAGRAPH>

         <EMPHASIS>plunger heads (3)</EMPHASIS>

        </PARAGRAPH>

       </ITEM>

       <ITEM>

        <PARAGRAPH>cylinder driven <EMPHASIS>contact site plungers (4)</EMPHASIS></PARAGRAPH>

       </ITEM>

       <ITEM>

        <PARAGRAPH><EMPHASIS>plunger servo motor</EMPHASIS> (not visible)</PARAGRAPH>

       </ITEM>

      </LIST>

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Mar 09, 2016

Copy link to clipboard

Copied

Th,

   Since you mention SGML, are you working with SGML or with XML?

   As I stated in a recent post, knowing when white space is significant is extremely difficult, even for people. I don't think an automatic process can always interpret it the way it is intended.

   Anyway, thank you for posting your input. It looks like the use of the EMPHASIS element is immaterial to the result you are getting. If you are using SGML, SGML's rules for white space include ignoring a line break immediately following a start-tag or immediately preceding an end-tag, but do not ignore indentation spaces after a start-tag and any immediately following line-break or preceding an end-tag. Thus, if you have

<CHAPTER>

    <PARAGRAPH>

         xxx

     </PARAGRAPH>

</CHAPTER>

the spaces before "xxx" and the line-break and spaces following "xxx" are all significant and come into FM as spaces. It does not matter whether the "xxx" occurs within an EMPHASIS.

In XML, by default the RemoveExtraWhiteSpacesOnXMLImport option is set to On and these spaces (and those you asked about) are ignored. If you set this option to Off in your maker.ini, the spaces come in.

Martti, as far as I know, the bug I reported in RemoveExtraWhiteSpacesOnXMLImport only affects incorrect deletion of a space after a cross-reference.

By the way, there was another recent discussion on handling of white space during XML import: Carriage return handling different - FM11 to FM2015.

   --Lynne

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Th__Zeisig AUTHOR LATEST
Community Beginner ,
Mar 09, 2016

Copy link to clipboard

Copied

Hi Lynne,

yes we still work in sgml.

If I understand you correctly the ini file option "RemoveExtraWhiteSpacesOnXMLImport" has no influence on sgml files.

If the sgml file would look as follows:

  <PARAGRAPH><EMPHASIS>plunger heads (3)</EMPHASIS></PARAGRAPH>

Then the result of the import in FrameMaker should show no white spaces before and after the plain text, am I right?

Because the line   <PARAGRAPH>cylinder driven <EMPHASIS>device carrier plungers (1)</EMPHASIS></PARAGRAPH>

renders perfectly in FrameMaker - now I understand why there is always a difference, when the emphasis element is preceeded by plain text.

But in the end it seems that we have to live with it.

Thank you

BR,

Thomas

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more