Locked

FrameMaker not recognizing installed fonts

Community Beginner ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

I am having issues with FrameMaker not recognizing installed fonts. I am currently running Adobe FrameMaker 2017. I there are five fonts that show as unavailable however the fonts have been properly installed on my computer. Any guidance? I can provide screenshots.

 

TOPICS
Error, Formatting and numbering

Views

860

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines

correct answers 1 Correct Answer

Adobe Community Professional , Nov 26, 2019 Nov 26, 2019
Adobe Community Professional ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

When is it claiming they're unavailable?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

In the console when I open the book file and the fm file.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

If you create a brand new FM doc, are the missing fonts available for using in the doc? If not, then there's something about those fonts that FM thinks aren't installed correctly.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

I created a new file in the book file and a new file just in framemaker and did not get the fonts not available message in either file.

 

 

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

Fine, but can you select them for use in a paragraph tag in that new doc?

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

Is your default printer inside FM, the Adobe PDF printer instance? If not, it should be - that often clears up "unavailable fonts" messages.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

Gotcha! There are four fonts missing, two I can select from the dropdown in character designer and two I cannot.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

I just changed the default printer to adobe pdf and that increased the number of unavailable fonts. And just to clarify, these are fonts that have been installed.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

So that indicates that the fonts were installed or associated with your printer - check your Windows list of fonts to ensure that all the missing ones are installed there or allow FM to do the font substitution it wants and save the result.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

Thank you for your help, how do I allow FM to do the font substitution permanently? I've saved and reopened this file many times and the error messge still appears.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Community Beginner ,
Nov 26, 2019 Nov 26, 2019

Copy link to clipboard

Copied

That worked. Thank you!

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Dec 17, 2019 Dec 17, 2019

Copy link to clipboard

Copied

Screen captures of the console would definitely help here...

You'll likely find that the missing fonts are similar, but not from the same foundry (font company) as the fonts you have installed on your machine.

Another possibility is that the style of the font is slightly different than what you have installed. Helvetica, for example, has a maddening number of variants, and each variant used must be installed on your system in order to avoid font substitution and errors.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 25, 2020 Jun 25, 2020

Copy link to clipboard

Copied

Now I'm getting the unavailable font message. These fonts are enabled through Adobe fonts and are not installed anywhere else on my system (that is to say, they are not in Windows fonts). Yesterday I fixed it by going to the Adobe Fonts page and discovered that for some reason it thought I wasn't using these fonts, despite my using them on a daily basis because they're our corporate font. I clicked the little icon telling it that yes, I am using these fonts and yesterday things were fine.

 

Today I open the same book I was working on yesterday and I 'm getting the same bloody message about the fonts not being available. This time even Adobe Fonts is saying they're available.

 

So why doesn't FRAMEMAKER think they're available? There's no conflict because I don't have them installed through Windows fonts, but I tell you, I'm about to disable everything in Adobe Fonts and just reinstall the font files from Google because this. is. pants. All I can think is that in their attempt to fix the Welcome screen, they've screwed something else up.

 

image.png

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines
Adobe Community Professional ,
Jun 25, 2020 Jun 25, 2020

Copy link to clipboard

Copied

How did my previous post get marked as correct? And it doesn't seem to be responding to my attempts to unmark it.

 

Anyway, today's fix was making sure that Creative Cloud launches with login and rebooting the machine.

 

ETA: Ah, that's got it unmarked. That was weird.

Likes

translate

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
community guidelines