Highlighted

Heading levels in the map

Explorer ,
Oct 30, 2018

Copy link to clipboard

Copied

Hi

I'm a new user with FrameMaker. I'm still using the trial version and learning the basics.

I'm trying to learn creating structured PDF manuals. I have created testing topics and tasks and used those in a bookmap (and ditamap). I have added the files with Insert child and Insert sibling commands. But when I view the published pdf the heading numbering goes as shown below.

1. Heading 1

     1.1 Subheading 1

     1.1 Subheading 2

     1.1 Subheading 3

2. Heading 2

     2.1 Subheading 4

     2.1 Subheading 5

All the modules have the same kind of title (title.0) as my thinking model is that I cannot know if the module is used in the same level in all the manuals.

Could someone give me a hint how to continue from here?

IT IS WORKING!

Yesterday just before I left the office I found one old discussion from the forum and there was a suggestion which was new for me.

The suggestions was to use numbering format C:<$chapnum>.<$sectionnum>. instead of C:<$chapnum>.<n+>. This was the solution. I clicked the title.1 and changed the format in paragraph designer and clicked Apply. Repeated this to other modules and that was it. Now I have to learn how to make it automatic, but at least now I have the solution.

Does anyone know why C:<$chapnum>.<$sectionnum>. instead of C:<$chapnum>.<n+>. works as C:<$chapnum>.<n+>. was the instruction I found from everywhere and it was there also automatically? 

TOPICS
Structured

Views

388

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Heading levels in the map

Explorer ,
Oct 30, 2018

Copy link to clipboard

Copied

Hi

I'm a new user with FrameMaker. I'm still using the trial version and learning the basics.

I'm trying to learn creating structured PDF manuals. I have created testing topics and tasks and used those in a bookmap (and ditamap). I have added the files with Insert child and Insert sibling commands. But when I view the published pdf the heading numbering goes as shown below.

1. Heading 1

     1.1 Subheading 1

     1.1 Subheading 2

     1.1 Subheading 3

2. Heading 2

     2.1 Subheading 4

     2.1 Subheading 5

All the modules have the same kind of title (title.0) as my thinking model is that I cannot know if the module is used in the same level in all the manuals.

Could someone give me a hint how to continue from here?

IT IS WORKING!

Yesterday just before I left the office I found one old discussion from the forum and there was a suggestion which was new for me.

The suggestions was to use numbering format C:<$chapnum>.<$sectionnum>. instead of C:<$chapnum>.<n+>. This was the solution. I clicked the title.1 and changed the format in paragraph designer and clicked Apply. Repeated this to other modules and that was it. Now I have to learn how to make it automatic, but at least now I have the solution.

Does anyone know why C:<$chapnum>.<$sectionnum>. instead of C:<$chapnum>.<n+>. works as C:<$chapnum>.<n+>. was the instruction I found from everywhere and it was there also automatically? 

TOPICS
Structured

Views

389

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 30, 2018 0
Advisor ,
Oct 30, 2018

Copy link to clipboard

Copied

At first glance, and given I don't use FM for my DITA work, that looks pretty much like what I'd expect to see … You're right to remember that topics might be re-used at different levels, but I'm not sure why you have numbering at both ends of the titles.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 30, 2018 0
Explorer ,
Oct 31, 2018

Copy link to clipboard

Copied

Ok that was a little bit misleading example. Sorry for that. The numbers after the titles were just to show that this is another topic. So the same as

1. Heading

     1.1 Subheading

     1.1 Also a subheading

     1.1 Again another subheading

2. Another heading

     2.1 Another subheading

     2.1 And another subheading

So the problem is: Why I don't have 1.1, 1.2, 1.3, 2.1 and 2.2.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2018 0
Participant ,
Oct 31, 2018

Copy link to clipboard

Copied

You say that you're using the same paragraph format (title.0) for both 1. heading and 1.1 subheading, but I don't think that can be the case because the numbering is different between the two.

If you look at the subheading paragraph format on the generated fm file (which is probably automatically applied based on an output template - so you don't have to worry about whether its the same as top level headings), and check the numbering tab, I suspect you'll see something like <$chapnum>.<n> in the Format: textbox. Try changing this to <$chapnum>.<n+> so the second number knows that it's meant to increment.

Shout if you're still stuck.

Kat

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 31, 2018 0
Explorer ,
Nov 01, 2018

Copy link to clipboard

Copied

Thank you for the reply!

Yes the title level is the same when you open the xml-file. But when I have created a ditamap or a bookmap and then Save ditamap as "Book with fm components" and I open the fm-files I see the heading levels as title.0 and title.1 as those should be. For the title.0 the numbering is C:<$chapnum>. (space after last dot) and for the title.1 the numbering is C:<$chapnum>.<n+>. (space after last dot)

So the format is as you suggested. I'm confused. Looks like the sub-chapters don't know about each other and both think that they are the first sub-chapter.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2018 0
Explorer ,
Nov 02, 2018

Copy link to clipboard

Copied

Is there a need to define somehow that which is the first subchapter or that the certain subchapter is included in a group of subchapters?

From a book level I tested to force the chapter numbering to start from a different number (Format - Document - Numbering). I was able to do this for the chapter level. BUT when I tested the same in Section level, the value still remains the same which is 1. What can be overwriting the numbering?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2018 0
Explorer ,
Nov 03, 2018

Copy link to clipboard

Copied

IT IS WORKING!

Yesterday just before I left the office I found one old discussion from the forum and there was a suggestion which was new for me.

The suggestions was to use numbering format C:<$chapnum>.<$sectionnum>. instead of C:<$chapnum>.<n+>. This was the solution. I clicked the title.1 and changed the format in paragraph designer and clicked Apply. Repeated this to other modules and that was it. Now I have to learn how to make it automatic, but at least now I have the solution.

Does anyone know why C:<$chapnum>.<$sectionnum>. instead of C:<$chapnum>.<n+>. works as C:<$chapnum>.<n+>. was the instruction I found from everywhere and it was there also automatically? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2018 0
Participant ,
Nov 05, 2018

Copy link to clipboard

Copied

Nice! Glad you got it working!

I think the difference between having to use <n+> vs <sectionnum> might be controlled by the ditafm-output.ini file under app data: C:\Users\Moi\AppData\Roaming\Adobe\FrameMaker\14. I had trouble getting it to work right until I set Generate flat book to 1. This file also contains a bunch of options for which numbering should continue from the previous section vs restart.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 05, 2018 0