How to link PDFs of multiple books in unstructured FM

Explorer ,
Dec 27, 2019

Copy link to clipboard


I've tried twice today to post a procedure for accomplishing this. I titled it:



Each time I do it I get back that it might be SPAM, and it does not get posted. Is it not possible to post solutions to problems? It's very odd. I'll copy/paste it here.


Hello Adobe FM community.

Summary: This is a procedure to allow multiple books in unstructured FM be cross referenced. Note that a setting in Acrobat Pro/Reader is also necessary. In this example my only desired output is PDF.

I have a project where I must heavily cross-reference 24 books. I am posting this procedure in case anyone runs into this problem. I want this to be crystal clear. My apologies for the lengthy explanation.

In this example, all .book files reside in the same common directory. Additionally, each PDF generated for each book will reside in this same directory. (The actual .fm files the book is comprised of can be in another folder).

Create all book files in the same folder. Let's call the folder  C:\RegulatoryBooks\

For example, this folder will contain all my 24 book files, so it will look something like this:





The .FM document files that make up each individual book resides in its own subfolder beneath the C:\RegulatoryBooks branch. I gave each subfolder the same name as the book, tho I do not think this is necessary. When creating each individual PDF, FM will automagically give the PDF the same name as the book it is based on. When complete, the folder <c:\RegulatoryBooks\ will contain a book file and a PDF file for each of those books.

Note that when updating each book (which creates the cross-reference), all cross-linked .book files must be open! It is not necessary to open the .FM file in each book containing a cross-reference, but the parent book file must be opened.

NOTE: When complete, Acrobat Reader/Pro may need a setting change. Make sure the following setting is invoked:

Once copied onto your hard drive, for the links to work, in Acrobat Reader (or Pro):

  1. From the menu at top; select pull-down Edit -> Preferences.
  2. From the Preferences window, select Category Documents.
  3. Under Open Settings, disable the checkmark Open cross-document links in same window. (note attached png file screen shot of the correct setting)
  4. Click <OK>.

For all the cross-references to work:

  1. All PDFs must reside in the same folder.
  2. PDF names cannot be changed!

That should do it!

Thanks to Bob Niland and Barb Binder for their insights in helping to get me on the right track.

Error, PDF output, Publishing







Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Have something to add?

Join the conversation