Highlighted

How to paste text as plain text by default?

New Here ,
Oct 19, 2015

Copy link to clipboard

Copied

How can I get FM to paste text as plain text by default, instead of having to use 'Paste Special'?

(Years ago there was a config file that could be changed, but memory fails me).

The config file is maker.ini.. There is a master copy within the FrameMaker application, but you should instead edit your own personal copy, which will override the master. You can find this in:

  • "\Documents and Settings\<username>\Application Data\Adobe\FrameMaker\<version>" on Windows XP
  • "\Users\<username>\AppData\Roaming\Adobe\FrameMaker\<version>" on Windows Vista and later.

FrameMaker rewrites your personal copy whenever it exits - so before you edit the file, quit FrameMaker, otherwise it will just overwrite your changes. Then backup the file, just in case.

The setting you want is ClipboardFormatsPriorities. It is very unlikely to already be present, but if it is, edit its value. Otherwise add this line to the [Preferences] section:

ClipboardFormatsPriorities=FILE, MIFW, MIF, RTF, OLE 2, META, EMF,  DIB, BMP, UNICODE TEXT, TEXT

The above is the default setting. Change the order to suit yourself; you might want one of the following:

  • ClipboardFormatsPriorities=FILE, UNICODE TEXT, TEXT, MIFW, MIF, RTF, OLE 2, META, EMF,  DIB, BMP
  • ClipboardFormatsPriorities=UNICODE TEXT, TEXT, FILE, MIFW, MIF, RTF, OLE 2, META, EMF,  DIB, BMP

Restart FrameMaker. Any problems, revert to your backup of the file.

TOPICS
Formatting and numbering

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to paste text as plain text by default?

New Here ,
Oct 19, 2015

Copy link to clipboard

Copied

How can I get FM to paste text as plain text by default, instead of having to use 'Paste Special'?

(Years ago there was a config file that could be changed, but memory fails me).

The config file is maker.ini.. There is a master copy within the FrameMaker application, but you should instead edit your own personal copy, which will override the master. You can find this in:

  • "\Documents and Settings\<username>\Application Data\Adobe\FrameMaker\<version>" on Windows XP
  • "\Users\<username>\AppData\Roaming\Adobe\FrameMaker\<version>" on Windows Vista and later.

FrameMaker rewrites your personal copy whenever it exits - so before you edit the file, quit FrameMaker, otherwise it will just overwrite your changes. Then backup the file, just in case.

The setting you want is ClipboardFormatsPriorities. It is very unlikely to already be present, but if it is, edit its value. Otherwise add this line to the [Preferences] section:

ClipboardFormatsPriorities=FILE, MIFW, MIF, RTF, OLE 2, META, EMF,  DIB, BMP, UNICODE TEXT, TEXT

The above is the default setting. Change the order to suit yourself; you might want one of the following:

  • ClipboardFormatsPriorities=FILE, UNICODE TEXT, TEXT, MIFW, MIF, RTF, OLE 2, META, EMF,  DIB, BMP
  • ClipboardFormatsPriorities=UNICODE TEXT, TEXT, FILE, MIFW, MIF, RTF, OLE 2, META, EMF,  DIB, BMP

Restart FrameMaker. Any problems, revert to your backup of the file.

TOPICS
Formatting and numbering

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 19, 2015 0
Contributor ,
Oct 19, 2015

Copy link to clipboard

Copied

The config file is maker.ini.. There is a master copy within the FrameMaker application, but you should instead edit your own personal copy, which will override the master. You can find this in:

  • "\Documents and Settings\<username>\Application Data\Adobe\FrameMaker\<version>" on Windows XP
  • "\Users\<username>\AppData\Roaming\Adobe\FrameMaker\<version>" on Windows Vista and later.

FrameMaker rewrites your personal copy whenever it exits - so before you edit the file, quit FrameMaker, otherwise it will just overwrite your changes. Then backup the file, just in case.

The setting you want is ClipboardFormatsPriorities. It is very unlikely to already be present, but if it is, edit its value. Otherwise add this line to the [Preferences] section:

ClipboardFormatsPriorities=FILE, MIFW, MIF, RTF, OLE 2, META, EMF,  DIB, BMP, UNICODE TEXT, TEXT

The above is the default setting. Change the order to suit yourself; you might want one of the following:

  • ClipboardFormatsPriorities=FILE, UNICODE TEXT, TEXT, MIFW, MIF, RTF, OLE 2, META, EMF,  DIB, BMP
  • ClipboardFormatsPriorities=UNICODE TEXT, TEXT, FILE, MIFW, MIF, RTF, OLE 2, META, EMF,  DIB, BMP

Restart FrameMaker. Any problems, revert to your backup of the file.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 19, 2015 1
New Here ,
Oct 19, 2015

Copy link to clipboard

Copied

Thank you!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 19, 2015 0