Highlighted

How to skip FM heading paragraph style's indent in chm output?

Participant ,
Apr 01, 2020

Copy link to clipboard

Copied

In my FM19 document my heading2 paragraph style has Indent 6 mm. Looks great in the pdf output.

However, in my chm output I want these headings without any indent at all.

I've tried adjusting different Publish Settings/Style Mapping attributes for the paragraph style, but without any success. What can I do?

 

The FM paragraph style has 6 mm indent.

I've found that if I go to the sts file's style mapping, and set the block attribute Text-indent to -6 mm, the chm output becomes properly zero indented. 6 - 6 = 0!

 

TOPICS
Formatting and numbering, Publishing

Views

544

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

How to skip FM heading paragraph style's indent in chm output?

Participant ,
Apr 01, 2020

Copy link to clipboard

Copied

In my FM19 document my heading2 paragraph style has Indent 6 mm. Looks great in the pdf output.

However, in my chm output I want these headings without any indent at all.

I've tried adjusting different Publish Settings/Style Mapping attributes for the paragraph style, but without any success. What can I do?

 

The FM paragraph style has 6 mm indent.

I've found that if I go to the sts file's style mapping, and set the block attribute Text-indent to -6 mm, the chm output becomes properly zero indented. 6 - 6 = 0!

 

TOPICS
Formatting and numbering, Publishing

Views

545

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 01, 2020 0
Adobe Community Professional ,
Apr 01, 2020

Copy link to clipboard

Copied

Not ideal, but here is what you can do:

1) Create a template that has heading2 with no indent.

2) Create your PDF as normal.

3) Import the paragraph formats from your template to remove the indent.

4) Publish your chm.

5) Restore the indent by importing paragraph formats from your original template.

There may be a settings in your sts file to avoid this, but I don't know what it is.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 01, 2020 0
Participant ,
Apr 01, 2020

Copy link to clipboard

Copied

The FM paragraph style has 6 mm indent.

I've found that if I go to the sts file's style mapping, and set the block attribute Text-indent to -6 mm, the chm output becomes properly zero indented. 6 - 6 = 0!

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 01, 2020 0