HTML5 Output Omitting Content

Community Beginner ,
Jun 28, 2016

Copy link to clipboard

Copied

I cannot figure out why FM is omitting a specific file from the HTML5 output... I just got a new work computer, and this wasn't happening on the old one (using the same .sts file). Any idea how to ensure all files are being added to the output?

Views

413

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 28, 2016

Copy link to clipboard

Copied

Conditioning? Show/Hide settings? Incorrect pagination?

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
SER617 AUTHOR
Community Beginner ,
Jun 28, 2016

Copy link to clipboard

Copied

None of these appear to be the issue. We have one type of conditional text (though not in the file being omitted). I applied the condition to the whole book (i.e. showed it), just in case. I also checked pagination, and the files are all paginated the same way.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
SER617 AUTHOR
Community Beginner ,
Jun 28, 2016

Copy link to clipboard

Copied

I have found a fix. I added a paratag from the omitted file to the FM TOC, and it now appears in the HTML5 output. I’m not clear on why it worked fine before without having to appear in the TOC, but I guess this will work. Thanks, Jeff for trying to help me troubleshoot.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
SER617 AUTHOR
Community Beginner ,
Jun 30, 2016

Copy link to clipboard

Copied

I am still working on this. I got most of the content to appear, but there are still several files that - when posted online - show "page not found." However, locally (from my hard drive), all content shows up when I open the index file. Not sure why some of the content is getting lost when posted online?? Here is an example: Adoption Proceedings Benchbook . If you click on "Summaries of Recent Updates" in the TOC, it shows page not found. However, if I view it offline, it is there... Any ideas? I did change the folder name to omit spaces (FM automatically creates the HTML5 folder, and it includes a space). However, I'm not sure why doing that would affect some files and not all of them...

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 30, 2016

Copy link to clipboard

Copied

I'm seeing "Summaries of Updates: January 2, 2016–May 1, 2016" but no "Summaries of Recent Updates" in the TOC of the example you show.

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
SER617 AUTHOR
Community Beginner ,
Jun 30, 2016

Copy link to clipboard

Copied

Sorry – yes that is it. If you click on Summaries of Updates: January 2, 2016–May 1, 2016, it shows a page not found. But locally, it shows up fine…

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Jun 30, 2016

Copy link to clipboard

Copied

Content is appearing fine for me - "Updates have been issued for the Adoption Proceedings Benchbook. A summary of each update appears below. The updates..."

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
SER617 AUTHOR LATEST
Community Beginner ,
Jun 30, 2016

Copy link to clipboard

Copied

So strange. My TOC link only says “Summaries of Updates” (it doesn’t have the date), and I’m getting the error. Someone in the next office opened it, and it works fine (and is displaying the whole TOC title like you are seeing)…

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more