Highlighted

I have installed FrameMaker 2017 and cannot run scripts

Community Beginner ,
Feb 22, 2018

Copy link to clipboard

Copied

Hi all,

I have recently installed FrameMaker 2017 and am unable to runs scripts.

From the FrameMaker menu I have tried File > Run and nothing happens.

I have also tried to create a new script by going file > Script > New Script and nothing happens.

I have looked in the start menu and Adobe Endscript is not there, which used to be packaged with FrameMaker 12 to create the scripts.

Is Adobe Extendscript required to be downloaded and installed to run scripts inside FrameMaker 2017?

Is there a work around to run scripts inside of FrameMaker 2017 without Adobe Extendscript.

Cheers

TOPICS
Scripting

Views

370

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

I have installed FrameMaker 2017 and cannot run scripts

Community Beginner ,
Feb 22, 2018

Copy link to clipboard

Copied

Hi all,

I have recently installed FrameMaker 2017 and am unable to runs scripts.

From the FrameMaker menu I have tried File > Run and nothing happens.

I have also tried to create a new script by going file > Script > New Script and nothing happens.

I have looked in the start menu and Adobe Endscript is not there, which used to be packaged with FrameMaker 12 to create the scripts.

Is Adobe Extendscript required to be downloaded and installed to run scripts inside FrameMaker 2017?

Is there a work around to run scripts inside of FrameMaker 2017 without Adobe Extendscript.

Cheers

TOPICS
Scripting

Views

371

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 22, 2018 0
Adobe Community Professional ,
Feb 22, 2018

Copy link to clipboard

Copied

You need the ExtendScript Toolkit application in order to run ExtendScript scripts with FrameMaker. Try installing FrameMaker again and see if ExtendScript Toolkit is one of the installation options.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 22, 2018 0
K.Daube LATEST
Advocate ,
Feb 26, 2018

Copy link to clipboard

Copied

Rick and BrakB,

Unfortunately ESTK CC (ESTK version 5) is not in the FM-14 = 2017 installation. It is only in the FM-13 = 2015 installation. The installation from https://creative.adobe.com/products/download/estk requires that you install the Creative Cloud on your system - which I hesitated to do so.

Although you have installed FM-14 = 2017, you can additionally install a trial version of FM13: install only ESTK, not FM itself. ESTK does not have a separate license.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2018 0