Highlighted

Importing Word files into FM 2015 strips character formatting

Community Beginner ,
Nov 21, 2015

Copy link to clipboard

Copied

‌Hi,

I'm hoping someone has a solution for me. After upgrading to FM 2015 (at great expense, I might add) I'm finding that imported MS Word  files (doesn't matter if they are 2003 or 2007 files) are getting nailed by Frame's new import dialog box. These are scientific documents, so they are filled with italics, superscripts, subscripts, and so on. No matter which options I choose in this fancy new dialog box, all this character formatting is gone. You can imagine my frustration at having to either 1) manually hunt for chemical formulas, Latin phrases, etc. and retypeset these properly, or 2) abandon FM 2015 completely and do the layout in FM 12, which preserves everything beautifully. Spending an hour with tech support was a waste of time.

Has anyone else had this problem, and if so, how did you solve it? Thanks in advance.

Gail

Views

672

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Importing Word files into FM 2015 strips character formatting

Community Beginner ,
Nov 21, 2015

Copy link to clipboard

Copied

‌Hi,

I'm hoping someone has a solution for me. After upgrading to FM 2015 (at great expense, I might add) I'm finding that imported MS Word  files (doesn't matter if they are 2003 or 2007 files) are getting nailed by Frame's new import dialog box. These are scientific documents, so they are filled with italics, superscripts, subscripts, and so on. No matter which options I choose in this fancy new dialog box, all this character formatting is gone. You can imagine my frustration at having to either 1) manually hunt for chemical formulas, Latin phrases, etc. and retypeset these properly, or 2) abandon FM 2015 completely and do the layout in FM 12, which preserves everything beautifully. Spending an hour with tech support was a waste of time.

Has anyone else had this problem, and if so, how did you solve it? Thanks in advance.

Gail

Views

673

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 21, 2015 0
Adobe Community Professional ,
Nov 23, 2015

Copy link to clipboard

Copied

If it was working in FM12 & now not in FM2015 (fully patched, right?) then you need to log a bug in the FM bugbase.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2015 0
Community Beginner ,
Nov 23, 2015

Copy link to clipboard

Copied

My version of FM is 13.0.1.385. I checked for further updates and it found none. I'll report the bug, but will also try tech support again to see if someone else might have a solution. If they do, I'll report back. Thanks Jeff.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 23, 2015 0
Community Beginner ,
Nov 24, 2015

Copy link to clipboard

Copied

Well, I have an update. I spent another hour or so on the phone with tech support, and he was stumped. He asked me to send him a file that he could do testing on. He emailed me the next day and said he had found a solution, so of course I got all excited.

Unfortunately, his solution was to import the Word file by reference, not by copying into the document. I told him  that does me no good whatsoever, because I can't format it, add links, add tables, figures, etc. We tried a few more potential fixes, but in the end he admitted that I uncovered a genuine bug in Frame 2015, which they were going to log and work on for the next patch.

The problem is, importing content from Word is critical to my work flow. I don't generate any content in FM; it's all imported through Word or graphics programs. So if this bug isn't fixed soon, I'm going to be asking for a refund, because I'll have to go back and use the old version.

Anyway, thought you might be interested in what happened.

Gail

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 24, 2015 0
Contributor ,
Nov 25, 2015

Copy link to clipboard

Copied

A further alternative would be to import the Word files into FrameMaker 12. Then select all, and copy to the clipboard. Open a document in FrameMaker 2015, and paste into that document. This gives you the working import filters of FrameMaker 12, and the other benefits of using FrameMaker 2015.

If you were feeling really brave, you could try replacing the filters in FrameMaker 2015 with those from FrameMaker 12. I don't have FrameMaker 2015, so I'm guessing a bit, but:

  1. Quit both versions of FrameMaker.
  2. Backup the maker.ini file within FrameMaker 2015 by making a copy, say as maker.ini-2015.
  3. Rename the filters subdirectory within FrameMaker 2015, say to filters-2015
  4. In the [APIClients] section of the FrameMaker 2015 maker.ini file, remove all entries that reference the filters subdirectory, and replace them with the equivalent entries from the FrameMaker 12 file. A diff of the two files will help you to see where changes are required.
  5. Copy the filters directory from FrameMaker 12 into FrameMaker 2015
  6. Restart FrameMaker 2015 and test.

Obviously this has lots of scope for breaking things. I'd not waste too much time on this - most likely, either it will or won't work, and that's it. If it doesn't work, quit both versions of FrameMaker and back out your changes.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 25, 2015 0
Community Beginner ,
Nov 25, 2015

Copy link to clipboard

Copied

I've done that in a pinch (import into the old version, then port over to 2015). But I've got about 1000 pages in this book and jockeying around that much is not appealing. I agree it's a workable solution, and when the Word file is filled with isotopes, chemical formulas, Latin phrases and the like, it's worth it. Just my luck I work for a bunch of scientists! 🙂

Gail

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 25, 2015 0
Most Valuable Participant ,
Nov 25, 2015

Copy link to clipboard

Copied

Gail,

Did you have the "Import Word document inline styles and list format" option enabled in the Word Import window? I tried this using both a docx and rtf files and it works just fine for me in FM2015:

FM2015_Word_inline_characters.png

If that option isn't enabled, then all of the inline formatting gets stripped.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 25, 2015 0
Community Beginner ,
Nov 25, 2015

Copy link to clipboard

Copied

Yes, we tried that over and over. It doesn't work for me, and it didn't work for the Adobe tester either. I'm importing into an FM template that has identical para. styles to the Word para. tags, so that the FM formatting will automatically overwrite Word formatting (I'm talking para styles, not char styles).

But putting aside the templates, we even tried importing into a blank FM document in case there was an issue with the FM template. Still didn't work. Meanwhile, I was able to demonstrate to him that the import worked perfectly using the previous version of FM and the same template. Something is rotten in Denmark.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 25, 2015 0
Most Valuable Participant ,
Nov 25, 2015

Copy link to clipboard

Copied

Are the character formats applied in Word using styles or as direct formats (i.e. overrides)?

Was the "blank" document, truly blank, i.e. absolutely no styles in the Catalogs or was it FM's default blank document? Try creating a truly blank document and then import a small sample [something similar to what I created using Word's formatting buttons] into that using the enabled option. How does that work? If it works, what's different betwen the inline formatting in the sample Word doc compared to your scientific papers?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 25, 2015 0
Community Beginner ,
Dec 02, 2015

Copy link to clipboard

Copied

Arnis,

Sorry this has taken so long, but I'm finally back to this issue again. I had a large project I had to finish up. I tried your method of creating a true blank document, and yes, the character formats are preserved when imported. But the problem is, I'm not importing into a blank document, I'm importing into my template, which has all the required formatting my client wants for his manuscripts. When I import into that, we're back to square one: the FM styles are supposed to overwrite the Word styles so that I have to do a minimum of manual formatting once the Word doc is imported. For 20+ years I didn't have to worry about character styles that were applied in Word; they were always preserved. Now with this 2015 version of Frame, the rest of my formatting looks just great, but the character formatting that was applied in Word is wiped out. Yes I am checking the little box that says Import Word Doc Inline Styles and List Formats. When that is checked, character formatting is preserved, but FM paragraph formatting is gone. If I don't check it, FM paragraph formatting is preserved but Word char formatting is gone.

If there is a way to apply italics, superscripts, subscripts, etc. in Word, inline, using character styles rather than overrides on Body tags, I am not aware of it. Nor could I find it in Word help. If that is the answer, please enlighten me.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 02, 2015 0
Most Valuable Participant ,
Dec 02, 2015

Copy link to clipboard

Copied

Have you tried applying your FM template to the Word import into the "blank" document instead of importing into directly into your template?

In Word, IIRC, you can create a Character style (Format > Style > New) and from the Style Type option select "Character". In the Styles window (ctrl+shift+alt+S), these will show with "a" at the far right instead of the pilcrow (for paragraph styles).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 02, 2015 0
Community Beginner ,
Feb 17, 2016

Copy link to clipboard

Copied

‌Arnis,

Beleven it or not, for the past 3 months I have been working with Adobe/TCS tech support on this issue, tackling the Word import in a hundred different ways. They eventually forwarded the issue to the "product team." After a few weeks, it appears they have decided that this is not a bug, but a feature:

"The new import feature in Framemaker 2015 is an enhancement from the previous versions. Thus in order to have the Word document superscripts to be reflected into the Fm file, you will have to select the “import Word Document inline styles and list format”. But as you have already mentioned, this will not allow you to keep the Fm formatting. So, we can conclude that this new feature does not allow word superscripts to be imported into Fm document while keeping the Fm formatting intact."

So, in essence, one of the great strengths of FrameMaker since long before Adobe bought them out, the fact that we could create templates that mirrored exactly the styles in the Word file and created perfectly formatted documents upon import, has been wiped out by this "enhanced" import filter. This is important enough to my work that I will have to go back to FM 11 and I'm wondering if I should drop my FM 2015 subscription.

Thought you might be interested in what happened with this case.

Gail

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 17, 2016 0
Most Valuable Participant ,
Feb 17, 2016

Copy link to clipboard

Copied

Sigh... Another case of BAD (Broken As Designed). There were quite a number of things [from the testers] that were ignored  during the pre-release development of this new Word Import module.

You might be able to add-in the older Word Import filter from an earlier FM package by some edits to the maker.ini and copying in the appropriate .dll file(s). [Not tested and definitely not endorsed - just a possibility...]

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 17, 2016 0
Adobe Employee ,
Feb 18, 2016

Copy link to clipboard

Copied

Hi Gail,

We were looking at the issues mentioned on this thread.

For that we created and have attached a word file "SampleFile.docx" on which we performed few steps as mentioned below.

  1. In "FM2015_Same_As_FM12.PNG", we get the styling of Word document by just Checking On "Import Word Documnet Inline Styles and List Formats".
  2. In "FM2015_Extra.PNG", we get the features of FM Paragraph Tag and also the Inline styles present in Word doc (Follow steps as mentioned in "FM2015_Extra_Steps.PNG").
  3. For reference, we have attached the word import of same document in FM12 also in "FM12.png".

Summarizing it, we can also map the word style paragraph to FM style paragraph and then check on the inline styles check box to get styling of Word also. This should work if file is imported in existing template also.

If possible you can share the files at "keshari@adobe.com", we can see more on this issue to provide the best possible solution on this.

Regards,

Pawan Keshari

FM Engineering Team

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 18, 2016 0
Community Beginner ,
Feb 24, 2016

Copy link to clipboard

Copied

OK I'm sending files to the email you provided. I look forward to your response after you see them.

Gail

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 24, 2016 0
Community Beginner ,
Feb 26, 2016

Copy link to clipboard

Copied

Pawan:

Can you let me know whether you received the files or not? It was kind of a big Zip file.

Gail

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2016 0
Adobe Employee ,
Mar 01, 2016

Copy link to clipboard

Copied

Hi Gail,

We have recieved the files and will revert back to you at the earliest.

Regards,

Pawan Keshari

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 01, 2016 0