Highlighted

Is this a bug?

Participant ,
Apr 10, 2019

Copy link to clipboard

Copied

Do the following:

  1. In a new FM document, put a few sentences at the top of the page.
  2. Add a table below those sentences.
  3. Create a second table below the first.
  4. Click Insert > Marker and insert a marker in one of the cells in each table.  Give the markers unique contents.
  5. Place the cursor in the first table and then open the Table Designer.
  6. On the Basic tab of the Table Designer, Set the Start value to TOP OF PAGE and click Apply.
  7. Both tables should jump to the following page, with the first table remaining above the second table, as it should.
  8. Save the FM document.
  9. Add the FM document to a Book file.
  10. In the Book file, create a List of Markers, setting it to use the marker type you used in Step 4 above.
  11. Update the book.
  12. Open the LoM document and check the order of the two table markers.

The second table marker should be listed above the first table marker, even though the second follows the first in the body document.

Why should the TOP OF PAGE quality rearrange the order of markers in the LoM?

Adobe Community Professional
Correct answer by Lynne_A__Price | Adobe Community Professional

I have submitted bug FRMAKER-6397 on this issue. I can create simple test files in both FM 2017 and FM 2019 that list the marker in the second table first and others that list the marker in the first table first.

        --Lynne

TOPICS
Formatting and numbering

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Is this a bug?

Participant ,
Apr 10, 2019

Copy link to clipboard

Copied

Do the following:

  1. In a new FM document, put a few sentences at the top of the page.
  2. Add a table below those sentences.
  3. Create a second table below the first.
  4. Click Insert > Marker and insert a marker in one of the cells in each table.  Give the markers unique contents.
  5. Place the cursor in the first table and then open the Table Designer.
  6. On the Basic tab of the Table Designer, Set the Start value to TOP OF PAGE and click Apply.
  7. Both tables should jump to the following page, with the first table remaining above the second table, as it should.
  8. Save the FM document.
  9. Add the FM document to a Book file.
  10. In the Book file, create a List of Markers, setting it to use the marker type you used in Step 4 above.
  11. Update the book.
  12. Open the LoM document and check the order of the two table markers.

The second table marker should be listed above the first table marker, even though the second follows the first in the body document.

Why should the TOP OF PAGE quality rearrange the order of markers in the LoM?

Adobe Community Professional
Correct answer by Lynne_A__Price | Adobe Community Professional

I have submitted bug FRMAKER-6397 on this issue. I can create simple test files in both FM 2017 and FM 2019 that list the marker in the second table first and others that list the marker in the first table first.

        --Lynne

TOPICS
Formatting and numbering

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 10, 2019 0
Adobe Community Professional ,
Apr 10, 2019

Copy link to clipboard

Copied

Hi Doug,

I tested this with new files, but I could not reproduce your issue.

I had created markers of type Comment and Subject.

Both marker types are ordered correctly in the LOM. The order did not change when I set the first table to Top of Page.

Which marker type did you use?

Best regards

Winfried

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2019 1
Participant ,
Apr 10, 2019

Copy link to clipboard

Copied

You need to use the same marker type.  I'm not sure the type matters, but I used "Tables".  I'm making a list of tables so I use the same marker type for each marker I put in each table.  I put them into the table itself to ensure that the table isn't off the top of the screen when a user clicks the link in the LoM document.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2019 0
Adobe Community Professional ,
Apr 10, 2019

Copy link to clipboard

Copied

Hi Doug,

I had several markers:

First table 1 (Index), 11 (Subject), 111 (Tables).

Second table 2 (Index), 22 (Subject), 222 (Tables)

The order is always correct:

1

11

111

2

22

222

When I remove markers Index and Subject from the LOM, then I just get 111 and then 222.

This order does not change, when I set the first table to start Top of Page.

Best regards

Winfried

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2019 1
Participant ,
Apr 10, 2019

Copy link to clipboard

Copied

Are you checking for order in the LoM document?  The order does not change in the body document, but for me it changes in the LoM document.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2019 0
Adobe Community Professional ,
Apr 10, 2019

Copy link to clipboard

Copied

Hi Doug,

Yes. I checked the order in the LOM file.

I do not know, why you have different results.

Did you do anything else besides the steps above?

Did you use the FrameMaker default template or your own template?

Best regards

Winfried

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2019 0
Participant ,
Apr 10, 2019

Copy link to clipboard

Copied

I used my work file at first, but at your prompting I tried to duplicate it using FM default files (File > New > Book and File > New > Document).  I was able to duplicate my results.

Are you putting the markers in a cell inside the tables?  If you put the markers outside the table the reverse order won't occur.

I'm using FM 2017, 14.0.4.511 on Windows 10.

Is there a way I can upload my test files?  There are only 3, and they're quite small.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2019 0
Adobe Community Professional ,
Apr 10, 2019

Copy link to clipboard

Copied

Hi,

Yes. My markers are in the table cells of the first row.

I use FM 2019, 15.0.3.603. Possibly that's the reason.

I do not have FM 2017. Therefore I cannot test your files.

As far as I know you can only upload pictures, not FM files.

Best regards

Winfried

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2019 2
Adobe Community Professional ,
Apr 10, 2019

Copy link to clipboard

Copied

HI Doug:

I have 2017 installed and happy to test. You can put them on a file-sharing server like dropbox and post the link here (public) or hover over my name and message me (private).

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2019 0
Adobe Community Professional ,
Apr 10, 2019

Copy link to clipboard

Copied

Doug,

    I, too, would be interested in seeing your sample files. I was unsuccessful in duplicating your results in  FM 2017, 14.0.4.511. However, I have a vague memory of encountering something similar in an earlier version of FM. I don't remember how I solved the problem. Details such as the number of lines in the first paragraph, whether the anchors of both tables are in the same paragraph, the number of rows in the tables, fonts used, page size, etc. may all make a difference.

      --Lynne

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 10, 2019 0
Participant ,
Apr 11, 2019

Copy link to clipboard

Copied

I put a ZIP file onto Dropbox at the link below.  Let me know if it works.   It contains a Book file, an FM file and a LoM file.

Dropbox - BugTest.zip

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2019 0
Adobe Community Professional ,
Apr 11, 2019

Copy link to clipboard

Copied

Doug,

   Thank you for the sample files. Here's what I've found so far:

1. FM 2019's behavior on this issue seems to be the same as FM 2017's.

2. I had created my own test file, following the steps you described yesterday. The LOM looked fine. When I looked at your file, I noticed that the anchor for the first table was in its own paragraph. I changed my test file by putting a break before the anchor, regenerated the LOM and the entries were out of order.

3. I next tried putting a space before the anchor to see if the incorrect result only appears when the anchor is the only thing in the paragraph; entries were still out of order. So then I tried a letter 'x' to see if a visible character made a difference. The entries were still out of order.

4. Setting the first table to start at the top of a page clearly makes a difference. When it is set to start anywhere, the order is correct. I can go back and forth and the order changes.

I'll try a few more variations later and let you know if I come up with a workaround.

--Lynne

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2019 0
Participant ,
Apr 11, 2019

Copy link to clipboard

Copied

Glad to know someone sees the issue.

I've tried putting the markers in the body of the document, and that works, but it puts the marker for the first table on the previous page, which isn't desired.

The only solution I've found is to put both markers in text frames next to their respective tables. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 11, 2019 0
Adobe Community Professional ,
Apr 15, 2019

Copy link to clipboard

Copied

I have submitted bug FRMAKER-6397 on this issue. I can create simple test files in both FM 2017 and FM 2019 that list the marker in the second table first and others that list the marker in the first table first.

        --Lynne

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 15, 2019 2
doug1120 LATEST
Participant ,
Apr 16, 2019

Copy link to clipboard

Copied

Thanks Lynne

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 16, 2019 0