Highlighted

Is this an error or a message that informs?

Community Beginner ,
Feb 09, 2018

Copy link to clipboard

Copied

Hi,

The FM log gave a message after I imported the element definitions (EDD) file: "Importing to book; no automatic format creating of new paragraph format (ss-StepSub). I received this message for the several other formats that I have. Is FM just informing me or is this an error that must be addressed?

Thank you,

Ahsan

Hi Ahsan,

This is just information, not an error. Formats are never created when an EDD is imported into a book.

In your EDD you can choose to Create formats on Import, or not. Look for the CreateFormats element near the start of the EDD.

This feature creates any Paragraph or Character formats that are referenced in the EDD, but not already in the target document. Of course FrameMaker does not know how you want to format these newly created formats, so you have to do that yourself.

Ian

TOPICS
Structured

Views

222

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Is this an error or a message that informs?

Community Beginner ,
Feb 09, 2018

Copy link to clipboard

Copied

Hi,

The FM log gave a message after I imported the element definitions (EDD) file: "Importing to book; no automatic format creating of new paragraph format (ss-StepSub). I received this message for the several other formats that I have. Is FM just informing me or is this an error that must be addressed?

Thank you,

Ahsan

Hi Ahsan,

This is just information, not an error. Formats are never created when an EDD is imported into a book.

In your EDD you can choose to Create formats on Import, or not. Look for the CreateFormats element near the start of the EDD.

This feature creates any Paragraph or Character formats that are referenced in the EDD, but not already in the target document. Of course FrameMaker does not know how you want to format these newly created formats, so you have to do that yourself.

Ian

TOPICS
Structured

Views

223

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 09, 2018 0
Enthusiast ,
Feb 12, 2018

Copy link to clipboard

Copied

Hi Ahsan,

This is just information, not an error. Formats are never created when an EDD is imported into a book.

In your EDD you can choose to Create formats on Import, or not. Look for the CreateFormats element near the start of the EDD.

This feature creates any Paragraph or Character formats that are referenced in the EDD, but not already in the target document. Of course FrameMaker does not know how you want to format these newly created formats, so you have to do that yourself.

Ian

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 12, 2018 0
Community Beginner ,
Feb 12, 2018

Copy link to clipboard

Copied

Thank you for the answer Ian!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 12, 2018 0
Mentor ,
Feb 12, 2018

Copy link to clipboard

Copied

Hi Ahsan,

It is informative only. During the process of EDD import, you have the option to let FrameMaker automatically generate paragraph and character formats referenced in the EDD if they do not currently exist in the target file(s). They are just generic formats... the system doesn't know anything about how you want them to actually look. Anyway, it can't create formats for a book, so it gives you those warnings.

You can turn off the auto-generate option by inserting a DoNotCreateFormats element near the beginning of your EDD.

Russ

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 12, 2018 0
Community Beginner ,
Feb 12, 2018

Copy link to clipboard

Copied

Thank you Russ!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 12, 2018 0