Highlighted

Leader dots in LOT unexpectedly change shape

Explorer ,
Feb 20, 2018

Copy link to clipboard

Copied

Hi, I am using the TableTitleLOT paragraph tag to correctly align page numbers with leader dots for any tables titles that are longer than one line. 

After finding helpful advice on the forum, I set the maximum word spacing to 325% and the minimum word spacing to 275% and the optimum spacing to 100%, and I added two tabs between <$paratext> and <$chapnum> to right align the page numbers on the second line.  I set the TableTitleLOT tag with right-aligned, square leader dots; however, the leader dots change from square to round when I add the second tab in the paragraph tag (in either reference or body pages).  I could live with round leader dots, except now the short title and the long title have different leader dots (see attached screenshot).  I really want the same style of dots for all table titles, long and short, so the LOT has a consistent look.

Does anyone know why the dots change when an extra tab is added?  Thanks, Emma.

extra tab LOT.png

Correct answer by Matt S - Tech Comm Tools | Adobe Community Professional

Yes, select the > before the <$chapnum>.

Using the Character Catalog, remove the character tag by selecting Default (Para) Font, where (Para) is the pilcrow, or paragraph symbol.

You should see the difference in the tab symbol, and after regenerating your LOT you should be fine.

-Matt

Views

231

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Leader dots in LOT unexpectedly change shape

Explorer ,
Feb 20, 2018

Copy link to clipboard

Copied

Hi, I am using the TableTitleLOT paragraph tag to correctly align page numbers with leader dots for any tables titles that are longer than one line. 

After finding helpful advice on the forum, I set the maximum word spacing to 325% and the minimum word spacing to 275% and the optimum spacing to 100%, and I added two tabs between <$paratext> and <$chapnum> to right align the page numbers on the second line.  I set the TableTitleLOT tag with right-aligned, square leader dots; however, the leader dots change from square to round when I add the second tab in the paragraph tag (in either reference or body pages).  I could live with round leader dots, except now the short title and the long title have different leader dots (see attached screenshot).  I really want the same style of dots for all table titles, long and short, so the LOT has a consistent look.

Does anyone know why the dots change when an extra tab is added?  Thanks, Emma.

extra tab LOT.png

Correct answer by Matt S - Tech Comm Tools | Adobe Community Professional

Yes, select the > before the <$chapnum>.

Using the Character Catalog, remove the character tag by selecting Default (Para) Font, where (Para) is the pilcrow, or paragraph symbol.

You should see the difference in the tab symbol, and after regenerating your LOT you should be fine.

-Matt

Views

232

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 20, 2018 0
Adobe Community Professional ,
Feb 20, 2018

Copy link to clipboard

Copied

Hi Emma,

It looks like your tab stops are probably using a different leader style. Can you check each tab stop and see if they're set to the same radio button choice?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2018 0
Explorer ,
Feb 20, 2018

Copy link to clipboard

Copied

Hi Matt, here's a ss of the leader settings for the paragraph tag.  I just have the right-aligned tab set with a leader.  I forgot to say I'm using FrameMaker 2015.

Tab stop leader.png

Thanks, Emma

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2018 0
Adobe Community Professional ,
Feb 20, 2018

Copy link to clipboard

Copied

can you share a pic of the reference page?

You may have inadvertently applied a character tag to the second tab character.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2018 0
Explorer ,
Feb 20, 2018

Copy link to clipboard

Copied

You must be right - I created a new book and set the same settings, and the leader dots stayed the same.  The doc I'm working on is a legacy doc from several years ago, and previous Frame versions.  Here's the ss of the reference page.

ref page.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2018 0
Adobe Community Professional ,
Feb 20, 2018

Copy link to clipboard

Copied

Yes, select the > before the <$chapnum>.

Using the Character Catalog, remove the character tag by selecting Default (Para) Font, where (Para) is the pilcrow, or paragraph symbol.

You should see the difference in the tab symbol, and after regenerating your LOT you should be fine.

-Matt

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2018 1
Adobe Community Professional ,
Feb 20, 2018

Copy link to clipboard

Copied

Hi Emma:

You also have three tab characters on the line but only two tab stops. You can just remove the third, bolded tab character. You don't need it.

~Barb

ref+page.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2018 0
Explorer ,
Feb 20, 2018

Copy link to clipboard

Copied

Thanks so much Matt, that works!!

Looking at it again, I think the square leader dots were an issue because I don't see them in the choice of leader dots, yet they are in our reference pages for TOC, LOT, and LOF.

How did you know that was the issue from looking at the ref page?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2018 0
Explorer ,
Feb 20, 2018

Copy link to clipboard

Copied

Hi Barb

I tried the setting with two tabs, but I found that the page number did not right-align for table titles that split onto a second line.  That's when I found a post saying add a third tab which corrects that behaviour.  If a table title is on a single line, the third tab is ignored.

Thanks for responding too, Barb.  You and Matt are so very helpful in this forum!

Emma

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2018 1
Adobe Community Professional ,
Feb 20, 2018

Copy link to clipboard

Copied

Ah, that makes sense, Emma.

How did you know that was the issue from looking at the ref page?

You can see that the third tab is bolder than the other two, so it has the character tag for the numbers assigned to it.

And always happy to help.

~Barb

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2018 1
Adobe Community Professional ,
Feb 20, 2018

Copy link to clipboard

Copied

Yep, as Barb said, the tab character in your screen shot was bolded. Since the page numbers were bold, it was an easy guess that the character tag was the problem.

Yes, it's a weird thing that the extra tab character is needed for two-line title, but I use the same technique for my work.

*** One other thing: With two-line titles, you'll likely want to control line breaks on your TOC pages. You can do this indirectly by replacing "regular" spaces with non-breaking spaces near the point of the desired line break in the TOC.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 20, 2018 1
Explorer ,
Feb 21, 2018

Copy link to clipboard

Copied

Thanks, Barb, just one character setting can make a whole lot of difference, eh. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2018 1
Explorer ,
Feb 21, 2018

Copy link to clipboard

Copied

Thanks, Matt, that's something that I'll remember for future reference.  Working on Frame files that were set up by someone else and have been customized is a good learning experience.

I use non-breaking spaces in body paragraphs to control line breaks, and that's a good suggestion for TOCs, especially as we use technical terms that ideally should be kept together on line line.

Thanks, I really appreciate the responses Matt and Barb - it's great to learn from the experts!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 21, 2018 1