Highlighted

List of figures - configure target display location?

Participant ,
Jun 27, 2018

Copy link to clipboard

Copied

I set up a list of figures, and it works fine.  But when click the list entry, the figure's link displays at the top of the screen.  Unfortunately our figures are above the link in the document.  This means the figure can't be seen unless the I scroll up the document. 

This wouldn't be a problem, I suppose, if our links were above the figures.  But that's not in our style guide.

Is there a way to make the link display lower on the screen, so the figure can be seen right away?

Views

230

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

List of figures - configure target display location?

Participant ,
Jun 27, 2018

Copy link to clipboard

Copied

I set up a list of figures, and it works fine.  But when click the list entry, the figure's link displays at the top of the screen.  Unfortunately our figures are above the link in the document.  This means the figure can't be seen unless the I scroll up the document. 

This wouldn't be a problem, I suppose, if our links were above the figures.  But that's not in our style guide.

Is there a way to make the link display lower on the screen, so the figure can be seen right away?

Views

231

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 27, 2018 0
Adobe Community Professional ,
Jun 27, 2018

Copy link to clipboard

Copied

No elegant solutions...it's best to have the titles above.

The issue is that you're referencing a specific marker, so either the title is above the figure, or you'll need a Cross-Ref marker on its own line to use for the cross-reference.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 27, 2018 0
Contributor ,
Jun 28, 2018

Copy link to clipboard

Copied

Suppose the graphic frames are anchored in the paragraph above:

Usually this paragraph above has a special paragraph tag, e.g. 'Graphics'.

Set up a new list of figures containing two paragraph tags:

  • Graphics
  • FigureTitle

It will look like this:

Do some magic with regular expressions:

  • Find: ^(.)\d*\n(.)
  • Change: $1$2

Now it will look like this:

Create a PDF. The links should work as desired.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 28, 2018 0
doug1120 LATEST
Participant ,
Jul 23, 2018

Copy link to clipboard

Copied

I'm told that the captions need to be below the figure.  I've decided to use a List of Markers instead, with Xref markers being placed above each image.  This will let me use non-linking captions below each figure yet enable the figures to display on-screen if a reader clicks the link in the List of Markers.

An entry in the List of Markers needs to look like this:

Figure 1: The House of Mouse

I've tested this and it works, but I'm having trouble with the formatting in the List of Markers.  The problem is with the requirement that Figure 1: needs to be in bold, with the rest of the text in non-bold font.  Since the <$markertext> variable contains the entire text, there's no way to format part of it differently from the rest.

I've attempted to resolve this using the following code on the Reference page:

Figure <$paranumonly[Figure]>: <$markertext>

This worked perfectly when I edited the Xref marker to remove the "Figure 1:" but one problem remains:

The $paranumonly[Figure] value starts at zero for some reason.  Even though the first figure in the document starts at 1, it shows up as zero in the LoM document I created.

Why is this happening?  Is there a way to initialize the variable to start at 1?

All I really need is a counter that starts at 1 in the LoM document.  I'm at a loss how to set a variable for use as a counter. 

Ideas? 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 23, 2018 0