Highlighted

Master page not spanning

Explorer ,
Feb 03, 2017

Copy link to clipboard

Copied

Hi all,

Here's the situation (Edit: I'm using version 13.0.3.495):

I have four master pages (Left, Right, LandscapeLeft, and LandscapeRight) in my two-sided document. I use the landscape pages* for tables that are too wide to fit in a portrait page. Some of these landscape tables span multiple pages. Depending on which side page (left or right) the table begins on, I either apply AnchorLandscapeLeft or AnchorLandscapeRight to the paragraph holding the table's anchor. These paragraph styles are mapped to the appropriate landscape master pages via the reference pages, and are both set to Span.

The right-handed landscape pages are applied such that the first page and any subsequent pages receive the LandscapeRight master page (this isn't actually what I need, because I still have to manually set LandscapeLeft to the left-handed pages, but at least it's what I expect). However, when the table begins on a left-handed page and I have AnchorLandscapeLeft applied, it only sets the LandscapeLeft master page to that first page of the table; the subsequent page of the table is being applied a None master page. (There is no "None" master page in my master pages.)

I've checked spelling/typos, but the fact that LandscapeLeft is being applied to the page with the anchor means Frame is finding it and doing the work, it's just not spanning.

Does anyone have an idea why this is happening?

And as a related question, is there a way to tell Frame that the LandscapeLeft and LandscapeRight master pages should be treated as Left and Right pages, so that I don't have to manually apply the appropriate landscape page to the spanning table?

Thanks!

John

*To be clear, the page is set up as a portrait page, but the text frame is rotated 90° counter-clockwise.

Ok, we figured out that if LandscapeLeft and LandscapeRight are both set to both the Left-Handed and Right-Handed columns in the reference table it'll span properly. Which actually answers my second question from above as well. This makes sense.

What still doesn't make sense is why the LandscapeRight was spanning "properly" even without being set to do so in the Left-Handed column.

Very weird.

Edit: Upon further testing, by setting up the table as follows, it eliminates the need to manually apply any master pages.

Edit: Upon even further testing, only one AnchorLandscape is necessary since Frame will properly apply right- and left-handed master pages.

Paragraph Tag nameRight-Handed Master PageLeft-Handed Master PageRange Indicator
AnchorLandscapeLeftLandscapeRightLandscapeLeftSpan
AnchorLandscapeRightLandscapeRightLandscapeLeftSpan

Views

200

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Master page not spanning

Explorer ,
Feb 03, 2017

Copy link to clipboard

Copied

Hi all,

Here's the situation (Edit: I'm using version 13.0.3.495):

I have four master pages (Left, Right, LandscapeLeft, and LandscapeRight) in my two-sided document. I use the landscape pages* for tables that are too wide to fit in a portrait page. Some of these landscape tables span multiple pages. Depending on which side page (left or right) the table begins on, I either apply AnchorLandscapeLeft or AnchorLandscapeRight to the paragraph holding the table's anchor. These paragraph styles are mapped to the appropriate landscape master pages via the reference pages, and are both set to Span.

The right-handed landscape pages are applied such that the first page and any subsequent pages receive the LandscapeRight master page (this isn't actually what I need, because I still have to manually set LandscapeLeft to the left-handed pages, but at least it's what I expect). However, when the table begins on a left-handed page and I have AnchorLandscapeLeft applied, it only sets the LandscapeLeft master page to that first page of the table; the subsequent page of the table is being applied a None master page. (There is no "None" master page in my master pages.)

I've checked spelling/typos, but the fact that LandscapeLeft is being applied to the page with the anchor means Frame is finding it and doing the work, it's just not spanning.

Does anyone have an idea why this is happening?

And as a related question, is there a way to tell Frame that the LandscapeLeft and LandscapeRight master pages should be treated as Left and Right pages, so that I don't have to manually apply the appropriate landscape page to the spanning table?

Thanks!

John

*To be clear, the page is set up as a portrait page, but the text frame is rotated 90° counter-clockwise.

Ok, we figured out that if LandscapeLeft and LandscapeRight are both set to both the Left-Handed and Right-Handed columns in the reference table it'll span properly. Which actually answers my second question from above as well. This makes sense.

What still doesn't make sense is why the LandscapeRight was spanning "properly" even without being set to do so in the Left-Handed column.

Very weird.

Edit: Upon further testing, by setting up the table as follows, it eliminates the need to manually apply any master pages.

Edit: Upon even further testing, only one AnchorLandscape is necessary since Frame will properly apply right- and left-handed master pages.

Paragraph Tag nameRight-Handed Master PageLeft-Handed Master PageRange Indicator
AnchorLandscapeLeftLandscapeRightLandscapeLeftSpan
AnchorLandscapeRightLandscapeRightLandscapeLeftSpan

Views

201

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 03, 2017 0
Adobe Community Professional ,
Feb 03, 2017

Copy link to clipboard

Copied

Is the complaint that:

1. An AMP operation is failing to apply as directed by your MasterPageMaps table, or
2. When creating content in Body mode, auto-created new pages aren't following the MPM table?

#1 requires some investigation.
#2 never has worked that way, unless enhanced in FMs later than what I use.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2017 0
Most Valuable Participant ,
Feb 03, 2017

Copy link to clipboard

Copied

Try using the "Until changed" range directive instead.

The "Span" directive means to apply the master page to the entire range of pages covering the paratag. The anchoring paratag only occurs on the first page that table is inserted on. The table can cover multiple pages, but the paratag itself only "spans" the one page.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2017 0
Explorer ,
Feb 03, 2017

Copy link to clipboard

Copied

Hi Bob,

Yes, the complaint is #1, as Apply Master Pages does not seem to be working as it should. It correctly applies LandscapeLeft to the page the anchor is on, but then applies None to the following page which contains the remainder of the table.

Hi Arnis,

Changing the directive to "Until changed" cascades the Landscape page well beyond the limits of the table, as there is no directive to start using a different page once the table ends.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2017 0
Adobe Community Professional ,
Feb 03, 2017

Copy link to clipboard

Copied

re: ...as there is no directive to start using a different page once the table ends.

So create one. Have AnchorLandscapeLeft or AnchorLandscapeRight set to generate EndLandscape as NextPgfTag. EndLand can be an empty para that itself invokes Body next. Use negative Space Above in EndLand to bury it under the end of the table.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2017 0
Explorer ,
Feb 03, 2017

Copy link to clipboard

Copied

Well, yes, I can do that as a workaround, but it doesn't really solve the problem which seems like a bug (unless I'm missing something, hence the post here). It may also lead to errors having an invisible paragraph line that less-experienced FM users may not notice/understand/etc. I'll keep your solution in mind as a last resort since these landscape pages are fairly infrequent in our docs, but hopefully there's a cleaner solution.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2017 0
Most Valuable Participant ,
Feb 03, 2017

Copy link to clipboard

Copied

As Bob says, create a condition that forces the change. Either use a paratag that you know follows the table(s) or create a special paratag that "ends" the table anchoring paratag (also use the next partag option in the paragraph designer for the anchoring paratags to make this an automatic insertion). Then setup the MP mapping table accordingly.

FM is like driving a car with a manual transmission. You have to do the work to get it to change gears. Once you know how to "shift", it drives quite nicely.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2017 0
Explorer ,
Feb 03, 2017

Copy link to clipboard

Copied

Ok, we figured out that if LandscapeLeft and LandscapeRight are both set to both the Left-Handed and Right-Handed columns in the reference table it'll span properly. Which actually answers my second question from above as well. This makes sense.

What still doesn't make sense is why the LandscapeRight was spanning "properly" even without being set to do so in the Left-Handed column.

Very weird.

Edit: Upon further testing, by setting up the table as follows, it eliminates the need to manually apply any master pages.

Edit: Upon even further testing, only one AnchorLandscape is necessary since Frame will properly apply right- and left-handed master pages.

Paragraph Tag nameRight-Handed Master PageLeft-Handed Master PageRange Indicator
AnchorLandscapeLeftLandscapeRightLandscapeLeftSpan
AnchorLandscapeRightLandscapeRightLandscapeLeftSpan

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 03, 2017 0