Highlighted

MasterPageMaps table - running off the reference page

Explorer ,
Mar 29, 2017

Copy link to clipboard

Copied

I'm working with a very long, complex FM template with many mapped paragraphs -> template pages.

I just inserted another row and the last row of the table runs off the page, but doesn't display on the next page. (I even tried adding a page.) It is there, just being cut off by the limited page length. It is worth mentioning that our user manuals are 5.5" high, not 11".

I used to love working with this product, but these are the things (seemingly undocumented) that are taking the fun out of it.

Has anyone else run into this? There is actually a table format for this table - UnstructMasterPageMaps, but I cannot see a setting that would prevent the page from flowing to the next page.

All this trouble for a reference page.

Adobe Community Professional
Correct answer by Lynne_A__Price | Adobe Community Professional

Diane,

    Most likely, the problem is that your 5.5" high reference page contains a text frame with a height that is more than 5.5". That was the case with a test file that I just created. In particular, I created a new Custom document with a page height of 5.5". I then applied master pages and looked at the resulting MasterPageMaps reference page. Its text frame was 7.559" high.

    If this is the problem, the missing rows are indeed in the text frame, you just can't see them because they've run off the bottom of the page.

    To fix, Ctrl-click on the page border and then use Open Text Frame Properties dialog (Esc o c f) in FM 2017 or Graphics > Object Properties in earlier versions, go to the Dimensions tab and set the height and top margin so that the sum is no more than 5.5".

    --Lynne

Views

227

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

MasterPageMaps table - running off the reference page

Explorer ,
Mar 29, 2017

Copy link to clipboard

Copied

I'm working with a very long, complex FM template with many mapped paragraphs -> template pages.

I just inserted another row and the last row of the table runs off the page, but doesn't display on the next page. (I even tried adding a page.) It is there, just being cut off by the limited page length. It is worth mentioning that our user manuals are 5.5" high, not 11".

I used to love working with this product, but these are the things (seemingly undocumented) that are taking the fun out of it.

Has anyone else run into this? There is actually a table format for this table - UnstructMasterPageMaps, but I cannot see a setting that would prevent the page from flowing to the next page.

All this trouble for a reference page.

Adobe Community Professional
Correct answer by Lynne_A__Price | Adobe Community Professional

Diane,

    Most likely, the problem is that your 5.5" high reference page contains a text frame with a height that is more than 5.5". That was the case with a test file that I just created. In particular, I created a new Custom document with a page height of 5.5". I then applied master pages and looked at the resulting MasterPageMaps reference page. Its text frame was 7.559" high.

    If this is the problem, the missing rows are indeed in the text frame, you just can't see them because they've run off the bottom of the page.

    To fix, Ctrl-click on the page border and then use Open Text Frame Properties dialog (Esc o c f) in FM 2017 or Graphics > Object Properties in earlier versions, go to the Dimensions tab and set the height and top margin so that the sum is no more than 5.5".

    --Lynne

Views

228

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 29, 2017 0
Adobe Community Professional ,
Mar 29, 2017

Copy link to clipboard

Copied

Diane,

    Most likely, the problem is that your 5.5" high reference page contains a text frame with a height that is more than 5.5". That was the case with a test file that I just created. In particular, I created a new Custom document with a page height of 5.5". I then applied master pages and looked at the resulting MasterPageMaps reference page. Its text frame was 7.559" high.

    If this is the problem, the missing rows are indeed in the text frame, you just can't see them because they've run off the bottom of the page.

    To fix, Ctrl-click on the page border and then use Open Text Frame Properties dialog (Esc o c f) in FM 2017 or Graphics > Object Properties in earlier versions, go to the Dimensions tab and set the height and top margin so that the sum is no more than 5.5".

    --Lynne

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2017 0
Adobe Community Professional ,
Mar 29, 2017

Copy link to clipboard

Copied

Alternatively, you can add a new reference page after your MasterPageMaps reference page (as you tried) but this time also add a text frame with the same flow tag (it's MasterPageMaps) and then enable autoconnect. This way, your table can flow to the next page.

  • Use Special > Add Reference Page (Insert > Add Reference Page in 2017)
  • Call it MasterPageMaps2
    VMware Fusionss_005.png
  • Draw a text frame to hold the 2nd page of the table
  • Select the frame and go to Format > Customize Layout > Customize Text Frame
  • Set the flow tag to MasterPageMaps and enable auto connect
    VMware Fusionss_006.png

What doesn't fit on the first MasterPageMaps page will flow to MasterPageMaps2

VMware Fusionss_007.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2017 3
Adobe Community Professional ,
Mar 29, 2017

Copy link to clipboard

Copied

Perhaps the easiest thing to try is just to set the point size smaller for the cell data in the UnstructMasterPageMaps table. Those cells are just using an override of the default Body ¶ format. I suspect that FM doesn't care about the details of the tags used in those cells.

What FM does care about is one or more of the following attributes of the MP mapping page:
Reference Page name: MasterPageMaps
Flow: MasterPageMaps
Flow body text tag: Body
Pgf1 text: "UnstructMasterPageMaps"
Pgf2 text: "Book Update (Yes or No): Yes"

Table anchored to Pgf2
Table tag: UnstructMasterPageMaps
Cell tags: Body* (the default override appears to be

  • Fixed)
    Without doing a lot of trial and error, it would be interesting to know which matter.
  • I seem to recall using a another trick for an over-length AMP tables: two-column format plus smaller point size.

    Barb's solution is more elegant, and is also of generic value. There are other cases where it would be really useful to connect flows across Reference Pages.

    Likes

    Translate

    Translate

    Report

    Report
    Community Guidelines
    Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
    Reply
    Loading...
    Mar 29, 2017 2
    Explorer ,
    Mar 30, 2017

    Copy link to clipboard

    Copied

    Dear Barb,

    Barb, Barb, Barb - why oh why have you not written a manual for us for FrameMaker? Yes, I know - things change quickly. But you could hire some minions to help with the updates!! I will be your minion! Just PLEASE oh please write us a user manual!! It doesn't even have to be print format (although I still love a good ole' fashioned printed manual, hence the reason I write them).

    Your appreciative apprentice,

    Diane

    Likes

    Translate

    Translate

    Report

    Report
    Community Guidelines
    Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
    Reply
    Loading...
    Mar 30, 2017 2
    Explorer ,
    Mar 30, 2017

    Copy link to clipboard

    Copied

    Yes, this was the issue. THANK YOU!!! Dang you people are good.

    Likes

    Translate

    Translate

    Report

    Report
    Community Guidelines
    Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
    Reply
    Loading...
    Mar 30, 2017 0