'other format overrides'

New Here ,
Sep 08, 2020

Copy link to clipboard

Copied

Hello, I am trying to import an rtf into an unstructured Framemaker 2020 file. In previous versions of Framemaker we could click to import 'other format overrides' but I cannot see this option in Framemaker 2020 - the Advanced dialogue box in 2020 offers removal of manual page breaks and empty paragraphs. I see it mentioned in the 2020 help - but cannot see the option when I import (Eg the line spacing for some styles in my Framemaker 2020 document is set to 9pt, but when I import I get 17pt. All styles are affected.) Any help gratefully received. Apologies, I know I must be missing something obvious! 

Views

74

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Sep 08, 2020

Copy link to clipboard

Copied

Hi,

 

With the new Word import (which works also for doc and docx files) you can select the FrameMaker paragraph formats for the imported content. When you do not select "Keep Word Formatting", then FrameMaker will use the formatting of the FrameMaker paragraph tags. That's the same as "Remove other format overrides". You just have more control.

Are you sure that your paragraph tag has 9 pt line spacing? This is not an override?

 

Best regards

 

Winfried

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Sep 08, 2020

Copy link to clipboard

Copied

Hi Claire:

the Advanced dialogue box in 2020 offers removal of manual page breaks and empty paragraphs

You are describing the options in the style mapping dialog box, and this hasn't changed in recent versions. (Here is a link to how the dialog box works from 2016: https://www.rockymountaintraining.com/adobe-framemaker-smoother-import-word-files-style-mapping/)

 

Are you actually mapping the Word styles to the equivalent FrameMaker styles? Are you enabling the Keep Word Formatting checkbox, or disabling it? (I recommend disabling it because it will produce overrides.)

 

Like Winfried, I suspect overrides. Try clicking on the 17 pt text. Is there an asterisk in front the the style name? If so, update the style to 9pt and remove the overrides. 

 

A much-overlooked feature of Find/Change is that you can ask Fm to find all Paragraph Format Overrides and and remove them. 

Screen Shot 2020-09-08 at 8.55.50 AM.png

~Barb 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
New Here ,
Sep 09, 2020

Copy link to clipboard

Copied

Hi Barb and Winfried, thank you for responding 🙂

 

We have Framemaker 2020 versions of all Word styles so we are mapping style name to style name (have been doing this in Frame 8 and 11 and other versions for at least two decades). We convert to rtf and Import > Copy into document as rtf. In the import box I see green bubbles next to the styles. I am not ticking 'Keep Word formatting' because then I definitely don't get what I want. I am clicking 'Import Word document inline styles' because otherwise I am losing italics and bold.

 

I set the Frame style up from scratch yesterday to see whether that fixed the issue (I had imported the formats from the Frame 8 templates initially) but again no luck.

 

When imported I do not get an asterisk against the style name in Frame, but it definitely says 9pt Fixed line spacing in the blank document, and then 17pt Fixed after importing - I also get different indents etc.

 

I am not sure how to insert screenshots here so cannot show you. Do I have to take photos of my screen and then copy onto my work laptop? The Find/Replace does work (thank you), but is not ideal as an extra step we didn't have to do before 😞

 

Hmmmm, at least we have a workaround I guess.

 

Many thanks, Claire

 

 

 

 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Sep 09, 2020

Copy link to clipboard

Copied

Hi Claire:

 

I am not sure how to insert screenshots here so cannot show you

How to take a screen shot on Windows 10:

https://www.businessinsider.com/how-to-screenshot-on-windows

 

How to add a screen shot to a reply on this forum:

  1. Click the blue and white Reply button at the top of this post.
  2. Type in the text portion of your reply, then click the Insert Photos button in the toolbar at the top of the text field. 
    Screen Shot 2020-09-09 at 8.30.51 AM.png
  3. Click the Choose Files button, select your image, wait while it uploads and then click the Done button in the lower right corner. 
  4. Click the blue and white Post button when you are ready to post your reply.

 

~Barb 

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more