Highlighted

Page Numbering and Table of Contents

Community Beginner ,
Jun 21, 2016

Copy link to clipboard

Copied

I have a Book containing 23 document files. The document files contain page numbers in the footers.

One of the document files is a generated table of contents (TOC). Unfortunately, the generated page

numbers in the TOC do not match the page numbers in the files. Here are the particulars:

  • The title page, in a file by itself, is unnumbered
  • The frontmatter, spread across five files uses lower-case roman (i-xvi)
  • The body text in the remaining 17 files is numeric (1-243)
  • The generated Table of Contents uses cardinal numbers from the book as a whole. For example,
    Chapter I is numbered correctly in the footer starting with page 1. However, in the TOC it is listed
    as starting on page 19 because it is the 19th actual file in the book. I have set the document numbering
    properties for this file to start at 1, and the Page Numbering properties for the book as a whole to
    be "Continue"
  • The style of the TOC entries is correct. That is, the frontmatter uses lower case roman, and the
    chapters use Numeric

I have tried regenerating the TOC, but this didn't help.

Does anyone have suggestions on what the prescribed way of doing this is?

Adobe Community Professional
Correct answer by Barb Binder | Adobe Community Professional

Ok, I kept reading and here's what I found:

Set the numbering style in the document, not in the book like we've been telling you. Format > Document > Numbering. Pick arabic or numeric. Repeat for the various chapters.

IMG_6548.png

Save and close chapters. In the book file, right click each chapter and choose Set up XXX. This is where you tell the book to continue page numbering or restart at 1.

IMG_6550.png

Once this is done, update your book. From there, if there are issues, we are relying on the Fm logic we are using every day and any one of us can help you resolve it.

Views

2.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Page Numbering and Table of Contents

Community Beginner ,
Jun 21, 2016

Copy link to clipboard

Copied

I have a Book containing 23 document files. The document files contain page numbers in the footers.

One of the document files is a generated table of contents (TOC). Unfortunately, the generated page

numbers in the TOC do not match the page numbers in the files. Here are the particulars:

  • The title page, in a file by itself, is unnumbered
  • The frontmatter, spread across five files uses lower-case roman (i-xvi)
  • The body text in the remaining 17 files is numeric (1-243)
  • The generated Table of Contents uses cardinal numbers from the book as a whole. For example,
    Chapter I is numbered correctly in the footer starting with page 1. However, in the TOC it is listed
    as starting on page 19 because it is the 19th actual file in the book. I have set the document numbering
    properties for this file to start at 1, and the Page Numbering properties for the book as a whole to
    be "Continue"
  • The style of the TOC entries is correct. That is, the frontmatter uses lower case roman, and the
    chapters use Numeric

I have tried regenerating the TOC, but this didn't help.

Does anyone have suggestions on what the prescribed way of doing this is?

Adobe Community Professional
Correct answer by Barb Binder | Adobe Community Professional

Ok, I kept reading and here's what I found:

Set the numbering style in the document, not in the book like we've been telling you. Format > Document > Numbering. Pick arabic or numeric. Repeat for the various chapters.

IMG_6548.png

Save and close chapters. In the book file, right click each chapter and choose Set up XXX. This is where you tell the book to continue page numbering or restart at 1.

IMG_6550.png

Once this is done, update your book. From there, if there are issues, we are relying on the Fm logic we are using every day and any one of us can help you resolve it.

Views

2.3K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jun 21, 2016 0
Adobe Community Professional ,
Jun 21, 2016

Copy link to clipboard

Copied

I believe numbering rules of the book override the numbering rules of the doc.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2016 0
Most Valuable Participant ,
Jun 21, 2016

Copy link to clipboard

Copied

You have to set all of the numbering properties for each file of the book in the Book file.

Set file 2 to start at page 1.

Set file 3 to also start at page 1.

Set the rest to continue numbering from previous.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2016 0
Community Beginner ,
Jun 21, 2016

Copy link to clipboard

Copied

Thanks Arnis. Can you help me to do what you suggest? When I select a file in in the Book and then choose Set Up File... I am given only the following choices.

bookVersion.jpg

However, if I Cancel and then open a Chapter from the Book file and choose Format->Document->Numbering,

I am given the following choices, which is what I have used:

fileVersion.jpg

I don't see any way that I can set the 1st Page # and Page # Style directly from the Book file.

Do you have any suggestions?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2016 0
Adobe Community Professional ,
Jun 21, 2016

Copy link to clipboard

Copied

Spencer:

In the book window, right+click each file and choose Numbering:
VMware Fusionss_001.png

Click the Pages tab to set the Page # and Format.

  • Front matter is roman, the first chapter starts on page one. Second and subsequent front matter chapters stay roman, but Continue Numbering from Previous Page in Book. Repeat for each front matter chapter.
  • When you get to the first body chapter, change the format to Numeric, and First Page # to 1. Select the second and subsequent chapters with a click, Shift click: keep the style numeric and Continue Numbering from Previous Page in Book.

VMware Fusionss_002.png

When you think you are done, select all of the chapters and check the numbering on the bottom row of the book window to confirm that it is correct.

VMware Fusionss_003.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2016 0
Community Beginner ,
Jun 21, 2016

Copy link to clipboard

Copied

Thanks for the detailed reply. I think that my problem is that I have an old version of FM (5.5) and it only offers me the following choices:

rc.jpg

Note that there is no numbering option.

Can anyone suggest how I can fake things in a version this old (other than buying a new version )?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2016 0
Adobe Community Professional ,
Jun 21, 2016

Copy link to clipboard

Copied

Oh my. 5.5 from 1997?

I can't imagine anyone else has that version installed in 2016, but I did dig up my old workbook from that era... the command for numbering was Set Up File for the user-created chapters, and was/is Set up Table of Contents or Index for the generated files.

So, using your screen shots for Arnis:

  1. On each file, use Set Up File to define starting page side and to mark page numbering as Continue or Restart.
  2. The chapter doesn't say anything about numbering properties and I don't remember. Maybe it was handled in the document at that point in time. Hopefully, someone else will remember.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2016 0
Most Valuable Participant ,
Jun 21, 2016

Copy link to clipboard

Copied

You were sort of on the right track, but unfortunately the context (right-click) menus for these options didn't appear until around FM 7.

You need to first select (but don't open) the file in the Book window listing [as you seem to have done], but then use the Format menu to select Document > Numbering to get the numbering window. You can select multiple files before popping up this window, so first set the first chapter file to begin on page 1 and then select the rest of the files and set them to continue the numbering from the previous file.

Likewise, to set the Pagination at the Book level, again select the file(s) and then from the Format menu select Page Layout > Pagination for the appropriate options.

FM always has had the Book settings override the individual file settings [so I'd recommend to not even bother setting at the file level] and one could always use the Format menus to set the book-level properties when there wasn't a context (right-click) menu option available.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 21, 2016 1
Community Beginner ,
Jun 22, 2016

Copy link to clipboard

Copied

Unfortunately, in my version of FrameMaker, if the book file is open but the individual file is not open, then the format menu does not appear. It only show up if I go ahead and open the file.

Untitled.jpg

I have to believe that there is some way to do this, and I vaguely recall building page-numbered books

with this version of FM in the past. But I can't seem to get it working now.

Can either of you think of a work-around?

Thank you Arnis and Barb for sticking with me on this.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2016 0
Adobe Community Professional ,
Jun 22, 2016

Copy link to clipboard

Copied

Was it in the File menu?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2016 0
Adobe Community Professional ,
Jun 22, 2016

Copy link to clipboard

Copied

Ok, I kept reading and here's what I found:

Set the numbering style in the document, not in the book like we've been telling you. Format > Document > Numbering. Pick arabic or numeric. Repeat for the various chapters.

IMG_6548.png

Save and close chapters. In the book file, right click each chapter and choose Set up XXX. This is where you tell the book to continue page numbering or restart at 1.

IMG_6550.png

Once this is done, update your book. From there, if there are issues, we are relying on the Fm logic we are using every day and any one of us can help you resolve it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2016 0
Community Beginner ,
Jun 22, 2016

Copy link to clipboard

Copied

That did it. Thanks for persevering.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2016 1
Adobe Community Professional ,
Jun 22, 2016

Copy link to clipboard

Copied

And now I've exposed my packrat tendencies! Should you find yourself any version from Fm 3 forward, Spencer... I have the manuals and workbooks! Along with Photoshop, Illustrator, PageMaker/InDesign, Acrobat...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jun 22, 2016 0