Highlighted

PDF bookmarks showing hidden text

Adobe Community Professional ,
Apr 17, 2019

Copy link to clipboard

Copied

For purposes of creating xrefs, I have added "hidden" numbers at the end of several paragraph tags. By hidden I mean that they are in a 2-point font, the text is set to a special color (white, but named "zhidden_numbers" and set in the color view to Invisible), and the background is set to white.

Up until the beginning of this month, those numbers did NOT show up in the bookmarks panel when I generated a PDF.

Now they are. I don't want them there. What changed, and how do I fix it?

(NB: I am cross-posting this to the FrameUsers list.)

Views

2.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

PDF bookmarks showing hidden text

Adobe Community Professional ,
Apr 17, 2019

Copy link to clipboard

Copied

For purposes of creating xrefs, I have added "hidden" numbers at the end of several paragraph tags. By hidden I mean that they are in a 2-point font, the text is set to a special color (white, but named "zhidden_numbers" and set in the color view to Invisible), and the background is set to white.

Up until the beginning of this month, those numbers did NOT show up in the bookmarks panel when I generated a PDF.

Now they are. I don't want them there. What changed, and how do I fix it?

(NB: I am cross-posting this to the FrameUsers list.)

Views

2.2K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 17, 2019 0
Adobe Community Professional ,
Apr 17, 2019

Copy link to clipboard

Copied

If anyone is wondering what this looks like, you see those numbers circled in red in the bookmarks panel? Those are the <$chapnum> variables that are supposed to be invisible in the text (and are) but they are showing up in the bookmarks, where I definitely don't want them and where they were never showing up before. 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2019 0
Adobe Employee ,
Apr 17, 2019

Copy link to clipboard

Copied

I guess you are looking for something like this: http://www.microtype.com/timesavers/TimeSaversDlg.pdf

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2019 0
Adobe Community Professional ,
Apr 17, 2019

Copy link to clipboard

Copied

Oh, yes, and if anyone can help me figure out how to get the bookmarks to read as "Section 1: Evelina", etc., even though the "Section 1" and the "Evelina" are two separate tags on two separate lines, that'd be lovely. I hate having to go in and edit bookmarks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2019 0
Adobe Employee ,
Apr 17, 2019

Copy link to clipboard

Copied

Makes sort of sense to me … The numbers might not be "visible" due to special formatting, however they are actually "there." The bookmarks however do not show formatting, but just the unformatted string (which includes the numbers). Try to copy and paste the whole paragraph text to Notepad or any other plain-text editor, and you will see them as well. And this is exactly what the "(unformatted) plain text bookmarks show.

Also, as you write that you are doing this construction for the purpose of creating xrefs: Am I correct in assuming that those "hidden" numbers appear in the xrefs pointing to these headings? If they do – why should that be different in the bookmarks?

However, strange is, that this is new behaviour in your scenario (I would have actually expected it to be there always). So your question "What changed?" [at the beginning of this month] is a good one. Or maybe the question other way around is be: Why did the numbers did not show up in the bookmarks before? (I think they should have had!)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 17, 2019 0
Adobe Community Professional ,
Apr 18, 2019

Copy link to clipboard

Copied

Hi Lin,

Did you create these numbers with automatic numbering?

Or did you add these numbers as regular text, but with a special formatting?

When automatic numbering, yes, depending on your cross-reference format the numbers will not show.

I also do not understand why the numbers had not been copied into the bookmarks some weeks before. As Stefan said the numbers should always be copied to the bookmark text. Whether regular text or autonumbering should not matter.

Did you update your FM version?

Best regards

Winfried

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2019 0
Adobe Community Professional ,
Apr 19, 2019

Copy link to clipboard

Copied

I just noticed I hadn't answered this.

It's Frame 2019, update 3. My employer pays for a subscription to the Creative Cloud, and Acrobat was updated earlier this week.

As I've said elsewhere in this thread, though, even with the latest updates applied, if the font color in the character tag that is applied to the paragraph's autonumbering is set to White, as opposed to the custom color, it does not show up in the bookmarks panel. I retested that this morning. Acrobat is not picking it up the trailing autonumber, at all, as shown when I performed Stefan's test opening the bookmark text for editing, copying the entire text, and pasting it into Notepad.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 19, 2019 0
Adobe Community Professional ,
Apr 18, 2019

Copy link to clipboard

Copied

The only difference I can determine between the document where it still works and the new document where it doesn't is that the document where it works uses Frame's pre-defined color of White for the character tag and the new one uses a color definition I created which is a duplicate of White except for the name.

Guess I'll put it back to White and delete the custom color. Seems odd that one would work and the other wouldn't when every single setting is identical.

these_settings_DO_NOT_work.png

these_settings_work.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2019 0
Most Valuable Participant ,
Apr 18, 2019

Copy link to clipboard

Copied

Lin,

Have you tried setting your custom colour to "Invisible" using the Color Views option prior to creating the PDF? FM should never output any item with a colour set to "Invisible". Using White, the (auto-)number would still be there if you do a copy&paste from the PDF (as Stefan indicatea), you just don't see it in the PDF. With the "Invisible" setting, the number should never get to the PDF in the first place.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2019 0
Adobe Community Professional ,
Apr 19, 2019

Copy link to clipboard

Copied

I had it set to Invisible first, which is why I was REALLY surprised to see it in the bookmarks panel. I moved it to Cutout to match the definition for White. Just to be sure I hadn't misremembered, I tried it again just now.

  1. I created the custom color by bringing up the definition for White and giving it a new name.
  2. In the color view, I set the custom color to Invisible.
  3. I updated my character tag so that it used the custom color for both Color and Background.
  4. I created 3 new documents, created a book, and ran Save As PDF.

The numbers are in the bookmark panel.

I did also try using the Publish pod (still learning my way around that) and got the same results.

It's weird.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 19, 2019 0
Adobe Employee ,
Apr 19, 2019

Copy link to clipboard

Copied

linsims​, it's not sooo weird – it's actually very logical 🙂

Again: Just because you format the numbers on the page in a certain way (like white, 2 points, whatever) with the result being that they are not visible, they are still there. The bookmarks are generated from the whole paragraph text and do not show this formatting. Therefore you see the numbers in the bookmarks.

Just image you would format the numbers in the paragraphs in a different way: Let's say your page background would be black, your paragraph text white and you format the numbers in black. You will not see the numbers (black on black), but they are still there and will therefore also go into the bookmark.

Also, as you mentioned you are using this construction for the purpose of creating xrefs (to the paragraphs with the numbers), I assume that you expect the numbers to appear in those xrefs? If so, and if they do: Same logic.

Can you give us the xref definition that you are using to reference the headings? I'm curious to see this definition (and maybe a screenshot of the text where the xref is).

On Frameusers you mentioned yesterday:

If I use FrameMaker's predefined color White, the autonumber does NOT appear. If I use a color I create that has everything the same except for the name, it does.

This is interesting. I tend to say, this is a bug. The numbers should be there in the bookmarks, even if you are formatting them using FrameMaker's build-in color "White".

I would like to recommend to think about a different construction. This kind of "hack" is not something I would like to rely on. It might work now, but it might no longer work in the future. Also, it might not work in other scenarios (e.g. HTML5 output), migration to XML or other possbile future scenarios.

Oh, and by the way, can you please try someting: In the scenario where it works (with FM built-in color "White"), please select a bookmark and press F2 to edit the bookmark and then ctrl+a to select everything in the bookmark, and then ctrl+c to copy it. Then paste it into a plain text editor like Windows Notepad. Is the numer there and you just do not see it in the bookmark?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 19, 2019 0