Highlighted

problem creating/editing tab stops in FM2015

Explorer ,
Jan 25, 2016

Copy link to clipboard

Copied

Hello,

I sometimes can't add a new tab stop, or edit a tab stop that has already been added, using the Paragraph Designer. Here's what happens:

I click on the tab I want to change and click Edit. The Edit Tab Stop dialog opens.

I enter the position in the New Position box.

I click Continue.

This closes the Edit box and goes back to the Paragraph Designer. The new tab is in the list, but only for a second, and then it just disappears. I go back to the beginning and try again, but the same thing happens.

The same thing also happens when I try to edit a tab stop that has already been created.

An important thing to mention here is that this is an intermittent problem. It doesn't always happen - sometimes it works fine, for either adding new tab stops or editing an existing one. I haven't been able to discern any pattern associated with it.

This wasn't a problem in FM8. But this past summer I upgraded to FM 2015 and I have encountered this problem numerous times. Is this a bug? Or is there a new step I need to do, that I'm not aware of?

Thanks,

Joyce

Adobe Community Professional
Correct answer by LinSims | Adobe Community Professional

It's still an issue sometimes, and for some reason it's associated with graphics files. What has been learned is that if you turn off the display of graphics in the document (View > Options and deselect the Graphics option), then you can edit your paragraph tabs as usual.

 

Weird, but this has worked for many people facing this same issue. I have no idea if a bug was logged for it, but I do know it's been a problem since at least FM 13.

Views

5.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

problem creating/editing tab stops in FM2015

Explorer ,
Jan 25, 2016

Copy link to clipboard

Copied

Hello,

I sometimes can't add a new tab stop, or edit a tab stop that has already been added, using the Paragraph Designer. Here's what happens:

I click on the tab I want to change and click Edit. The Edit Tab Stop dialog opens.

I enter the position in the New Position box.

I click Continue.

This closes the Edit box and goes back to the Paragraph Designer. The new tab is in the list, but only for a second, and then it just disappears. I go back to the beginning and try again, but the same thing happens.

The same thing also happens when I try to edit a tab stop that has already been created.

An important thing to mention here is that this is an intermittent problem. It doesn't always happen - sometimes it works fine, for either adding new tab stops or editing an existing one. I haven't been able to discern any pattern associated with it.

This wasn't a problem in FM8. But this past summer I upgraded to FM 2015 and I have encountered this problem numerous times. Is this a bug? Or is there a new step I need to do, that I'm not aware of?

Thanks,

Joyce

Adobe Community Professional
Correct answer by LinSims | Adobe Community Professional

It's still an issue sometimes, and for some reason it's associated with graphics files. What has been learned is that if you turn off the display of graphics in the document (View > Options and deselect the Graphics option), then you can edit your paragraph tabs as usual.

 

Weird, but this has worked for many people facing this same issue. I have no idea if a bug was logged for it, but I do know it's been a problem since at least FM 13.

Views

5.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jan 25, 2016 0
Adobe Employee ,
Jan 25, 2016

Copy link to clipboard

Copied

Hi Joyce,

please check wich version of FrameMaker 2015 you have (> Help > About FrameMaker). I think I remember this was a bug in a very early version of FM2015.

It's no longer present in the current builds. The latest version is FrameMaker 2015.0.2 (13.0.2.433).

If your versions older than this, please update with the latest patches. You can do this with > Help > Updates…

You can also download the latest updates here.

Thanks,

*Stefan.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2016 0
Explorer ,
Jan 25, 2016

Copy link to clipboard

Copied

Hi Stefan,

I upgraded to the latest version, and now have build 13.0.2.433 installed. I also restarted my system afterwards.

Unfortunately, the problem is still there. New tabs disappear as soon as I create them. If I try to edit one that is already there, it will revert to the original value as soon as I enter it. (For example, if I want to change a tab stop from 3 inches to 4 inches, I enter 4.0 in the Edit Tab Stop dialog and click Continue. Back in the Paragraph Designer, the value "4.0" appears in the tab-stops list for a half-second, and immediately goes back to 3.0.)

Could there be some other problem causing this?

Thanks,

Joyce

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2016 1
Explorer ,
Jan 25, 2016

Copy link to clipboard

Copied

P.S. I didn't mean to flag this as the correct answer since it did not work. Not sure how to remove that. However, thank you for taking the time. I hope that you or someone else has another suggestion!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2016 1
Most Valuable Participant ,
Jan 25, 2016

Copy link to clipboard

Copied

Do you have any plug-ins or Extendscripts [running automatically at start-up]?

Are you trying to make the change in a paratag with an override applied [see the Status Bar - the tag name will have an asterisk beside it when there is an override]?  Did you hit the Apply or Update All button after making the change(s)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2016 0
Adobe Employee ,
Jan 25, 2016

Copy link to clipboard

Copied

I have tried to reproduce this in all kind of combinations I could think of, but I was not able to get this effect.

Is there anything special? Like, let's say a combination of left, right, center tabs with ... to fill or anything other special?

Does it also happen with documents, that you create in FM 2015 from the scratch? Or only with documents that came from FM8?

Does it also happen with styles that you created from the scratch? Or only with legacy styles?

There must be something … 😉

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2016 0
Explorer ,
Jan 25, 2016

Copy link to clipboard

Copied

Hi Arnis,

I'm not sure what Extendscripts are - what are likely names for them? I'm looking at the list of processes in the task manager, but i don't see anything that jumps out at me as a script that might affect FrameMaker. I haven't added anything that I was aware of. The only plug-ins I have are for Firefox, i think.

There's no asterisk next to the paragraph tag in the status bar. I didn't even have time to hit "Apply," because my change disappeared before I could.

Thanks,

Joyce

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2016 0
Explorer ,
Jan 25, 2016

Copy link to clipboard

Copied

Stefan,

You know, I think the files I'm using are all originally FM8 files that I converted to 2015. I will try this with a brand new file to see what happens. Watch this space.

Thanks,

Joyce

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2016 0
Most Valuable Participant ,
Jan 25, 2016

Copy link to clipboard

Copied

Joyce.

The plug-ins and Extendscripts that I was referring to are FM specific, but it sounds like you don't have any installed. I also tried to duplicate your scenario, as Stefan did, and can not see this type of behaviour either.

If you could include a screen capture [or a video clip link if possible] that shows what symbols are in the Ruler along with the Paragraph Designer and Edit Tab window (something like as shown below), it might provide some additional clues as to what might be happening.

tab_stops_sample.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2016 0
Explorer ,
Jan 25, 2016

Copy link to clipboard

Copied

I tried the last thing Stefan suggested, of using a brand-new file, not a converted FM8 file, and it didn't happen. But the file didn't have much content in it, so I'm not sure that was the cause.

However, after I created the test file, I opened one of the real files where the problem existed, and it didn't happen as much. It still happened, just not all the time. It's a weird problem - not consistent.

Next time I encounter this, I'll get the screen captures you asked for and post them here.

Thanks again!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 25, 2016 0
Adobe Community Professional ,
Jan 26, 2016

Copy link to clipboard

Copied

I would suggest doing a MIF-wash of your old files; that may clean out some accumulated cruft.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 26, 2016 1
Community Beginner ,
Feb 15, 2016

Copy link to clipboard

Copied

Hi,

I also have the same exact problem.

I tried adding new tabs via the paragraph designer, but failed miserably.

It seems the problem occurs when upgrading documents from older FrameMaker versions.

The document I'm working on was originally created in FM-12. Now it's in FM-15.

Trying to update existing paragraph format in paragraph designer by adding more tabs - fails.

However, if I create a new document, and add tabs, the problem disappears.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 15, 2016 0
Community Beginner ,
Mar 22, 2016

Copy link to clipboard

Copied

Hello,

I have the same problem, and I can't find a solution.

I have tried creating a document from scratch and imported my paragraphs. And this still happens.

I can add tab stops only if I create a new document and create new paragraphs.

Bellow is a video with the bug in action

Please solve this issue. It's not very ok to have to create new documents and redefine the paragraphs.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2016 1
Adobe Community Professional ,
Mar 22, 2016

Copy link to clipboard

Copied

Are you totally patched up on FM2015? – there’s been at least 2 patches since its release.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2016 0
Community Beginner ,
Mar 22, 2016

Copy link to clipboard

Copied

My version is 13.0.2.433

I had some problems with FM in the beginning of the year, and I asked for help from adobe support, which reinstalled FM2015 from the latest installer on 24.02.2016.

Are there patches newer than that date?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2016 0
Adobe Community Professional ,
Mar 22, 2016

Copy link to clipboard

Copied

Not sure what the latest point version is, but try doing Help > Updates to poll for more recent fixes. Or you can check http://www.adobe.com/support/downloads/product.jsp?product=22&platform=Windows

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 22, 2016 0
Adobe Employee ,
Jul 14, 2016

Copy link to clipboard

Copied

Hi Mihail,

We tried to repro the bug at our end - from files as old as FM8 but we still haven't been able to repro the issue.

Please could yo send us a sample file at the earliest [{amagarwa at adobe dot com}]

Amit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 14, 2016 0
Advocate ,
Apr 18, 2016

Copy link to clipboard

Copied

I encounter the same problem. MIF washing did not help.

It is however not a problem for new documents, into which I have imported ALL formats from the failing one:

  1. File > New > Portrait
  2. Import all formats from existing file
  3. In exiting file select all contens of flow
  4. Copy into new file
  5. Update the master page usage in new file
  6. Close the existing file
  7. Save new file with the name of the existing one.
  8. Close FM and reopen to check new file.
  9. TAB handling OK now

What the heck is going on here?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2016 1
Most Valuable Participant ,
Apr 18, 2016

Copy link to clipboard

Copied

Please wait for the 3.1 patch, due out shortly, to see if this issue has been addressed.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 18, 2016 0
Most Valuable Participant ,
Apr 19, 2016

Copy link to clipboard

Copied

A quick update: please go ahead and install patch 3.0 and then 3.1 when it is released. The 3.1 patch won't address the tab issue (hopefully that will be in the next patch - Adobe is aware of this issue).

An alternative workaround (as it doesn't seem to affect all installations of FM2015) is to create the revised paratags in a new document using the same paratag name as in use and then import that back into the working document. Clumsy, inconvenient, but a workaround none the less.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 19, 2016 0
Explorer ,
Feb 08, 2019

Copy link to clipboard

Copied

So, I'm unsure why the "Left:" doesn't set the distance of my text from the bullet, and I cannot add the needed tab stop. I've encountered the issue with the text distance requiring a tab stop over and over again. It's illogical for me. Perhaps I've misunderstood the "Left:" function.

Your work-around is interesting, but why hasn't Adobe addressed this in almost 3 years??

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 08, 2019 0
Adobe Community Professional ,
Feb 08, 2019

Copy link to clipboard

Copied

Umm, because FM2015 is now 2 versions old? IMHO I'd be downloading a trial version of FM2019 (applying all current patches) & trying to see if this is fixed. And if it's not, then file a bug report.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 08, 2019 0
Explorer ,
Feb 08, 2019

Copy link to clipboard

Copied

THREE years!! That's the excuse? I have 2019 full version. I don't have time to google where everything got hidden away. I'm under a HUGE deadline, so I kept the 2015 for the moment. I suppose I should believe that this issue has been resolved in the newer versions? I've yet to see a version of FM that's bug-free. I hear that if I go back far enough, they did exist.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 08, 2019 0
Adobe Community Professional ,
Feb 08, 2019

Copy link to clipboard

Copied

LOL, don't kid yourself - all software has bugs even older versions of FM.

It just depends on whether the bug is mission-critical to you or not...But just to let you know, the FM team is much more responsive to fixes in the current version than they used to be. Every month/every couple of months there's a new patch out.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 08, 2019 0
Explorer ,
Jul 14, 2016

Copy link to clipboard

Copied

I have the same issue.  FM2015 fully patched to 13.0.3.495.

I did find somewhat of a workaround. If you are displaying rulers, just beneath is a thin strip. Click in the strip to add a tab stop. It displays as a bent arrow.

You can slide it left and right as required, and it shows up, and STAYS, in the Paragraph Editor window.  You still cannot edit it, however, and cannot add a leader if required (unless there is a special key combination that allows you to click to add a specific type of stop).

Tabby.jpg

So it is still broken but at least you can do something while you wait.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 14, 2016 2
Participant ,
Jul 24, 2016

Copy link to clipboard

Copied

What if you create a new file, get the tab stops where they need to be with all your imported formats, and then import those back into your existing files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2016 2
New Here ,
Feb 13, 2020

Copy link to clipboard

Copied

I realize that it's 4 years later, but THIS suggestion is the only thing that has worked for me in the face of this bug, which I just encountered today. I have the most up-to-date FrameMaker 2019 but I'm working with files originally created in FrameMaker 11 (and now converted). I can tell that this is going to be a problem in the 4,000 documents I'll be updating to my new FM. Having to create paragraph tags in empty documents and then import them into my existing documents every time I want to add/change a tab setting will not be fun, but at least it will be POSSIBLE, where nothing else worked.  Thanks for the clever solutioneering, Robnurflugel.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2020 0
Adobe Community Professional ,
Feb 13, 2020

Copy link to clipboard

Copied

It's still an issue sometimes, and for some reason it's associated with graphics files. What has been learned is that if you turn off the display of graphics in the document (View > Options and deselect the Graphics option), then you can edit your paragraph tabs as usual.

 

Weird, but this has worked for many people facing this same issue. I have no idea if a bug was logged for it, but I do know it's been a problem since at least FM 13.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2020 0
Participant ,
Nov 02, 2016

Copy link to clipboard

Copied

I am still seeing this issue. I'm completely patched up to 13.0.5.547. It happens with files that we created in various versions of FM over the last 10 years (and have been upgrading to the latest FM version as it becomes available). Oddly enough, I can create a new tab stop in some files, but there's no discernible pattern or evident reason why. AMAGARWA@ADOBE.COMStefan Gentz [Adobe]​ any idea what's going on?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2016 0
Engaged ,
Nov 02, 2016

Copy link to clipboard

Copied

The bug was submitted (and reproducible) by myself and Amit in July on 13.0.3.495: Bug#4170815 - v13.0.3.495 - Cannot modify tab stops in Paragraph Designer (changes revert when tab s...

I took a look at the release notes here: FrameMaker (2015 release) – Update 5 released – TechComm Central by Adobe  for the most recent version and I don't see that it's been addressed yet.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2016 0
Adobe Employee ,
Nov 02, 2016

Copy link to clipboard

Copied

Hi Deborah,

Please check your inbox and provide the requested information so that we can connect and troubleshoot this issue further.

I will be looking forward to your response.

Regards,

Ajit

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2016 0
Participant ,
Nov 03, 2016

Copy link to clipboard

Copied

Hi Ajit,

I replied from my work email. Please check your inbox.

Thanks

Deborah

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 03, 2016 0
Adobe Employee ,
Nov 07, 2016

Copy link to clipboard

Copied

Hi Deborah,

I think this bug isn't fixed with Update5.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 0
Advocate ,
Nov 07, 2016

Copy link to clipboard

Copied

Yes, Amit You are right - this hasn't been fixed in 13.0.5.547, hence I filed bug 4197115 on october 27.

Klaus Daube

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 07, 2016 1
New Here ,
Jan 29, 2017

Copy link to clipboard

Copied

Just want to add my voice to the mix, as I am experiencing this quite often. All of our files are new creations with the newly installed FM 2015. We have only just downloaded 2015 (v 13.0.2.433) and have yet to apply the patches, but it seems that the patches don't help anyway. Any estimates on a fix? Any ideas on a workaround? By the way, the manual method of adjusting tabs in the ruler only works some of the time and the resultant tab stops aren't precise (e.g. 0.987cm instead of 1cm).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jan 29, 2017 1
Adobe Community Professional ,
Feb 13, 2020

Copy link to clipboard

Copied

It's still not fixed, and the bug you filed, which was given a new number when they changed databases, was closed as a duplicate. Not that they have the NON-closed version available. Time to file a new report, maybe?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2020 0
New Here ,
Feb 13, 2020

Copy link to clipboard

Copied

Holy moly, that worked! That is weird, but excellent. Thanks for the help!
Confidentiality notice: This message may contain confidential information. It is intended only for the person to whom it is addressed. If you are not that person, you should not use this message. We request that you notify us by replying to this message, and then delete all copies including any contained in your reply. Thank you.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 13, 2020 0