Highlighted

Problem with autonumbering

Community Beginner ,
Apr 14, 2020

Copy link to clipboard

Copied

I have a problem with the autonumbering. I have a format that simply counts up usinga simple <n+> tag ( [T:Fig. <n+>:]  and used in tables). I have various files combined into one book and NORMALLY it would count up when using the same format across the files in the book (i.e.counting up from the the last value in the file previously listed in the book). I have tried everything I can think of: cleaning up the formats catalogue, changing the paragraph setting in the book settings for each individual file, restarting FrameMaker, restarting the computer, fiddling with the format itself, importing the formts from the file that goes before and more – n will just not behave and I am at my wits' end and getting really annoyed. I doubt that throwing the PC out of the window will help.
I am using the latest FM version on a Windows 10 Pro.
Any ideas anybody?

Views

605

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Problem with autonumbering

Community Beginner ,
Apr 14, 2020

Copy link to clipboard

Copied

I have a problem with the autonumbering. I have a format that simply counts up usinga simple <n+> tag ( [T:Fig. <n+>:]  and used in tables). I have various files combined into one book and NORMALLY it would count up when using the same format across the files in the book (i.e.counting up from the the last value in the file previously listed in the book). I have tried everything I can think of: cleaning up the formats catalogue, changing the paragraph setting in the book settings for each individual file, restarting FrameMaker, restarting the computer, fiddling with the format itself, importing the formts from the file that goes before and more – n will just not behave and I am at my wits' end and getting really annoyed. I doubt that throwing the PC out of the window will help.
I am using the latest FM version on a Windows 10 Pro.
Any ideas anybody?

Views

606

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 14, 2020 0
Advisor ,
Apr 14, 2020

Copy link to clipboard

Copied

First question, what's the problem you're facing? and first general thought, have you reset the paragraph numbering from the book panel?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2020 0
Community Beginner ,
Apr 14, 2020

Copy link to clipboard

Copied

Thanks for replying to my post:
The problem was (skip to bottom for end result)  that the numberiung overlooked the settings.Yes, I did change the paragraph numbering - that is actually what i meant with "changing the paragraph setting in the book settings " (I am using the German version, so not sure about the terms in the English version).

Sometimes – after chaning the settings and updating the book – nothing happened and the numbering started anew (i.e. with 1) in the next chapter/file. Then, next update, it ignored the fact that a number had been previsiouly applied - e.g. the last chapter ended with Fig. 10, the next chapter started with Fig 10 - that was my inital problem.
I tried re-formatting all tables or chaning the files around in the book to find a regularity in the behaviour

However in the end - I did find a solution - or rather a work around: I traced the table that was "overlooked" and copied and pasted the previous table and entered the content of the "hick-up"-table. I then closed framemaker again, re-opened it and updated the book and that worked. It only cost me 2 hours and there seems no reason. It maddens me that there is no way to see where it takes the current n-value from. That would help in even finding a work around.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2020 0
Adobe Community Professional ,
Apr 14, 2020

Copy link to clipboard

Copied

Right-click on your book component (or components) in the book window and choose Numbering. Here is the setting you need to get your paragraph numbering to continue across all files:

 

image.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2020 0
Community Beginner ,
Apr 14, 2020

Copy link to clipboard

Copied

Thanks but I had tried that - but as I said, to no avail. it seems to have got stuck.
When I chucked the table it got stuck on, it  behaved again. I have no clue what was wring with the table as it had the same settings as the ones in the same file and the follwing. The caption (with the autonumbering) was of the same paragraph format and even importing and exporting the formats (both for the table and the paragraph) did not help.
It was just one of those things that are not supposed to happen yet do (and sometimes end in the programme crashing) and often are remedied the programme or the computer is restarted. Very frsutrating though as it takes up a lot of time and effort and there are few options to finding out where the problem lies - i.e., e.g. a debugging feature for "n")

 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 14, 2020 0