Highlighted

Publish to pdf creates pdf with "Invalid ColorSpace"?

Engaged ,
Nov 01, 2018

Copy link to clipboard

Copied

Running FrameMaker 2019 rel. 15.0.1.430, Win 7 - 64 bit.

I am trying to publish a bunch of files to PDF for print output, but I keep getting empty PDF's with a dialogue stating stat the have "Invalid ColorSpace"

Printing the docs with "High Quality Print" and not "Press Quality" makes it work. Only that was not what I was trying to do...

What might be wrong? I thought Adobe had this "CMYK color thing" in FrameMaker fixed by now.

Best regards

Bjørn

Adobe Community Professional
Correct answer by LinSims | Adobe Community Professional

Adobe expects to have this fixed in Update 2. Meantime, Amitoj gave me a workaround.

In the maker.ini file located in C:\Program Files\Adobe\Adobe FrameMaker 2019, change EnforcePDFXCompliance to OFF.

Views

1.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Publish to pdf creates pdf with "Invalid ColorSpace"?

Engaged ,
Nov 01, 2018

Copy link to clipboard

Copied

Running FrameMaker 2019 rel. 15.0.1.430, Win 7 - 64 bit.

I am trying to publish a bunch of files to PDF for print output, but I keep getting empty PDF's with a dialogue stating stat the have "Invalid ColorSpace"

Printing the docs with "High Quality Print" and not "Press Quality" makes it work. Only that was not what I was trying to do...

What might be wrong? I thought Adobe had this "CMYK color thing" in FrameMaker fixed by now.

Best regards

Bjørn

Adobe Community Professional
Correct answer by LinSims | Adobe Community Professional

Adobe expects to have this fixed in Update 2. Meantime, Amitoj gave me a workaround.

In the maker.ini file located in C:\Program Files\Adobe\Adobe FrameMaker 2019, change EnforcePDFXCompliance to OFF.

Views

1.0K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 01, 2018 0
Adobe Community Professional ,
Nov 01, 2018

Copy link to clipboard

Copied

Make sure that you're up to date - they have been working on IIRC.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2018 2
Adobe Community Professional ,
Nov 01, 2018

Copy link to clipboard

Copied

Adobe expects to have this fixed in Update 2. Meantime, Amitoj gave me a workaround.

In the maker.ini file located in C:\Program Files\Adobe\Adobe FrameMaker 2019, change EnforcePDFXCompliance to OFF.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 01, 2018 2
Engaged ,
Nov 02, 2018

Copy link to clipboard

Copied

Yes, adjusting the maker.ini fixes the problem. Color management in FrameMaker is still a bit confusing but at least there seems to be substantial improvements coming with respect to cmyk colors and print. Still wonder why though, you can adjust overprint etc in the fills dialogue, but not in the stroke dialogue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 02, 2018 1
Participant ,
Nov 27, 2018

Copy link to clipboard

Copied

Great responses here.

Unfortunately, I was provoked to try the new Publish pod to create a PDF. It failed with the invalid colorspace error. Am not going to mess with it, though the workaround seems easy; I have another font issue to fix. For the color thing, I'll lay off using the Publish pod until it's fully baked.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 27, 2018 0
Adobe Employee ,
Nov 27, 2018

Copy link to clipboard

Copied

@seanb_us@yahoo.com

Please try the following workaround

EnforcePDFXCompliance in maker.ini please turn it "OFF"

we have an update 2 coming up next few days where we have this addressed already.

thanks

amitoj Singh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 27, 2018 1
Participant ,
Nov 29, 2018

Copy link to clipboard

Copied

Perhaps someone can comment on this.

I went to set EnforcePDFXCompliance to OFF. My laptop is "managed" by IT. I couldn't save changes to maker.ini in C:\Program Files\ Adobe\ FrameMaker 19 because of permissions. I spent 60 minutes on the phone with our IT service and no luck. Finally found a workaround to copy maker.ini to a different location, change it, and copy it back, overwriting the original.

Anyone run into such a hassle? (The fix worked, though, because I can now create PDFs and open them.)

Sean

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 29, 2018 0
Adobe Community Professional ,
Nov 29, 2018

Copy link to clipboard

Copied

Comment how? Other than your IT people not giving you proper access? You probably could have just edited the second maker.ini in your c:\users\user_name\AppData\ folder (have to be able to view hidden folders though) to include the line you wanted to have come into effect.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 29, 2018 2
Adobe Employee ,
Nov 29, 2018

Copy link to clipboard

Copied

Yes, the maker.ini in the FrameMaker installation folder should remain untouched and is protected by Windows by default.

As Jeff_Coatsworth writes, the correct maker.ini is the one in your user profile folder. Just copy this into your Windows Explorer address bar:

%appdata%\Adobe\FrameMaker\15

There you will find the user-specific maker.ini. As it is in your user profile folder, you can open, edit, and save it.

Just add EnforcePDFXCompliance=On in the [Preferences] section.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 29, 2018 1
Participant ,
Nov 29, 2018

Copy link to clipboard

Copied

That's helpful, thanks. I found the extra ini file here, C:\Users\userisme\AppData\Roaming\Adobe\FrameMaker\15.

I would rather just make changes in one spot, though, and program files seems to have more items to change. And, the original answer was to make changes in program files, which I did. (Having two maker.ini files feels redundant, although I understand this probably gives different users on the same computer their own settings. Still, I'd have to make this workaround in each and every maker.ini, right? Better to just do it once.)

Anyway, I was wondering if anyone else had such trouble editing maker.ini in the program files location. I was wondering why the IT staff had such a difficult time and whether Windows 10 was doing something evil?

Sean

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 29, 2018 0
Most Valuable Participant ,
Nov 29, 2018

Copy link to clipboard

Copied

Hi Sean,

Keep in mind that FM reads the user version of the maker.ini last and will then add or overwrite any directive in the FM directory version. So go with what Stefan says and leave the original untouched.

Klaus Daube has a great resource on the internals of the maker.ini content at: https://www.daube.ch/docu/fmaker65.html

Regards,

Arnis

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 29, 2018 1
Participant ,
Nov 29, 2018

Copy link to clipboard

Copied

Thanks Arnis. I had considered that FM would have to read the user version of maker.ini last. Still, if I want to make a change for all users, like the EnforcePDFXCompliance one, doesn't it make sense to just make the change once, in Program Files, rather than coordinate all the various maker.ini files in user locations? And, when the update is released and you have to go change everything back, isn't it more efficient to just revert the maker.ini one time?

All of this makes me curious to know the use case for making maker.ini files for each user on a given computer. Are significant numbers of people sharing the same computer with the same installation of FrameMaker that user-specific maker.ini files are useful?

Anyway, thanks for the tip,

Cheers,

Sean

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 29, 2018 0
Most Valuable Participant ,
Nov 29, 2018

Copy link to clipboard

Copied

Well, if all users are "sharing" the same computer and you are license compliant, then yes it would make sense to make such "global" changes in the FM directory version. However, in most cases, each tech writer is usually working on their own machine [unless you have something like shifts and machines are shared].

I think I'll defer to Stefan to provide an official Adobe response to this one.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 29, 2018 0
pulkitn LATEST
Adobe Employee ,
Nov 29, 2018

Copy link to clipboard

Copied

Stefan Gentz (Adobe), I feel it should be EnforcePDXCompliance=Off  as a workaround for colorspace issue 

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 29, 2018 0