Highlighted

"Spread" control not working on some paragraphs

Community Beginner ,
Nov 05, 2018

Copy link to clipboard

Copied

Are there situations where FM's "spread" control (in Paragraph Designer) can become inoperable, or perhaps can be counteracted by some other setting, in such a way that it will be able to change the tracking on some paragraphs, but seem to be useless on others, no matter how you set it? These are all fully justified paragraphs, with a normal default spread of negative 1. The Word Spacing is also set to the same percentages on all paragraphs.

I've been trying to bump down to the next line an en dash that needs to be directly followed by a "46," followed by a nonbreaking space, a degree sign, and finally a capital "C" for "Celsius"), but currently, that en dash stubbornly wants to sit by itself at the very end of the line, with the "46" sitting at the beginning of the next line....which is no good! I figured the easiest way to keep this temperature together is to nudge the en dash to the line below, joining the rest of the temperature range....but there is no value, negative or positive, that I can put into the spread control that makes any difference whatsoever on the paragraph! It's very odd....I don't think I can recall ever seeing this happen before. I tried the spread control on the next paragraph, too -- a five line paragraph -- and changing a neg. 1 spread to neg 2 or neg 3, and then positive 1, 2, and 3 all did nothing at all ....no words broke onto other lines. It's not become completely inoperable on the entire document though; I an able to change some paragraphs with minor changes in the spread....but for some reason, not these two paragraphs (and possibly others --- I've only checked these two). Quark would give me a way to bump any character at the end of a line to the next line and everything stays justified, but Frame doesn't seem to have this ability....so I need to use that spread control sometimes.

UPDATE: I just now had success by changing a setting I usually never play with, the "Word Spacing" percentages....changing a few of those finally bumped the en dash down as I wanted. But I'd still very curious about the spread control ineffectiveness --- if it sounds like a glitch perhaps (I've found nothing in google, thus far), or if I'm just ignorant of some other FM setting that can work against the spread, so that changing the spread will accomplishes nothing...? I compared the paragrah settings on the problem paragraph vs. one in which the spread control worked, and everythign was the same on both that I could see...all were set to our default paragraph style. I'm at a loss! Hope I was able to make everything clear enough...thanks in advance--! (oh, and if it helps, this is the 2015 FM, with all current updates installed: version 13.0.5.547)

Views

280

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

"Spread" control not working on some paragraphs

Community Beginner ,
Nov 05, 2018

Copy link to clipboard

Copied

Are there situations where FM's "spread" control (in Paragraph Designer) can become inoperable, or perhaps can be counteracted by some other setting, in such a way that it will be able to change the tracking on some paragraphs, but seem to be useless on others, no matter how you set it? These are all fully justified paragraphs, with a normal default spread of negative 1. The Word Spacing is also set to the same percentages on all paragraphs.

I've been trying to bump down to the next line an en dash that needs to be directly followed by a "46," followed by a nonbreaking space, a degree sign, and finally a capital "C" for "Celsius"), but currently, that en dash stubbornly wants to sit by itself at the very end of the line, with the "46" sitting at the beginning of the next line....which is no good! I figured the easiest way to keep this temperature together is to nudge the en dash to the line below, joining the rest of the temperature range....but there is no value, negative or positive, that I can put into the spread control that makes any difference whatsoever on the paragraph! It's very odd....I don't think I can recall ever seeing this happen before. I tried the spread control on the next paragraph, too -- a five line paragraph -- and changing a neg. 1 spread to neg 2 or neg 3, and then positive 1, 2, and 3 all did nothing at all ....no words broke onto other lines. It's not become completely inoperable on the entire document though; I an able to change some paragraphs with minor changes in the spread....but for some reason, not these two paragraphs (and possibly others --- I've only checked these two). Quark would give me a way to bump any character at the end of a line to the next line and everything stays justified, but Frame doesn't seem to have this ability....so I need to use that spread control sometimes.

UPDATE: I just now had success by changing a setting I usually never play with, the "Word Spacing" percentages....changing a few of those finally bumped the en dash down as I wanted. But I'd still very curious about the spread control ineffectiveness --- if it sounds like a glitch perhaps (I've found nothing in google, thus far), or if I'm just ignorant of some other FM setting that can work against the spread, so that changing the spread will accomplishes nothing...? I compared the paragrah settings on the problem paragraph vs. one in which the spread control worked, and everythign was the same on both that I could see...all were set to our default paragraph style. I'm at a loss! Hope I was able to make everything clear enough...thanks in advance--! (oh, and if it helps, this is the 2015 FM, with all current updates installed: version 13.0.5.547)

Views

281

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Nov 05, 2018 0
Advocate ,
Nov 09, 2018

Copy link to clipboard

Copied

You may have a look at Format > Document > Text Options: Allow Line Breaks After.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0
Community Beginner ,
Nov 09, 2018

Copy link to clipboard

Copied

You may have a look at Format > Document > Text Options: Allow Line Breaks After.

K. Daube, thanks for that -- I'd forgotten about that setting. Here's what I've got in mine: / - – —\sm

I think the 2nd, 3rd, and 4th characters above are supposed to be a hyphen, en dash, and em dash -- even though they don't look quite like this in actual practice, keyed in Frame. The thing is, this setting couldn't explain why the spread setting works on one paragraph but not another with the exact same Paragraph Designer settings, same number of lines, etc....b/c Format>Document>Text Options: "Allow Line Breaks After" is global to the entire document; it should affect one paragraph the same as any other, I'd think...

Like I said, I ultimately WAS able to get it to break exactly where I wanted it to -- right after the en dash. I just had to do it via the Word Spacing percentages, not via Spread, as I'd usually use. The nagging mystery for me now is why won't that Spread control do anything at all on some paragraphs, but will on other seemingly identical ones....? I'm not even talking about it not getting specific characters to break in specific places....I'm saying my Spread control won't rebreak certain paragraphs anywhere at all, on ANY word, whether I set it to minus 3, zero, or plus 3! It seems like a bug, unless there's a paragraph-specific setting or setup I'm not aware of that could be behind the way it's behaving...

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0
Adobe Community Professional ,
Nov 09, 2018

Copy link to clipboard

Copied

FM2015 and 2017 had a bug that prevented en dashes from being non-breaking, no matter what you did. The bug tracker claims this is fixed, but I suspect that is only for FM2019 since no updates have been made to FM2015 and 2017 since the bug was reported.

Rick Quattro over on the Framers email list suggested creating a variable that contains a non-breaking hyphen with a character tag that stretches it out to about 200%. So the variable would contain:

[stretching character tag]<non-breaking hyphen special character>[Default Font]

I can confirm this works, although the hyphen is a little "taller" than the standard en dash is.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Nov 09, 2018 0