Highlighted

Rechtschreibprüfung Leerzeichen nach Punkt FM2017

Explorer ,
Mar 23, 2017

Copy link to clipboard

Copied

Guten Tag,

seit dem Update zu FrameMaker 2017, werden Leerzeichen nach Klammern, Punkten etc. als Rechtschreibfehler angesehen.

Wenn ich die Rechtschreiboption für "Leerzeichen nach:   " deaktiviere, werden die "normalen" Leerzeichen auch nicht mehr als Fehler erkannt.

Scheint mir ein Fehler in der Software zu sein.

Views

596

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Rechtschreibprüfung Leerzeichen nach Punkt FM2017

Explorer ,
Mar 23, 2017

Copy link to clipboard

Copied

Guten Tag,

seit dem Update zu FrameMaker 2017, werden Leerzeichen nach Klammern, Punkten etc. als Rechtschreibfehler angesehen.

Wenn ich die Rechtschreiboption für "Leerzeichen nach:   " deaktiviere, werden die "normalen" Leerzeichen auch nicht mehr als Fehler erkannt.

Scheint mir ein Fehler in der Software zu sein.

Views

597

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Mar 23, 2017 0
Adobe Employee ,
Mar 23, 2017

Copy link to clipboard

Copied

I was not able to reproduce this. Can you provide some more info? Which language do you have assigned to the paragraph? Can you provide a sample sentence (Copy & paste it from FrameMaker to here)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 23, 2017 0
Explorer ,
Mar 23, 2017

Copy link to clipboard

Copied

The text is set to British English.

Example:

The lifting drives (rope drums) will be positioned laterally to the machine columns. Counterweights will be mounted inside the machine columns.

I get green squiggly lines under the space between "s) w" and also "s. C". The spellchecker wants to remove the space after the period completely.

The period is added in the "ignore spaces after: " option. (Sorry don't know how the option is called in english.)

Unchecking the option removes the green marks.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 23, 2017 0
Adobe Community Professional ,
Mar 24, 2017

Copy link to clipboard

Copied

Any chance there are two or more spaces at these locations? If so you can either remove them (perhaps with a global change of two spaces to one), or if you don't mind having them, by deselecting the "Extra Spaces" option in the Spelling Checker.

      --Lynne

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 24, 2017 0
Explorer ,
Mar 24, 2017

Copy link to clipboard

Copied

Unfortunatly there a only single spaces in the sentences.

Generally speaking I get green markings every time a space is required and correct.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 24, 2017 0
Adobe Employee ,
Mar 24, 2017

Copy link to clipboard

Copied

Hm. I cannot replicate this with the exact same text and EN UK language applied. I only get the same green line for "Extra Spaces" and there it's okay because I have activated "Straight Quotes" in the spell checker.

BUT: If I exchange the default entries for "Space Before" and "Space After" like this in > Edit > Preferences > Spelling > Spelling Options:

Space Before: $([{«“‘‹‚„

Space After:  !%),.:;?]}»”’›

... then I get exactly the same result you get.

So, could you please check if the entries were mixed up in your FM for some reason?

They should be like this:

Space Before: !%),.:;?]}»”’›

Space After:  $([{«“‘‹‚„

I have a strong feeling that this might be the case ...

If it should be the case and solve the problem, please mark this answer as "Correct Answer", so that we can close it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 24, 2017 0
Explorer ,
Mar 26, 2017

Copy link to clipboard

Copied

No, the program is set to default settings.

If I reverse the settings intentionally it looks like this:

Space Before: $([{«“‘‹‚„

Space After:  !%),.:;?]}»”’›

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 26, 2017 0
Adobe Employee ,
Mar 27, 2017

Copy link to clipboard

Copied

Thanks for confirming. We will look into this. Are you using FrameMaker with the German or English User Interface?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 27, 2017 0
Explorer ,
Mar 27, 2017

Copy link to clipboard

Copied

German interface.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 27, 2017 0
StevenR LATEST
Explorer ,
Sep 07, 2018

Copy link to clipboard

Copied

Hello Stefan,

is there already a solution for that "Spacea after" problem?

I am currently working with FrameMaker 2019 and experienced the same behaviour I also can confirm for 2017.

Glad to get a solution

Steffen

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Sep 07, 2018 0
Explorer ,
May 03, 2017

Copy link to clipboard

Copied

Error still there after the latest patch. Every space after a period ist marked green as error by the spellchecker.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 03, 2017 0
Advocate ,
May 04, 2017

Copy link to clipboard

Copied

Forumname01, have you changed any of the dafault settings for the Dictionary Provide Settings (rechtschreibung > Wörterbuch)?

Klaus Daube

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 04, 2017 0
Explorer ,
May 04, 2017

Copy link to clipboard

Copied

No, dictionary it is set to Germany -> Hunspell, settings for spell checking are set to default.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 04, 2017 0
Explorer ,
May 04, 2017

Copy link to clipboard

Copied

So i found something new.

It appears that the entries in "Spaces before" are also used in the "spaces after" option in the spellchecker. When I remove one of the elements in the default settings of "spaces before" ->  !%),.:;?]}»”’› . This element is also no longer marked as mistake if it has a space after it.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
May 04, 2017 0