Highlighted

Removing underlines in FM 2017

Explorer ,
Oct 24, 2018

Copy link to clipboard

Copied

Hi,

Is there a way to remove the underlines from hyperlinks created in HTML5 output?

I have been searching for an answer but have not had any luck.

Thanks for any help.

Cheers,

Elizabeth

Views

320

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Removing underlines in FM 2017

Explorer ,
Oct 24, 2018

Copy link to clipboard

Copied

Hi,

Is there a way to remove the underlines from hyperlinks created in HTML5 output?

I have been searching for an answer but have not had any luck.

Thanks for any help.

Cheers,

Elizabeth

Views

321

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Oct 24, 2018 0
Adobe Community Professional ,
Oct 24, 2018

Copy link to clipboard

Copied

I suspect that would be controlled by the CSS applied to the files.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2018 0
Engaged ,
Oct 24, 2018

Copy link to clipboard

Copied

The hyperlinks are your cross references.

So these depend on your cross reference style. (character style)

In the Publish pod, choose responsive HTML, and then edit the Settings file.

In Style mapping select the style you use for the cross references/hyperlinks and change it to be without the underline.

2018-10-25_8-10-26.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 24, 2018 0
Explorer ,
Oct 25, 2018

Copy link to clipboard

Copied

Hi Zippy21, Jeff_Coatsworth,

When I look at the Settings file in the Publish pod, the text does not appear with underlines.

When I create a PDF of the document the links appear in the color I chose and are not underlined.

I have looked at every file created after publishing and can't determine what is causing the underlines.

Any other suggestions??

Thank you again.

Cheers,

Elizabeth

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Adobe Community Professional ,
Oct 25, 2018

Copy link to clipboard

Copied

Can you give us the same screenshot that Zippy21​ shared?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Explorer ,
Oct 25, 2018

Copy link to clipboard

Copied

Yes. Here's the screenshot:

FM_Style_Mapping.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Adobe Community Professional ,
Oct 25, 2018

Copy link to clipboard

Copied

Ok, and how does the CSS describe what to do with hyperlinks?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Explorer ,
Oct 25, 2018

Copy link to clipboard

Copied

Where do I find the CSS?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Adobe Community Professional ,
Oct 25, 2018

Copy link to clipboard

Copied

You can look at it via FM by using that "Manage CSS:" button or you can look at the CSS file being referenced in your output by searching for *.css in your output folder.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Explorer ,
Oct 25, 2018

Copy link to clipboard

Copied

This is what’s in the output CSS file:

}

span.FM_Hyperlink {

font-family:Arial;

font-style:normal;

font-weight:normal;

font-size:11.0pt;

color:#305596;

text-decoration:none;

letter-spacing:0.00em;

}

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Adobe Community Professional ,
Oct 25, 2018

Copy link to clipboard

Copied

Have a look around for other "link" hits in the CSS file - according to CSS Styling Links you can use a text-decoration property to turn off underlining.

Edit - sorry, I missed seeing that bit in your post - there must be some other "link" properties overriding the styling (or it's not that CSS being used)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Explorer ,
Oct 25, 2018

Copy link to clipboard

Copied

I’ve checked the other entries in the CSS and the text-decoration property is set to ‘None’. From what I’ve found, that should remove the underlining.

Is there anything else I can try?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Adobe Community Professional ,
Oct 25, 2018

Copy link to clipboard

Copied

Are there multiple CSS files in the output folders?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Engaged ,
Oct 25, 2018

Copy link to clipboard

Copied

In the text box, if you click  Edit style,  how about if you actually check the "none" checkbox under text decoration?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Explorer ,
Oct 25, 2018

Copy link to clipboard

Copied

Yes, there is one more CSS file, but it doesn’t contain the text-decoration property.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Explorer ,
Oct 25, 2018

Copy link to clipboard

Copied

In the Publish Settings page, when I choose the Hyperlink entry from the Style Mapping page, and then click the Edit Style button, nothing happens.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Engaged ,
Oct 25, 2018

Copy link to clipboard

Copied

The box below should open. I was saying to actually choose none here

1.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Adobe Community Professional ,
Oct 25, 2018

Copy link to clipboard

Copied

Check the HTML file of a page with an underlined hyperlink and see what CSS file(s) it's referencing - whatever is the "last" one in the list will be the one used.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Engaged ,
Oct 25, 2018

Copy link to clipboard

Copied

Instead of "Use Source style" can you choose a different Output style from the mapping drop down box?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Explorer ,
Oct 25, 2018

Copy link to clipboard

Copied

Ok. So how do I get to that page?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Engaged ,
Oct 25, 2018

Copy link to clipboard

Copied

Which were you asking about.

2 different suggestions

choose a different style in this drop down box for the hyperlink

2.png

or   this box should open when you click Edit style if hyperlink (or whatever you named the style you assign) is selected.  and there choose none

3.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Explorer ,
Oct 25, 2018

Copy link to clipboard

Copied

The only other option in that drop down is ‘Automap’ but clicking that produces this:

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Adobe Community Professional ,
Oct 25, 2018

Copy link to clipboard

Copied

Using the [Use Source Style] option attempts to use Fm formatting for your web output. Don't do that.

Start by setting Output Style to something other than [Use Source Style]

After that, you will have the option to edit the style you choose using the Edit Style button.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Explorer ,
Oct 25, 2018

Copy link to clipboard

Copied

How do I change the Output Style setting to something else? When I click the drop-down arrow I see Automap, but if I select that I see this:

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Adobe Community Professional ,
Oct 25, 2018

Copy link to clipboard

Copied

Your screenshots aren't coming through - use the web interface to put them in your posts.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
New Here ,
Oct 25, 2018

Copy link to clipboard

Copied

Let me try this again.

This is what I see: Automapping failed. Add ‘Hyperlink’ to the CSS

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0
Explorer ,
Oct 25, 2018

Copy link to clipboard

Copied

In response to your last answer, here's what I see:  Automapping failed. Add 'Hyperlink' to the CSS

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 25, 2018 0