Highlighted

Structured FM 2019: File > Open menu defaults to show only .Book

New Here ,
Apr 05, 2019

Copy link to clipboard

Copied

I have struggled trying to find a way to change the default type of file FM shows when using the File > Open dialog.

After switching to Structured Framemaker we now primarily work in .XML and .DITAMAP files. We have now used Framemaker 2015, 2017, and now 2019 and the behavior continues.

It drives me insane that every time I use File > Open, I have to switch the file type off of Book (*.book) to All Files. Is there a setting where I can change this default? I can't find any maker.ini or preference option but am hoping someone has found a solution.

TOPICS
Structured

Views

689

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Structured FM 2019: File > Open menu defaults to show only .Book

New Here ,
Apr 05, 2019

Copy link to clipboard

Copied

I have struggled trying to find a way to change the default type of file FM shows when using the File > Open dialog.

After switching to Structured Framemaker we now primarily work in .XML and .DITAMAP files. We have now used Framemaker 2015, 2017, and now 2019 and the behavior continues.

It drives me insane that every time I use File > Open, I have to switch the file type off of Book (*.book) to All Files. Is there a setting where I can change this default? I can't find any maker.ini or preference option but am hoping someone has found a solution.

TOPICS
Structured

Views

690

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 05, 2019 0
Adobe Employee ,
Apr 07, 2019

Copy link to clipboard

Copied

Can you please check the version of FM2019 and if it has all the updates applied.

by default the option is  All framemaker documents which now includes .dita, .ditamap and .xml files as well.

Thanks

Amitoj Singh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 07, 2019 0
Adobe Community Professional ,
Apr 08, 2019

Copy link to clipboard

Copied

Amitoj,

   You say, "by default the option is  All framemaker documents". Is that a default that users can change? Personally, I have other filenaming conventions and would like my system to include .edd (for EDDs), .rw (for read/write rules), .app (for application definition files).

   Also, I am surprised that you decided that .sgm and .mml are not FrameMaker documents.

     --Lynne

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 08, 2019 0
Adobe Employee ,
Apr 08, 2019

Copy link to clipboard

Copied

Hi @charissaf75933291,

I think You are doing operation from "Code View " Workspace.

Kindly log a bug from Tracker  . It will surely be handled in the coming update.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 08, 2019 0
New Here ,
Apr 08, 2019

Copy link to clipboard

Copied

I did the latest updates (I'm now on 15.0.3.6.03) and also tried from Code View. I thought when i had no files open, I used to see all files as an option but I am not able to get that now.  .BOOK only. I'll open a bug as you suggest.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 08, 2019 0
Amitoj LATEST
Adobe Employee ,
Apr 09, 2019

Copy link to clipboard

Copied

We will get this fixed for an upcoming update.

thanks

Amitoj Singh

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 09, 2019 0