Text frame flows that is NOT autoconnected

Explorer ,
Apr 04, 2018

Copy link to clipboard

Copied

Hello, all.

I am using FM 2015 in a Windows 10 environment.

I am creating a template that has three master pages:

  • First: Contains one text frame ("Top") at the top of the page for document title and type variables, and one large text frame for body text ("Body"), which takes up the remainder of the page. I tagged "Top" as flow B, and did not autoconnect it. "Body" is flow A, and is autoconnected. The First master page looks like this:

TopBodyTextFlows.png

  • Left: Standard FrameMaker master page with untagged text frames for header and footer, and "Body" text frame
  • Right: Identical to Left

"Top" is intended to be self-contained. I want it to be obvious to any writer using the template for the first time, so they know where to put the title and doc type information.  I tagged it separately as B, and did not autoconnect it. If a document title overflows the "Top" text box, I would expect to see a black line at the bottom of "Top" indicating that my text was too lengthy.

Instead, if "Top" overflows, FrameMaker inserts a new First page as page 3 of the document. The text overflow appears in the Top text frame of that new page. Even if I select and delete the excess text, the new First page remains. I have to use the Special menu to delete it manually.

How can I stop this from happening? Or am I taking the wrong approach?

Thanks for all suggestions.

--Nancy

Views

207

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

1 Correct Answer

Adobe Community Professional , Apr 06, 2018
Barb Binder Adobe Community Professional , Apr 06, 2018
Hi Nancy:Thank you for sharing your file with me, I'll admit I was as baffled as you were—your settings matched mine but the behavior was quite different.I ended up taking notes on the frame size and position, deleted it, and recreated it with your exact same settings. Silly computers.I have no idea it wasn't working before, but glad to see that now it is. ~Barb

Likes

Translate

Translate
Jump to answer Jump to answer
Adobe Community Professional ,
Apr 04, 2018

Copy link to clipboard

Copied

I just keystroked it for you Nancy, and it works the way you want it to.

So, head back to the custom master:

  1. Select the top frame with the Object Selection Tool
  2. Graphics > Object Properties, and double check that Flow B has Auto-connect off (empty check box). Remember that checkboxes have three states: on, off and as is. 
    Screenshot 2018-04-04 13.26.26.png

  3. Then test again on the Body page:
    Screenshot 2018-04-04 13.27.50.png

~Barb

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Apr 05, 2018

Copy link to clipboard

Copied

Hi, Barb.

I have done just what you did, and I'm still having the same problem.  I thought maybe I was having a problem because I'd created Top from the default heading text box that is provided on the Right page of the Portrait template. I deleted it and created a new text box and assigned it as follows; your settings and mine are identical:

FlowBNotConnected.png

The body text frames are flow A and are autoconnected.

I double-checked and am still getting the same problem ON THE BODY PAGE:

  • On the Master page ("First"), if I enter too much text in Top, I get the black line as expected at the bottom of the text frame.
  • On the Body page to which the First master page has been applied, if the text overflows the "Top" textframe,  Framemaker adds a new body page 3, applying First to it, and pouring the overflow text into the Top textframe.

Is there some other element that accounts for the difference? Thanks very much for your help.

--Nancy

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 05, 2018

Copy link to clipboard

Copied

Hi Nancy:

Perhaps I misunderstood the original question.

"Top" is intended to be self-contained. I want it to be obvious to any writer using the template for the first time, so they know where to put the title and doc type information.  I tagged it separately as B, and did not autoconnect it. If a document title overflows the "Top" text box, I would expect to see a black line at the bottom of "Top" indicating that my text was too lengthy.

My first screen shot is the master, the second is the body—with the overset text. Here are larger screen shots that include the status bar so that you can see that for yourself:

Master Page (top frame settings are shown in my first reponse, bottom frame is using defaults):

Screenshot 2018-04-05 14.19.56.png;

Body Page 1 (I pasted twice as much text as is visible—it is overset, shows the black line and did not generate a second body page.

Screenshot 2018-04-05 14.19.41.png

That's what I thought you asked for. If I misunderstood, I hope you will accept my apology and the please clarify the question. If this is what you want and aren't getting it, please show me the object properties for both frames on the custom master, and what is happening on body page 1.

~Barb

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Apr 05, 2018

Copy link to clipboard

Copied

Oh, Barb, I'm afraid my all caps sounded like shouting. I should know better! I wrote that way because I realized I hadn't been clear, even in my own mind!

You've responded to my question exactly and I really appreciate it.  I don't know what accounts for the difference ...

Thank you again!

--Nancy

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 05, 2018

Copy link to clipboard

Copied

No worries! I'm not easily offended.

So is it working for you now? If not, please share the object properties. We can figure this out.

~Barb

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Explorer ,
Apr 06, 2018

Copy link to clipboard

Copied

Hi, Barb.

No, it's still not working. It behaves as described; if the text poured into the top textbox on page one overflows, FM inserts a new "First" page on page 3 of the document and pours the excess text into that Top textbox.

The object properties for Top are these:

TopObjectProperties.png

The properties for the body text frame for First, Left, and Right are identical:

LeftObjectProperties.png

--Nancy

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 06, 2018

Copy link to clipboard

Copied

Hi Nancy,

Those match my settings.

Can you share the template file—or if that worries you for any reason—just blank document with these settings on the master page?

If you are ok with that, put it on dropbox and post a link here (public) or hover over my name and message me (private).

~Barb

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Adobe Community Professional ,
Apr 06, 2018

Copy link to clipboard

Copied

Hi Nancy:

Thank you for sharing your file with me, I'll admit I was as baffled as you were—your settings matched mine but the behavior was quite different.

I ended up taking notes on the frame size and position, deleted it, and recreated it with your exact same settings. Silly computers.

I have no idea it wasn't working before, but glad to see that now it is.

~Barb

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
nancy33534756 AUTHOR LATEST
Explorer ,
Apr 06, 2018

Copy link to clipboard

Copied

Thank you! I have no idea what it was, either, but am delighted to have a working template!

--Nancy

Likes

Translate

Translate

Report

Report
Reply
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more