Highlighted

Turn off hyphenation for a single paragraph

Explorer ,
Dec 09, 2015

Copy link to clipboard

Copied

This seems so simple yet I cannot get it to work.

I click into the paragraph, then in the paragraph settings I deselect the "Hyphenate" check box and click "Apply". But nothing happens, the text is still hyphenated. I also tried the spelling feature to re-hyphenate the entire document (no idea how this is called in the English UI) but this does not help either.

This is a command line and has to be displayed without hyphenation. If I insert a forced line break (shift+return) then it looks fine but cannot be copied from the PDF in one piece because of the line feed.

By default, FrameMaker allows a linebreak if a hyphen falls at the end of a line. To prevent this, do one of the following:

  • Disallow line breaks after a hyphen:
    1. Choose Format > Document > Text Options
    2. Remove the hyphen from Allow Line Breaks After
    3. Click Apply

This applies to the entire document. You might want to make this setting for all files in your book.

  • Change the hyphen to a non-breaking hyphen (Esc hyphen h).

Note that if your users copy and paste the code or command, it will not work correctly.

Views

3.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Turn off hyphenation for a single paragraph

Explorer ,
Dec 09, 2015

Copy link to clipboard

Copied

This seems so simple yet I cannot get it to work.

I click into the paragraph, then in the paragraph settings I deselect the "Hyphenate" check box and click "Apply". But nothing happens, the text is still hyphenated. I also tried the spelling feature to re-hyphenate the entire document (no idea how this is called in the English UI) but this does not help either.

This is a command line and has to be displayed without hyphenation. If I insert a forced line break (shift+return) then it looks fine but cannot be copied from the PDF in one piece because of the line feed.

By default, FrameMaker allows a linebreak if a hyphen falls at the end of a line. To prevent this, do one of the following:

  • Disallow line breaks after a hyphen:
    1. Choose Format > Document > Text Options
    2. Remove the hyphen from Allow Line Breaks After
    3. Click Apply

This applies to the entire document. You might want to make this setting for all files in your book.

  • Change the hyphen to a non-breaking hyphen (Esc hyphen h).

Note that if your users copy and paste the code or command, it will not work correctly.

Views

3.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Dec 09, 2015 0
Adobe Community Professional ,
Dec 09, 2015

Copy link to clipboard

Copied

You can suppress hyphenation of a single word by putting the cursor at the start of the word and typing:
ECns
(EC is the Escape key).

I'd be tempted to create or spin-off a paragraph tag that has hyphenation disabled (and I'd expect it to work - no insight on why your override is failing).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 09, 2015 0
Advocate ,
Dec 09, 2015

Copy link to clipboard

Copied

You actually have to click twice. The first time you click, the check

mark disappears, but it is replaced by a shaded box. This is the setting

for "as is." Clicking again, clears the shading to leave and empty box,

turning off the feature. Then click apply.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 09, 2015 0
Explorer ,
Dec 10, 2015

Copy link to clipboard

Copied

No luck yet, here is a screenshot to show the problem (this is actually a paragraph in a table cell, in case it matters). The command line contains attributes preceded by "-" which evidently provokes a hyphenation even if it is turned off in the paragraph settings.

Bob, how was that other solution meant, I type escape and then sequentially the letters "n" and "s"? That has not worked out and inserts the last letter "s" as text.

hyph.png

P.S. I have also tried setting the language setting to "None" for the paragraph. But no luck either, when the text contains a dash ("-") FrameMaker automatically hyphenates.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 10, 2015 0
Contributor ,
Dec 10, 2015

Copy link to clipboard

Copied

By default, FrameMaker allows a linebreak if a hyphen falls at the end of a line. To prevent this, do one of the following:

  • Disallow line breaks after a hyphen:
    1. Choose Format > Document > Text Options
    2. Remove the hyphen from Allow Line Breaks After
    3. Click Apply

This applies to the entire document. You might want to make this setting for all files in your book.

  • Change the hyphen to a non-breaking hyphen (Esc hyphen h).

Note that if your users copy and paste the code or command, it will not work correctly.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 10, 2015 1
Explorer ,
Dec 10, 2015

Copy link to clipboard

Copied

EDIT: I was happy to soon. The result looks fine, but when generating the PDF Framemaker inserts a line feed which again prevents you from copy/pasting the command in one piece.

I'll mark your answer as correct and will open a separate thread, I suppose the mentioned line feeds are not related to hyphenation.

--

Mike, thanks for the hint I achieved a partial success that way. Both solutions result in the expression containing the dash to break into the next line completely (see screenshot). I would prefer FM not to treat this as a word but rather as a sequence of characters and just fill up the line, then continue the remaining characters on the next line. But having it like this is already much better.

hyph_2.png

BTW, I have to type Esc hyphen w instead of Esc hyphen h. Do they use different shortcuts for different UI languages (mine is set to German)?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 10, 2015 0
Contributor ,
Dec 11, 2015

Copy link to clipboard

Copied

For Unix command lines with multiple lines, you can add a backslash at the end of each line. This makes Unix concatenate the lines before interpreting them. For example this:

yum --enablerepo=sina-cd-* install \
  sina-mgmt_meta_all_in_one_*

will be interpreted as this:

yum --enablerepo=sina-cd-* install  sina-mgmt_meta_all_in_one_*

No idea on the keyboard shortcut, I'm afraid - but it wouldn't surprise me if they use different shortcuts for different UI languages.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 11, 2015 0
Rsfl LATEST
Explorer ,
Dec 14, 2015

Copy link to clipboard

Copied

Thanks for the idea, but the main problem is the line feed at the end of the line. If you copy the two lines you wrote and paste them (e.g. into the windows 'run' dialog), then only the first part will be pasted.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Dec 14, 2015 0