Highlighted

UI issues when you change the default font size on Windows

Community Beginner ,
Jul 24, 2015

Copy link to clipboard

Copied

I have somewhat limited vision which is especially bad with my high def monitor (2560x1440). Consequently, I set the size default in Windows (Change the size of text, apss and other items in Display Customization) to 125%. When I do this, FrameMaker does not properly draw toolbars or the status bar items on the bottom of the screen (like Zoom). Functionality works but you can wind up hitting the wrong buttom (like remove file instead of Update Book !). Document pages render fine.

Anyone have a solution to this problem? Setting Windows back to 100% makes it a lot harder for me to see.

This is not the only Adobe app that behaves badly but it is the worst of the ones I use regularly.

Thanks for help

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

UI issues when you change the default font size on Windows

Community Beginner ,
Jul 24, 2015

Copy link to clipboard

Copied

I have somewhat limited vision which is especially bad with my high def monitor (2560x1440). Consequently, I set the size default in Windows (Change the size of text, apss and other items in Display Customization) to 125%. When I do this, FrameMaker does not properly draw toolbars or the status bar items on the bottom of the screen (like Zoom). Functionality works but you can wind up hitting the wrong buttom (like remove file instead of Update Book !). Document pages render fine.

Anyone have a solution to this problem? Setting Windows back to 100% makes it a lot harder for me to see.

This is not the only Adobe app that behaves badly but it is the worst of the ones I use regularly.

Thanks for help

Views

1.1K

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Jul 24, 2015 0
Adobe Community Professional ,
Jul 24, 2015

Copy link to clipboard

Copied

re: ... high def monitor (2560x1440) ...

What is the screen diagonal size?

The problem isn't the raster size (pixel count), but the pixel pitch (dots per inch). I recommend 27 to 32 inch for FM use‌ at 1440p, and even 27 might be too tight for some eyes.

Windows, and apps for it, never really recovered from early hard-coded assumptions that screen resolution would be less than 100 dots per inch.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2015 0
Community Beginner ,
Jul 24, 2015

Copy link to clipboard

Copied

This is a 27-inch, NEC high-end monitor.

There are no hard-coded assumptions in Windows about resolution and there are several options for scaling elements when using these smaller pitch displays, all of which are queryable from applications. Unfortunately, Adobe knows best and does not follow UI guidelines nor accessibility guidelines for scaling UI elements. This is the only app that screws up the icon/button placement that I currently use. While Photoshop and Lightroom have their scaling challenges, this isn't something they screw up. C'mon - Frame has a drop down that lets you select 14 to 22-inch monitors? Really? Maybe I expect too much from a $1000 product but that could have been updated sometime in the last 10 years if it is supposed to account for scaling.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2015 0
Adobe Community Professional ,
Jul 24, 2015

Copy link to clipboard

Copied

I kvetched to the Bugbase yesterday about this & got back a suggestion which I haven’t time to try out yet.

They suggested - Disable scaling for FM : Right click FrameMaker.exe->Properties->Compatibility->check "Disable display scaling on high DPI settings" and then restart FM.

Give it buzz & see if it works for you (& let the rest of us know if it does)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2015 2
Community Beginner ,
Jul 24, 2015

Copy link to clipboard

Copied

Well, it has some effect. For example, the page display is now readable at 100% instead of having to always go to 120%. I will try to put the font scaling back to 125% and see if it works or not. Thanks.

Right now I have icon set to Large, although that made a minimal difference.

Thanks for the tip, I will try font scaling in Windows again and report back.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2015 0
Adobe Community Professional ,
Jul 24, 2015

Copy link to clipboard

Copied

I’m hoping when I test it that I can go back to the 150% setting I was running on pre-FM12 versions – my eyes don’t like 125% much

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2015 0
Community Beginner ,
Jul 24, 2015

Copy link to clipboard

Copied

OK, I can now use the Windows font scaling and it doesn't mess up Frame. Thanks so much! I also tried Photoshop and that's a bit better too (using the Large Font setting).

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2015 0
Adobe Community Professional ,
Jul 24, 2015

Copy link to clipboard

Copied

Cool – can’t wait to get back to the office to try it out ;>)

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2015 0
Adobe Community Professional ,
Jul 24, 2015

Copy link to clipboard

Copied

re: This is a 27-inch, NEC high-end monitor.

High end doesn't help. Any 27in 1440 monitor is 109 ppi, which is at the borderline for moldy content that assumes legacy monitor resolutions.

re: There are no hard-coded assumptions in Windows about resolution ...

Anymore, mostly, but that's why I said "early hard-coded".

re: ... and there are several options for scaling elements when using these smaller pitch displays, ...

Indeed, but the challenge there is that unless the display has at least 200 ppi, there are going to be visible scaling artifacts.

re: ... all of which are queryable from applications.

And that's the problem, as you point out. In any event, it appears that a work-around is at hand.

Meanwhile, anyone contemplating a 4K (3840x2160) display for FM probably needs to be looking at 41 inches or bigger. I wouldn't bet that Adobe will fix this before Microsoft manages to kill off desktop computing altogether.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 24, 2015 0
Adobe Community Professional ,
Jul 27, 2015

Copy link to clipboard

Copied

OK, that seems to have worked. Now all I need to do is test it via RDP when I'm working from home.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Jul 27, 2015 0
New Here ,
Mar 29, 2017

Copy link to clipboard

Copied

Thanks a bunch for this -- it worked for me! I'd call it a solution

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Mar 29, 2017 0
Adobe Employee ,
Apr 02, 2017

Copy link to clipboard

Copied

Meanwhile, anyone contemplating a 4K (3840x2160) display for FM probably needs to be looking at 41 inches or bigger. I wouldn't bet that Adobe will fix this before Microsoft manages to kill off desktop computing altogether.

FrameMaker (2017 release) comes with support for 4K screens including high-dpi / high definition screens and the UI scales automatically in steps based on the Windows Display scaling (100/150/200%).

I have FrameMaker 2017 running on a "retina" screen (15" / 2.880 × 1.800 / 220.53 PPI) and it looks great 🙂

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 02, 2017 1
Community Beginner ,
Oct 11, 2017

Copy link to clipboard

Copied

Hi, I just upgraded to FM 2017. I'm on Windows 10 using a big monitor, with these settings (see screenshot below):

It looks okay, but in fact the program is not usable, because the cursor jumps elsewhere when I try to click into a menu command. The Zoom - Default setting is no solution.

Any suggestions? thank you

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 11, 2017 0
Adobe Community Professional ,
Oct 13, 2017

Copy link to clipboard

Copied

Have you applied the latest patch? IIRC there was an issue with FM2017 that was fixed after release.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Oct 13, 2017 0