Highlighted

Update Book Changes Pagination Setting

Explorer ,
Feb 01, 2017

Copy link to clipboard

Copied

I am printing a book to PDF, and I keep seeing extra pages.

I have changed the pagination setting for Before Saving & Printing to "Delete Empty Pages", but when I click Update Book, FrameMaker changes the pagination for two chapters (of 11) back to "Make Page Count Even".

Does anyone know why it is doing that? And how I can stop it?

Most Valuable Participant
Correct answer by Arnis_Gubins | Most Valuable Participant

You're reading the starting page setting from the file, rather than letting the book set which page to start on  [hint: use Next Available]. So you're probably running into the scenario where those files are ending on the right and then next file is set to start on the right. In that situation, FM will always add an empty left.

Views

845

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Update Book Changes Pagination Setting

Explorer ,
Feb 01, 2017

Copy link to clipboard

Copied

I am printing a book to PDF, and I keep seeing extra pages.

I have changed the pagination setting for Before Saving & Printing to "Delete Empty Pages", but when I click Update Book, FrameMaker changes the pagination for two chapters (of 11) back to "Make Page Count Even".

Does anyone know why it is doing that? And how I can stop it?

Most Valuable Participant
Correct answer by Arnis_Gubins | Most Valuable Participant

You're reading the starting page setting from the file, rather than letting the book set which page to start on  [hint: use Next Available]. So you're probably running into the scenario where those files are ending on the right and then next file is set to start on the right. In that situation, FM will always add an empty left.

Views

846

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Feb 01, 2017 0
Most Valuable Participant ,
Feb 01, 2017

Copy link to clipboard

Copied

Are you setting the pagination controls at the file or book level? You should control how a book behaves at the book level and not rely on the settings in each component file.

If you have double-sided files, and you've specified your files (chapters?) to start on the right, then when you have these in a book, any file that ends on a right page, will automatically add a blank Left page, regardless of your setting to Delete Empty Pages. This is the way a physical book behaves. If you don't care if the chapters start on the right or left, then change your settings to ensure all files use the next available page. Then the Delete Empty Pages option will work.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2017 0
Explorer ,
Feb 01, 2017

Copy link to clipboard

Copied

I think I have Pagination set for no blank pages at both the book and chapter levels. Perhaps I am trying to do the book level wrong?

If I have just the book file selected, the Pagination option is grayed out in the Page Layout menu. I have tried having all of the chapters selected and applying the Pagination rule that way, but FM changes the files anyway.

Is there some other method I should be using?

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2017 0
Most Valuable Participant ,
Feb 01, 2017

Copy link to clipboard

Copied

In the Book file panel, select the component files and then right-click to get the context menu for selecting Pagination or Numbering. This will then apply the settings that you specify to all of the selected files.

Usually, one sets the first file [and perhaps the front matter numbering] separately and then the remaining files to continue from the previous behaviours as required.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2017 0
Explorer ,
Feb 01, 2017

Copy link to clipboard

Copied

Sounds like what I already did.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2017 0
Explorer ,
Feb 01, 2017

Copy link to clipboard

Copied

Followed those instructions. Two chapters were still reset to "Make Page Count Even".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2017 0
Most Valuable Participant ,
Feb 01, 2017

Copy link to clipboard

Copied

So then what are the pagination settings for the files in the Book view? They should be Next Available and Delete Empty pages.

book_pagination_a.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2017 0
Explorer ,
Feb 01, 2017

Copy link to clipboard

Copied

I have set both the book and the individual chapters to "Delete Empty Pages".

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2017 0
Most Valuable Participant ,
Feb 01, 2017

Copy link to clipboard

Copied

You're reading the starting page setting from the file, rather than letting the book set which page to start on  [hint: use Next Available]. So you're probably running into the scenario where those files are ending on the right and then next file is set to start on the right. In that situation, FM will always add an empty left.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2017 1
Explorer ,
Feb 01, 2017

Copy link to clipboard

Copied

Okay. I'll test that.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 01, 2017 0
New Here ,
Feb 25, 2020

Copy link to clipboard

Copied

This is happening to me also. I have Next Available and Delete Empty Pages set at the book level. I save the book and the .fm file. If I print the book at that point I'm ok. But when I update the book it resets back to Make Page Count Even. I have 20 fm files in this book and this is the only one that is giving me this issue.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 25, 2020 0
Engaged ,
Feb 26, 2020

Copy link to clipboard

Copied

From your screen capture, you chose "double sided"

I think that is why it is adding the extra pages.

Try choosing single sided.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Feb 26, 2020 0