Highlighted

Why won't "medium" hyphenate

Explorer ,
Apr 06, 2017

Copy link to clipboard

Copied

I am converting a manual from InDesign to FrameMaker. To get the text in FM, all of the text is exported from InDesign to text only, and it is copied from there and pasted into FM.

Now and then there are soft line breaks that I need to delete. This is what I was doing within the word "medium" when I hit the delete one too many times.

Now it seems I have taught FM never to hyphenate the word medium.

It is still hyphenated in the Spelling dialog screen. Here's what I've tried to fix it:

  1. I've tried re-applying hyphenation (several times) to no avail.
  2. I've tried deleting the word medium and retyping it
  3. I've tried adding "me-di-um" to the site dictionary and applying hyphenation again
  4. I've tried closing the file and reopening and reapplying hyphenation again
  5. I set Personal dictionary to None
  6. I cleared the Document dictionary

I'm out of ideas. It's a three-column document, so it's important.

Anyone know what I am missing?

Thanks!!

Views

273

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more

Why won't "medium" hyphenate

Explorer ,
Apr 06, 2017

Copy link to clipboard

Copied

I am converting a manual from InDesign to FrameMaker. To get the text in FM, all of the text is exported from InDesign to text only, and it is copied from there and pasted into FM.

Now and then there are soft line breaks that I need to delete. This is what I was doing within the word "medium" when I hit the delete one too many times.

Now it seems I have taught FM never to hyphenate the word medium.

It is still hyphenated in the Spelling dialog screen. Here's what I've tried to fix it:

  1. I've tried re-applying hyphenation (several times) to no avail.
  2. I've tried deleting the word medium and retyping it
  3. I've tried adding "me-di-um" to the site dictionary and applying hyphenation again
  4. I've tried closing the file and reopening and reapplying hyphenation again
  5. I set Personal dictionary to None
  6. I cleared the Document dictionary

I'm out of ideas. It's a three-column document, so it's important.

Anyone know what I am missing?

Thanks!!

Views

274

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Apr 06, 2017 0
Adobe Community Professional ,
Apr 06, 2017

Copy link to clipboard

Copied

Did you try a discretionary hyphen (aka soft hyphen)? Cntl+hyphen where you want to word to hyphenate.

Also are there hyphens on the preceding lines? Max adjacent defaults to 2, as I recall. You may need to up that number in the ¶ Designer.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2017 0
Adobe Community Professional ,
Apr 06, 2017

Copy link to clipboard

Copied

Share a screen shot if neither works.

And Diane, are you removing the line breaks manually? You can search for \r and replace with a space, and then remove the double spaces with:

VMware Fusionss_001.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2017 0
Explorer ,
Apr 06, 2017

Copy link to clipboard

Copied

It's not Friday yet so don't laugh at this question: isn't the hyphen key the minus key?? When I do cntrl+minus key FM puts some kind of a reference marker in the doc instead of a discretionary hyphen. (Unless that's what the reference marker is.)

Also - if I add a discretionary hyphen, does FM leave it there regardless of how content is edited in the future? I don't want to add a hyphen that won't adjust with changing content.

Thanks Barb!

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2017 0
Adobe Community Professional ,
Apr 06, 2017

Copy link to clipboard

Copied

Hi Diane:

First of all, did it work? Or was it because of the hyphenation settings? Max # Adjacent is always my go to when a word isn't hyphenating. Oh wait. Shortest prefix is 3. Me-di-um. 2-2-2. That's why!

VMware Fusionss_003.png

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2017 0
Adobe Community Professional ,
Apr 06, 2017

Copy link to clipboard

Copied

Anyway! To answer your question it does put a symbol in (an overline, not a marker) that tells FrameMaker that this is your preferred place for hyphenation. It only comes into play when Fm is looking to hyphenate the word. It will ignore it otherwise.

Another related command I use all time is Esc n s in front of the word that I do not want to hyphenate. Same deal, it only kicks in when Fm is considering hyphenating the word. Otherwise it is ignored.

Finally, you can use Esc - h to add a non-breaking hyphen (it shows up as a hyphen but it not allowed at the end of a line).

Who knew there could be so many hyphens!

P.S. For anyone reading this down the road, I work on a Mac and some keys don't work the same as they do in a normal Windows environment. I can't use Ctrl+- for the discretionary hyphen, I need to use the alternative: Esc - D.

Likes

Translate

Translate

Report

Report
Community Guidelines
Be kind and respectful, give credit to the original source of content, and search for duplicates before posting. Learn more
Reply
Loading...
Apr 06, 2017 0